(address . guix-patches@gnu.org)(name . Fries)(address . fries1234@protonmail.com)
* gnu/packages/golang.scm (go-github-com-felixge-fgprof): Add variable.
---
gnu/packages/golang.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
Toggle diff (43 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9f5ef95b82..208b88d934 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2113,6 +2113,36 @@ (define-public go-github-com-dhowett-go-plist
types.")
(license license:giftware))))
+(define-public go-github-com-felixge-fgprof
+ (package
+ (name "go-github-com-felixge-fgprof")
+ (version "0.9.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/felixge/fgprof")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03q3vnjd13r944y2qvfncs21lfkgmg0y8z14zz0xda1hz490wha3"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/felixge/fgprof"
+ #:phases (modify-phases %standard-phases
+ ;; The tests fails randomly.
+ (delete 'check))))
+ (propagated-inputs
+ `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
+ ("go-github-com-google-pprof" ,go-github-com-google-pprof)))
+ (home-page "https://github.com/felixge/fgprof")
+ (synopsis "The Full Go Profiler")
+ (description
+ "Fgprof is a sampling Go profiler that allows you to analyze On-CPU as well as
+@uref{https://www.brendangregg.com/offcpuanalysis.html,Off-CPU} (e.g. I/O) time
+together.")
+ (license license:expat)))
+
(define-public go-github-com-google-pprof
(package
(name "go-github-com-google-pprof")
--
2.41.0