(address . guix-patches@gnu.org)(name . Fries)(address . fries1234@protonmail.com)
* gnu/packages/golang.scm (go-github-com-chyzer-test): New variable.
---
gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
Toggle diff (39 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d99f76dc7d..ef82f0aa1b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2113,6 +2113,32 @@ (define-public go-github-com-dhowett-go-plist
types.")
(license license:giftware))))
+(define-public go-github-com-chzyer-test
+ (package
+ (name "go-github-com-chzyer-test")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chzyer/test")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1axdlcnx2qjsn5wsr2pr1m0w0a8k4nk5kkrngh742fgh81vzzy8s"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/chzyer/test"
+ #:phases
+ ;; Tests relating to a in-memory disk fail due to a Segfault.
+ (modify-phases %standard-phases
+ (delete 'check))))
+ (propagated-inputs `(("go-github-com-chzyer-logex" ,go-github-com-chzyer-logex)))
+ (home-page "https://github.com/chzyer/test")
+ (synopsis "Testing")
+ (description "Testing library.")
+ (license license:expat)))
+
(define-public go-github-com-chzyer-logex
(package
(name "go-github-com-chzyer-logex")
--
2.41.0