[PATCH] gnu: Add emacs-fedi.

  • Open
  • quality assurance status badge
Details
One participant
  • Cayetano Santos
Owner
unassigned
Submitted by
Cayetano Santos
Severity
normal
C
C
Cayetano Santos wrote 14 hours ago
(address . guix-patches@gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
52458f3c4ee6ad72276e6eccd1dbd5e13631d9aa.1737116650.git.csantosb@inventati.org
* gnu/packages/emacs-xyz.scm (emacs-fedi): New variable.

Change-Id: Icfcb92e9e57e060390c14389c748567fa809a6cb
---
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9e99bad820..9eb38db85d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -36070,6 +36070,27 @@ (define-public emacs-mastodon
federated microblogging social network.")
(license license:gpl3+)))
+(define-public emacs-fedi
+ (package
+ (name "emacs-fedi")
+ (version "0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/martianh/fedi.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0a5zq7axxh3khx6465s7ym9s7v2iw7ky9z486d0zg41k7926bm9d"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-markdown-mode))
+ (home-page "https://codeberg.org/martianh/fedi.el")
+ (synopsis "Library to make writing clients for APIs easier")
+ (description "@code{fedi.el} is an Emacs library used by several fediverse
+frontend packages.")
+ (license license:gpl3+)))
+
(define-public emacs-ebdb
(package
(name "emacs-ebdb")

base-commit: f0804b0c2253542e9f0e255fbf8dc5847bba919d
--
2.47.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75630@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75630
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch