[PATCH] gnu: solfege: Build and install manual.

  • Open
  • quality assurance status badge
Details
One participant
  • iyzsong
Owner
unassigned
Submitted by
iyzsong
Severity
normal
I
I
iyzsong wrote 19 hours ago
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
5e2b57ba3eb681435755cb2a0c25a5cea143a10a.1737097498.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

* gnu/packages/music.scm (solfege)[arguments]: Add 'build-manual
phase. Pass "--enable-docbook-stylesheet" to configure-flags.
[native-inputs]: Add docbook-xsl, docbook-xml-4.1.2, itstool and libxslt.

Change-Id: Icef6c393e1d4c6413e53ef9de9ffc16d5e973a94
---
gnu/packages/music.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index f3fbe76fff..eeee00871d 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2206,6 +2206,13 @@ (define-public solfege
(list
#:tests? #f ;xmllint attempts to download DTD
#:test-target "test"
+ #:configure-flags
+ #~(list (string-append "--enable-docbook-stylesheet="
+ #$(this-package-native-input "docbook-xsl")
+ "/xml/xsl/"
+ #$(package-name docbook-xsl) "-"
+ #$(package-version docbook-xsl)
+ "/html/chunk.xsl"))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'set-version
@@ -2250,6 +2257,9 @@ (define-public solfege
(substitute* "run-solfege.py"
(("prefix = os.path.*$")
(string-append "prefix = " #$output)))))
+ (add-after 'build 'build-manual
+ (lambda _
+ (invoke "make" "update-manual")))
(add-after 'install 'wrap-program
(lambda* (#:key outputs #:allow-other-keys)
;; Make sure 'solfege' runs with the correct PYTHONPATH.
@@ -2274,6 +2284,10 @@ (define-public solfege
pkg-config
txt2man
libxml2 ; for tests
+ docbook-xsl ; for manual
+ docbook-xml-4.1.2
+ itstool
+ libxslt
ghostscript
texinfo))
(home-page "https://www.gnu.org/software/solfege/")

base-commit: cd12fa4e2051925eaa9833035fef019315c4b721
--
2.47.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75624@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75624
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch