[PATCH] gnu: emacs-ruby-electric: Update to 2.3.3-0.c53376d.

  • Open
  • quality assurance status badge
Details
One participant
  • gemmaro
Owner
unassigned
Submitted by
gemmaro
Severity
normal
G
G
gemmaro wrote 21 hours ago
(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
9824fedb2a2a23c89690da4f26665b268c77649c.1737090773.git.gemmaro.dev@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-ruby-electric): Update to 2.3.3-0.c53376d.

Change-Id: I40c21d89cec9be7eafb185958eecbf56f44dda4c
---
gnu/packages/emacs-xyz.scm | 40 ++++++++++++++++++++------------------
1 file changed, 21 insertions(+), 19 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9e99bad820..d1e686ce90 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -141,7 +141,7 @@
;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
;;; Copyright © 2024 Noé Lopez <noelopez@free.fr>
-;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2024, 2025 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2024 Daniel Szmulewicz <daniel.szmulewicz@gmail.com>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
@@ -13999,26 +13999,28 @@ (define-public emacs-request
(license license:gpl3+))))
(define-public emacs-ruby-electric
- (package
- (name "emacs-ruby-electric")
- (version "2.3.3")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ruby/elisp-ruby-electric")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1p0l0fsn0jcgb4raimyc4d1wpfksrfhn0rkwdazadvm6s8baydf7"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/ruby/elisp-ruby-electric")
- (synopsis "Minor mode for electrically editing Ruby code")
- (description
- "Ruby Electric mode accelerates code writing in Ruby by making some keys
+ (let ((revision "0")
+ (commit "c53376da891713e0c49f01aad2ff64d4fbb0b812"))
+ (package
+ (name "emacs-ruby-electric")
+ (version (git-version "2.3.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ruby/elisp-ruby-electric")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14grv2gwr6lyjlcp8h1frvipyisakkw2q0jpv4h5rd5bzky7m8w0"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/ruby/elisp-ruby-electric")
+ (synopsis "Minor mode for electrically editing Ruby code")
+ (description
+ "Ruby Electric mode accelerates code writing in Ruby by making some keys
electric and automatically supplying with closing parentheses and @code{end}
as appropriate.")
- (license license:ruby)))
+ (license license:ruby))))
(define-public emacs-rudel
(package

base-commit: 0b06a5bc97938cae3da19e566c2f6f71cc299d78
--
2.47.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75621@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75621
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch