(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
* gnu/packages/cran.scm (r-optimparallel): New variable.
Change-Id: Id2615f15090036c21754b399e897086c06a38c4f
---
gnu/packages/cran.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7489954875..410de79ecf 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -27716,6 +27716,34 @@ (define-public r-bookdown
authoring books and technical documents with R Markdown.")
(license license:gpl3)))
+(define-public r-optimparallel
+ (package
+ (name "r-optimparallel")
+ (version "1.0-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "optimParallel" version))
+ (sha256
+ (base32 "178ayfaivkbxkghxbg97lx4gl27kxkmgaaw9y8q5206r4cncd6qg"))))
+ (properties `((upstream-name . "optimParallel")))
+ (build-system r-build-system)
+ (arguments
+ (list
+ #:phases '(modify-phases %standard-phases
+ (add-after 'unpack 'set-HOME
+ (lambda _
+ (setenv "HOME" "/tmp"))))))
+ (native-inputs (list r-numderiv r-r-rsp r-testthat))
+ (home-page "https://github.com/florafauna/optimParallel-R")
+ (synopsis "Parallel version of the L-BFGS-B optimization method")
+ (description
+ "This toole provides a parallel version of the L-BFGS-B method of @code{optim()}.
+The main function of the package is @code{optimParallel()}, which has the
+same usage and output as @code{optim()}. Using @code{optimParallel()}
+can significantly reduce the optimization time.")
+ (license license:gpl2+)))
+
(define-public r-options
(package
(name "r-options")
base-commit: 7aae0e2c159b1612b405a372b18f25fbb58f9d82
--
2.43.0