python-pytorch build failure due to libgpg-error update

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Rostislav Svoboda
Owner
unassigned
Submitted by
Rostislav Svoboda
Severity
normal

Debbugs page

Rostislav Svoboda wrote 2 months ago
CAEtmmez=E0+eGkgZudw+DkhHAyXR1RPrbFfWf8Mpd9qiLHon2w@mail.gmail.com
Hello, the following commit:
eec2c5d6a7 2024-12-29 gnu: libgpg-error: Update to 1.51.
causes guix build python-pytorch to fail. Below are the last few lines
from the build log; the full build log is attached.

Cheers,
Bost


cd /tmp/guix-build-eigen-3.4.0.drv-0/build/test &&
/gnu/store/78wn2hb9q46xg5pa4m2zvigs3n4nqznw-cmake-minimal-3.24.2/bin/cmake
-E cmake_link_script CMakeFiles/mixingtypes_6.dir/link.txt --verbose=1
/gnu/store/86fc8bi3mciljxz7c79jx8zr4wsx7xw8-gcc-11.4.0/bin/c++
-std=c++03 -pedantic -Wall -Wextra -Wundef -Wcast-align
-Wchar-subscripts -Wnon-virtual-dtor -Wunused-local-typedefs
-Wpointer-arith -Wwrite-strings -Wformat-security -Wlogical-op
-Wenum-conversion -Wdouble-promotion -Wshadow -Wno-psabi
-Wno-variadic-macros -Wno-long-long -fno-check-new -fno-common
-fstrict-aliasing -ansi -O3 -DNDEBUG
CMakeFiles/mixingtypes_6.dir/mixingtypes.cpp.o -o mixingtypes_6
make[3]: Leaving directory '/tmp/guix-build-eigen-3.4.0.drv-0/build'
[ 21%] Built target mixingtypes_6
[ 21%] Linking CXX executable mixingtypes_3
cd /tmp/guix-build-eigen-3.4.0.drv-0/build/test &&
/gnu/store/78wn2hb9q46xg5pa4m2zvigs3n4nqznw-cmake-minimal-3.24.2/bin/cmake
-E cmake_link_script CMakeFiles/mixingtypes_3.dir/link.txt --verbose=1
/gnu/store/86fc8bi3mciljxz7c79jx8zr4wsx7xw8-gcc-11.4.0/bin/c++
-std=c++03 -pedantic -Wall -Wextra -Wundef -Wcast-align
-Wchar-subscripts -Wnon-virtual-dtor -Wunused-local-typedefs
-Wpointer-arith -Wwrite-strings -Wformat-security -Wlogical-op
-Wenum-conversion -Wdouble-promotion -Wshadow -Wno-psabi
-Wno-variadic-macros -Wno-long-long -fno-check-new -fno-common
-fstrict-aliasing -ansi -O3 -DNDEBUG
CMakeFiles/mixingtypes_3.dir/mixingtypes.cpp.o -o mixingtypes_3
make[3]: Leaving directory '/tmp/guix-build-eigen-3.4.0.drv-0/build'
[ 21%] Built target mixingtypes_3
make[2]: Leaving directory '/tmp/guix-build-eigen-3.4.0.drv-0/build'
make[1]: *** [CMakeFiles/Makefile2:3501: CMakeFiles/buildtests.dir/rule] Error 2
make[1]: Leaving directory '/tmp/guix-build-eigen-3.4.0.drv-0/build'
make: *** [Makefile:182: buildtests] Error 2
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("buildtests"
"-j24") exit-status: 2 term-signal: #f stop-signal: #f>
phase `check' failed after 92.2 seconds
command "make" "buildtests" "-j24" failed with status 2
build process 18 exited with status 256
builder for `/gnu/store/1dcg3vfmib2f63jib57g4hvj2k6cbf8i-eigen-3.4.0.drv'
failed with exit code 1
build of /gnu/store/1dcg3vfmib2f63jib57g4hvj2k6cbf8i-eigen-3.4.0.drv failed
View build log at
'/var/log/guix/drvs/1d/cg3vfmib2f63jib57g4hvj2k6cbf8i-eigen-3.4.0.drv.gz'.
cannot build derivation
`/gnu/store/92k9v3rdympz3djzayr67riah6axd5qq-python-pytorch-2.4.0.drv':
1 dependencies couldn't be built
guix build: error: build of
`/gnu/store/92k9v3rdympz3djzayr67riah6axd5qq-python-pytorch-2.4.0.drv'
failed
Ludovic Courtès wrote 1 months ago
(name . Rostislav Svoboda)(address . rostislav.svoboda@gmail.com)(address . 75589-done@debbugs.gnu.org)
871pwca1kv.fsf@gnu.org
Hi!

Rostislav Svoboda <rostislav.svoboda@gmail.com> skribis:

Toggle quote (5 lines)
> Hello, the following commit:
> eec2c5d6a7 2024-12-29 gnu: libgpg-error: Update to 1.51.
> causes guix build python-pytorch to fail. Below are the last few lines
> from the build log; the full build log is attached.

[...]

Toggle quote (40 lines)
> cd /tmp/guix-build-eigen-3.4.0.drv-0/build/test &&
> /gnu/store/78wn2hb9q46xg5pa4m2zvigs3n4nqznw-cmake-minimal-3.24.2/bin/cmake
> -E cmake_link_script CMakeFiles/mixingtypes_6.dir/link.txt --verbose=1
> /gnu/store/86fc8bi3mciljxz7c79jx8zr4wsx7xw8-gcc-11.4.0/bin/c++
> -std=c++03 -pedantic -Wall -Wextra -Wundef -Wcast-align
> -Wchar-subscripts -Wnon-virtual-dtor -Wunused-local-typedefs
> -Wpointer-arith -Wwrite-strings -Wformat-security -Wlogical-op
> -Wenum-conversion -Wdouble-promotion -Wshadow -Wno-psabi
> -Wno-variadic-macros -Wno-long-long -fno-check-new -fno-common
> -fstrict-aliasing -ansi -O3 -DNDEBUG
> CMakeFiles/mixingtypes_6.dir/mixingtypes.cpp.o -o mixingtypes_6
> make[3]: Leaving directory '/tmp/guix-build-eigen-3.4.0.drv-0/build'
> [ 21%] Built target mixingtypes_6
> [ 21%] Linking CXX executable mixingtypes_3
> cd /tmp/guix-build-eigen-3.4.0.drv-0/build/test &&
> /gnu/store/78wn2hb9q46xg5pa4m2zvigs3n4nqznw-cmake-minimal-3.24.2/bin/cmake
> -E cmake_link_script CMakeFiles/mixingtypes_3.dir/link.txt --verbose=1
> /gnu/store/86fc8bi3mciljxz7c79jx8zr4wsx7xw8-gcc-11.4.0/bin/c++
> -std=c++03 -pedantic -Wall -Wextra -Wundef -Wcast-align
> -Wchar-subscripts -Wnon-virtual-dtor -Wunused-local-typedefs
> -Wpointer-arith -Wwrite-strings -Wformat-security -Wlogical-op
> -Wenum-conversion -Wdouble-promotion -Wshadow -Wno-psabi
> -Wno-variadic-macros -Wno-long-long -fno-check-new -fno-common
> -fstrict-aliasing -ansi -O3 -DNDEBUG
> CMakeFiles/mixingtypes_3.dir/mixingtypes.cpp.o -o mixingtypes_3
> make[3]: Leaving directory '/tmp/guix-build-eigen-3.4.0.drv-0/build'
> [ 21%] Built target mixingtypes_3
> make[2]: Leaving directory '/tmp/guix-build-eigen-3.4.0.drv-0/build'
> make[1]: *** [CMakeFiles/Makefile2:3501: CMakeFiles/buildtests.dir/rule] Error 2
> make[1]: Leaving directory '/tmp/guix-build-eigen-3.4.0.drv-0/build'
> make: *** [Makefile:182: buildtests] Error 2
> error: in phase 'check': uncaught exception:
> %exception #<&invoke-error program: "make" arguments: ("buildtests"
> "-j24") exit-status: 2 term-signal: #f stop-signal: #f>
> phase `check' failed after 92.2 seconds
> command "make" "buildtests" "-j24" failed with status 2
> build process 18 exited with status 256
> builder for `/gnu/store/1dcg3vfmib2f63jib57g4hvj2k6cbf8i-eigen-3.4.0.drv'
> failed with exit code 1

Note that it’s Eigen, not PyTorch itself that fails to build. We’re
missing the actual error message (perhaps if we scrolled up we’d see
a “No space left on device” error message because those C++ test
programs in Eigen take quite a bit of space) but it’s unlikely that it’s
due to libgpg-error because they’re only remotely connected:

Toggle snippet (11 lines)
$ guix graph --path python-pytorch libgpg-error
python-pytorch@2.5.1
python-expecttest@0.2.1-0.683b09a
poetry@1.8.4
python-dulwich@0.21.7
gnupg@2.4.7
libgpg-error@1.51
$ guix graph --path eigen libgpg-error
guix graph: error: no path from 'eigen@3.4.0' to 'libgpg-error@1.51'

The good news is that ‘python-pytorch’ is available right now:

Toggle snippet (18 lines)
$ guix weather python-pytorch
computing 1 package derivations for x86_64-linux...
looking for 1 store items on https://ci.guix.gnu.org...
https://ci.guix.gnu.org ☀
100.0% substitutes available (1 out of 1)
at least 100.9 MiB of nars (compressed)
263.1 MiB on disk (uncompressed)
2.817 seconds per request (2.8 seconds in total)
0.4 requests per second
^C
$ guix describe
Generation 335 Feb 04 2025 19:46:37 (current)
guix 9366217
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: 9366217997d759a4150cf5e44d83b947ac2028ab

Closing!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 75589@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75589
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help