[PATCH] gnu: kakoune: Add search path

  • Open
  • quality assurance status badge
Details
One participant
  • ingar
Owner
unassigned
Submitted by
ingar
Severity
normal

Debbugs page

ingar wrote 2 months ago
(address . guix-patches@gnu.org)
5h10okukiukqmc2uhgpwfkf3sw@onionmail.info
* gnu/packages/text-editors.scm (kakoune): Add KAKOUNE_RUNTIME to search
paths. This is needed to eg. package plugins, or to have a stable target
for the symlink inside `${userconf}/autoload` to `@{runtime}/autoload`
(see Kakoune manual).

Change-Id: I55a48696f20e13499206b573a9b07895250d791c
---
This is my first contribution... If I forgot any guidelines, let me know!
This patch would prepare the way for some kakoune plugin packages, but I'll
first consult the guix-devel mailing list to see if & how that is alright.
This patch should be nonetheless useful on its own.

gnu/packages/text-editors.scm | 5 +++++
1 file changed, 5 insertions(+)

Toggle diff (20 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 1fde977dff..9bda9f61c6 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -366,6 +366,11 @@ (define-public kakoune
"\";\n " line)))))
(delete 'configure)))) ; no configure script
(native-inputs (list pkg-config))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "KAKOUNE_RUNTIME")
+ (separator #f) ;pretty sure kakoune can handle only 1 runtime dir
+ (files (list "share/kak")))))
(synopsis "Vim-inspired code editor")
(description
"Kakoune is a code editor heavily inspired by Vim, as such most of its

base-commit: 21574796e98f897d86a0909e31fbb321ebb6e399
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75575@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75575
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help