[PATCH] gnu: Add emacs-orgit-forge.

  • Open
  • quality assurance status badge
Details
One participant
  • Arjan Adriaanse
Owner
unassigned
Submitted by
Arjan Adriaanse
Severity
normal
A
A
Arjan Adriaanse wrote 3 days ago
(address . guix-patches@gnu.org)(name . Arjan Adriaanse)(address . arjan@adriaan.se)
04e6dd72b7cf1742fd2aa588c63b2c2e191bd28f.1736888242.git.arjan@adriaan.se
* gnu/packages/emacs-xyz.scm (emacs-orgit-forge): New variable.

Change-Id: If1f354218c700dac11376f5581816d67381e058d
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 160015c1b5..9a48599cad 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -151,6 +151,7 @@
;;; Copyright © 2024 aurtzy <aurtzy@gmail.com>
;;; Copyright © 2024 Olivier Rojon <o.rojon@posteo.net>
;;; Copyright © 2024 Divya Ranjan Pattanaik <divya@subvertising.org>
+;;; Copyright © 2025 Arjan Adriaanse <arjan@adriaan.se>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32385,6 +32386,33 @@ (define-public emacs-orgit
@code{org-insert-link}.")
(license license:gpl3+)))
+(define-public emacs-orgit-forge
+ (package
+ (name "emacs-orgit-forge")
+ (version "1.0.0")
+ (home-page "https://github.com/magit/orgit-forge")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xcv7kqsrv39rk8fjd2sbl2wrr8mdb6y1xipifki4q7mry1c6v6w"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-compat
+ emacs-forge
+ emacs-magit
+ emacs-org
+ emacs-orgit))
+ (synopsis "Org links to Forge issue buffers")
+ (description
+ "This package defines the Org link type @code{orgit-topic}, which can be
+used to link to Forge topic buffers.")
+ (license license:gpl3+)))
+
(define-public emacs-amx
(package
(name "emacs-amx")

base-commit: f9277af3affaea400e759ff35e6950a867de231c
--
2.47.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75565@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75565
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch