[PATCH] gnu: tree-sitter-clojure: Update to 0.0.13.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ian Eure
  • Roman Scherer
Owner
unassigned
Submitted by
Roman Scherer
Severity
normal

Debbugs page

Roman Scherer wrote 2 months ago
(address . guix-patches@gnu.org)(name . Roman Scherer)(address . roman@burningswell.com)
980ce040fa2c057ec0db511056ea6f5971398c72.1736861713.git.roman@burningswell.com
* gnu/packages/tree-sitter.scm (tree-sitter-clojure): Update to 0.0.13.

Change-Id: If12e1a32744a2ecec3774303ccbba2032e2b0855
---
gnu/packages/tree-sitter.scm | 18 +++++++++++++++---
1 file changed, 15 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index 1fcc5533c9..16c0ccec13 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -596,9 +596,21 @@ (define-public tree-sitter-ungrammar
(define-public tree-sitter-clojure
(tree-sitter-grammar
"clojure" "Clojure"
- "0bgd9g1j4ww45g0l0aa1jac49421z95cc2rhcgqmgx7nzn94rszp"
- "0.0.11"
- #:repository-url "https://github.com/sogaiu/tree-sitter-clojure"))
+ "1j41ba48sid6blnfzn6s9vsl829qxd86lr6yyrnl95m42x8q5cx4"
+ "0.0.13"
+ #:repository-url "https://github.com/sogaiu/tree-sitter-clojure"
+ #:get-cleanup-snippet
+ (lambda (grammar-directories)
+ #~(begin
+ (use-modules (guix build utils))
+ (for-each
+ (lambda (lang)
+ (with-directory-excursion lang
+ (delete-file "src/grammar.json")
+ (delete-file "src/node-types.json")
+ (delete-file "src/parser.c")
+ (delete-file-recursively "src/tree_sitter")))
+ '#$grammar-directories)))))
(define-public tree-sitter-markdown
;; No tags

base-commit: c2532d05a52a826223a5659d104bf7d73af3e396
--
2.47.1
Ian Eure wrote 3 weeks ago
(name . Roman Scherer)(address . roman@burningswell.com)
871pvwjvgv.fsf@retrospec.tv
Pushed as 53a77c096d.

Thanks,
-- Ian
Ian Eure wrote 3 weeks ago
control message for bug #75556
(address . control@debbugs.gnu.org)
87zfikigw9.fsf@retrospec.tv
close 75556
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75556@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75556
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help