[PATCH 0/2] Add bsnes-hd / libretro-bsnes-hd

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal

Debbugs page

Maxim Cournoyer wrote 2 months ago
(address . guix-patches@gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
cover.1736781446.git.maxim.cournoyer@gmail.com
Yet another SNES emulator option.

Maxim Cournoyer (2):
gnu: Add bsnes-hd.
gnu: Add libretro-bsnes-hd.

gnu/packages/emulators.scm | 55 +++++++++++++++++++++++++++++++++++++-
1 file changed, 54 insertions(+), 1 deletion(-)


base-commit: 8c11f8740a52339f51fe1841658e8e549589f2e2
--
2.47.1
Maxim Cournoyer wrote 2 months ago
[PATCH 1/2] gnu: Add bsnes-hd.
(address . 75537@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
d362ca9c08ffc836a88243a731e0894f682ac03b.1736781774.git.maxim.cournoyer@gmail.com
* gnu/packages/emulators.scm (bsnes-hd): New variable.

Change-Id: Id3654e1231e24084e219c4d060eff2b4d888f62d
---
gnu/packages/emulators.scm | 42 +++++++++++++++++++++++++++++++++++++-
1 file changed, 41 insertions(+), 1 deletion(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index b65c91cdf5..5a2ac8846f 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2020 Christopher Howard <christopher@librehacker.com>
;;; Copyright © 2021 Felipe Balbi <balbi@kernel.org>
;;; Copyright © 2021, 2024 Felix Gruber <felgru@posteo.net>
-;;; Copyright © 2021, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021, 2025 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2023 c4droid <c4droid@foxmail.com>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
@@ -3190,6 +3190,46 @@ (define-public bsnes
performance, features, and ease of use.")
(license license:gpl3)))
+(define-public bsnes-hd
+ (package
+ (inherit bsnes)
+ (name "bsnes-hd")
+ ;; As of 10.6, there only ever was beta releases -- treat these as the
+ ;; stable releases for now.
+ (version "10.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DerKoun/bsnes-hd")
+ (commit (string-append
+ "beta_"
+ (string-replace-substring version "." "_")))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0f3cd89fd0lqskzj98cc1pzmdbscq0psdjckp86w94rbchx7iw4h"))))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/DerKoun/bsnes-hd/")
+ (synopsis "Fork of bsnes with added HD video features")
+ (description "bsnes-hd (called ``HD Mode 7 mod, for bsnes'' in early
+betas) is a fork of bsnes (the great SNES emulator by Near) that adds HD video
+features, such as:
+@table @asis
+@item HD Mode 7
+Renders the rotated, scaled or pseudo perspective backgrounds at
+higher resolutions. This does not involve new custom imagery or upscaling
+algorithms. It is a higher resolution version of the process the SNES uses.
+@item Widescreen
+Extends the scenes to the left and right, without distorting them. It works
+for most Mode 7 scenes, but also for some other scenes/games, after some
+settings tweaking.
+@item True color
+Color calculation are done at true color instead of the SNES color depth (3x8
+instead of 3x5 bit). With the optional line color smoothing color ``steps''
+turn into actual gradients (without influencing the sharpness of the artwork).
+@end table")
+ (license license:gpl3+)))
+
(define-public jg-api
(package
(name "jg-api")
--
2.47.1
Maxim Cournoyer wrote 2 months ago
[PATCH 2/2] gnu: Add libretro-bsnes-hd.
(address . 75537@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
f7232e1a0e2cdf142f682fb14ee5787378a5d328.1736781774.git.maxim.cournoyer@gmail.com
* gnu/packages/emulators.scm (libretro-bsnes-hd): New variable.

Change-Id: Ibb99d4f027530d5dc812c1cdbc22ad9d972234e5
---
gnu/packages/emulators.scm | 15 +++++++++++++++
1 file changed, 15 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 5a2ac8846f..1c8f66c924 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -3230,6 +3230,21 @@ (define-public bsnes-hd
@end table")
(license license:gpl3+)))
+(define-public libretro-bsnes-hd
+ (package/inherit bsnes-hd
+ (name "libretro-bsnes-hd")
+ (arguments
+ (substitute-keyword-arguments (package-arguments bsnes-hd)
+ ((#:make-flags flags ''())
+ #~(cons "target=libretro" #$flags))
+ ((#:phases phases '%standard-phases)
+ #~(modify-phases #$phases
+ (replace 'install ;no install target
+ (lambda _
+ (install-file "bsnes/out/bsnes_hd_beta_libretro.so"
+ (string-append #$output "/lib/libretro/"))))))))
+ (synopsis "Libretro port of bsnes-hd")))
+
(define-public jg-api
(package
(name "jg-api")
--
2.47.1
宋文武 wrote 2 months ago
Re: [bug#75537] [PATCH 0/2] Add bsnes-hd / libretro-bsnes-hd
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
87sephhk30.fsf@envs.net
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (7 lines)
> Yet another SNES emulator option.
>
> Maxim Cournoyer (2):
> gnu: Add bsnes-hd.
> gnu: Add libretro-bsnes-hd.
>

Look good to me, please push, thank you!
Maxim Cournoyer wrote 2 months ago
(name . 宋文武)(address . iyzsong@envs.net)
87o7038dev.fsf@gmail.com
Hi,

宋文武 <iyzsong@envs.net> writes:

Toggle quote (11 lines)
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> Yet another SNES emulator option.
>>
>> Maxim Cournoyer (2):
>> gnu: Add bsnes-hd.
>> gnu: Add libretro-bsnes-hd.
>>
>
> Look good to me, please push, thank you!

Thanks, done with commit a1ca12fe85.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 75537@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75537
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help