[PATCH] gnu: qtbase: Increase test timeout.

  • Open
  • quality assurance status badge
Details
One participant
  • Leo Nikkilä
Owner
unassigned
Submitted by
Leo Nikkilä
Severity
normal

Debbugs page

Leo Nikkilä wrote 2 months ago
(address . guix-patches@gnu.org)(name . Leo Nikkilä)(address . hello@lnikki.la)
20250112213337.11877-1-hello@lnikki.la
* gnu/packages/qt.scm (qtbase): Increase test timeout.
[arguments]: <#:phases>: Set QTEST_FUNCTION_TIMEOUT.
---
gnu/packages/qt.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 76c11af543..d2a7c52a80 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -909,7 +909,19 @@ (define-public qtbase
;; due to bitness (see: https://code.qt.io/cgit/qt/qtbase.git
;; /tree/src/testlib/qtestblacklist.cpp).
(setenv "QTEST_ENVIRONMENT" "linux ci 32bit")
+ ;; Some tests use a lot of memory and might trigger
+ ;; swapping, which often hits the default test timeout of
+ ;; 300 seconds:
+ ;;
+ ;; QFATAL : tst_QByteArrayLarge::qUncompress4GiBPlus() Test function timed out
+ ;; QFATAL : tst_QByteArrayMatcher::haystacksWithMoreThan4GiBWork() Test function timed out
+ ;; QFATAL : tst_QLatin1StringMatcher::haystacksWithMoreThan4GiBWork() Test function timed out
+ ;;
+ ;; Guix has its own timeout anyway.
+ ;;
+ ;; <https://doc.qt.io/qt-6/qtest-overview.html#increasing-test-function-timeout>
+ (setenv "QTEST_FUNCTION_TIMEOUT" "3600000") ; 1 hour
(setenv "HOME" "/tmp") ;some tests require a writable HOME
;; Note: the search path specified for TZDIR is only

--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75525@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75525
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help