[PATCH] gnu: Add bchunk.

  • Open
  • quality assurance status badge
Details
One participant
  • Yovan Naumovski
Owner
unassigned
Submitted by
Yovan Naumovski
Severity
normal
Y
Y
Yovan Naumovski wrote on 12 Jan 16:04 +0100
(address . guix-patches@gnu.org)(name . Yovan Naumovski)(address . yovan@gorski.stream)
8f3f46af6367db20582698fbf35adc6284a1961c.1736694157.git.yovan@gorski.stream
* gnu/packages/cdrom.scm (bchunk): New variable.

Change-Id: I0fbc7255fcb4cf5b52c52092a4f56b06511a2294
---
gnu/packages/cdrom.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index e441423573..486f3b1048 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -210,6 +210,37 @@ (define-public xorriso
files.")
(license gpl3+)))
+(define-public bchunk
+ (package
+ (name "bchunk")
+ (version "1.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hessu/bchunk")
+ (commit
+ (string-append "release/" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0amhc196ibg7gj2iki0z9kykvcm85jxpbnkcmk2jxj3hni242n60"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ;; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "bchunk" (string-append out "/bin"))
+ (install-file "bchunk.1" (string-append out "/share/man/man.1"))))))))
+ (home-page "http://he.fi/bchunk/")
+ (synopsis "Bin/cue to ISO image converter")
+ (description "@command{cdrecord} converts a CD image in a \".bin / .cue\"
+format (sometimes \".raw / .cue\") to a set of .iso and .cdr tracks.")
+ (license gpl2)))
+
(define-public cdparanoia
(package
(name "cdparanoia")

base-commit: bde32a3d88482f6e0b2f260174914c020a7c6166
--
2.47.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75516@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75516
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch