[PATCH 0/4] gnu: Add partitionmanager.

  • Done
  • quality assurance status badge
Details
3 participants
  • Sughosha
  • Z572
  • Zheng Junjie
Owner
unassigned
Submitted by
Sughosha
Severity
normal

Debbugs page

Sughosha wrote 2 months ago
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
cover.1736636959.git.sughosha@disroot.org
This patch series fixes kpmcore and adds partitionmanager.

Sughosha (4):
gnu: kpmcore: Fix polkit action path.
gnu: Add fatresize.
gnu: kpmcore: Support filesystems.
gnu: Add partitionmanager.

gnu/packages/disk.scm | 23 +++++++++
gnu/packages/kde.scm | 107 ++++++++++++++++++++++++++++++++++++++----
2 files changed, 120 insertions(+), 10 deletions(-)


base-commit: 3ea95d7736be1f807d578d17c174b0976543b333
--
2.47.1
Sughosha wrote 2 months ago
[PATCH 2/4] gnu: Add fatresize.
(address . 75503@debbugs.gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
283226444b4c95d7c71dec530225070799e39cc8.1736636961.git.sughosha@disroot.org
* gnu/packages/disk.scm (fatresize): New variable.

Change-Id: Id2fafb664fe3c34184bb7c86cec7e08a204565aa
---
gnu/packages/disk.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index fd9cb8a45e..9144a2af55 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -595,6 +595,29 @@ (define-public fatfsck/static
and a @command{fsck.vfat} compatibility symlink for use in an initrd.")
(license (package-license dosfstools))))
+(define-public fatresize
+ (package
+ (name "fatresize")
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ya-mouse/fatresize")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1vhz84kxfyl0q7mkqn68nvzzly0a4xgzv76m6db0bk7xyczv1qr2"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list parted))
+ (home-page "https://github.com/ya-mouse/fatresize")
+ (synopsis "Tool to resize FAT partitions using libparted")
+ (description
+ "This package provides a tool to resize FAT partitions using libparted")
+ (license license:gpl3+)))
+
(define-public hdparm
(package
(name "hdparm")
--
2.47.1
Sughosha wrote 2 months ago
[PATCH 1/4] gnu: kpmcore: Fix polkit action path.
(address . 75503@debbugs.gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
925c0ad854a0f6f40a8563084e82879adadcd3ae.1736636961.git.sughosha@disroot.org
* gnu/packages/kde.scm (kpmcore)[arguments]<#:phases>: Replace
fix-cmake-install-directories with fix-polkit-action-path.

Change-Id: I2d230d78b1dbf423b431e14f290c372efa9c1a45
---
gnu/packages/kde.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 62e43c6afd..ce64619feb 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1281,11 +1281,13 @@ (define-public kpmcore
(list
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'fix-cmake-install-directories
+ (add-after 'unpack 'fix-polkit-action-path
(lambda _
(substitute* "src/util/CMakeLists.txt"
(("DESTINATION \\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
- "DESTINATION share/polkit-1/actions")))))))
+ "DESTINATION share/polkit-1/actions"))
+ (substitute* "src/backend/corebackend.cpp"
+ (("\\/usr") #$output)))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Library for managing partitions")
(description "Library for managing partitions.")
--
2.47.1
Sughosha wrote 2 months ago
[PATCH 3/4] gnu: kpmcore: Support filesystems.
(address . 75503@debbugs.gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
1412ede1633b77ff8cb340760ba9f4df6b868cef.1736636962.git.sughosha@disroot.org
* gnu/packages/kde.scm (kpmcore)[inputs]: Switch to the old input style; Add
eudev, cryptsetup, bcachefs-tools, btrfs-progs, dosfstools, e2fsprogs,
exfatprogs, f2fs-tools, fatresize, jfsutils, lvm2, mdadm, nilfs-utils, ntfs-3g,
udftools, util-linux and zfs.
[arguments]<#:phases>: Add patch-trustedprefixes phase.

Change-Id: Ib39b8997411cce89494006e3e00ed81d17ded16f
---
gnu/packages/kde.scm | 64 +++++++++++++++++++++++++++++++++++++-------
1 file changed, 55 insertions(+), 9 deletions(-)

Toggle diff (97 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index ce64619feb..a08634bee8 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -58,12 +58,15 @@ (define-module (gnu packages kde)
#:use-module (gnu packages code)
#:use-module (gnu packages cpp)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cryptsetup)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages disk)
#:use-module (gnu packages djvu)
#:use-module (gnu packages documentation)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages graphics)
#:use-module (gnu packages ebook)
+ #:use-module (gnu packages file-systems)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
@@ -1269,14 +1272,33 @@ (define-public kpmcore
(native-inputs
(list extra-cmake-modules pkg-config))
(inputs
- (list kauth
- kcoreaddons
- ki18n
- kwidgetsaddons
- polkit-qt6
- qtbase
- qca-qt6
- `(,util-linux "lib")))
+ `(("kauth" ,kauth)
+ ("kcoreaddons" ,kcoreaddons)
+ ("ki18n" ,ki18n)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("polkit-qt6" ,polkit-qt6)
+ ("qtbase" ,qtbase)
+ ("qca-qt6" ,qca-qt6)
+ ("util-linux:lib" ,util-linux "lib")
+
+ ;; For external commands
+ ("eudev" ,eudev)
+ ("cryptsetup" ,cryptsetup)
+ ("bcachefs-tools" ,bcachefs-tools)
+ ("btrfs-progs" ,btrfs-progs)
+ ("dosfstools" ,dosfstools)
+ ("e2fsprogs" ,e2fsprogs)
+ ("exfatprogs" ,exfatprogs)
+ ("f2fs-tools" ,f2fs-tools)
+ ("fatresize" ,fatresize)
+ ("jfsutils" ,jfsutils)
+ ("lvm2" ,lvm2)
+ ("mdadm" ,mdadm)
+ ("nilfs-utils" ,nilfs-utils)
+ ("ntfs-3g" ,ntfs-3g)
+ ("udftools" ,udftools)
+ ("util-linux" ,util-linux)
+ ("zfs" ,zfs)))
(arguments
(list
#:phases
@@ -1287,7 +1309,31 @@ (define-public kpmcore
(("DESTINATION \\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
"DESTINATION share/polkit-1/actions"))
(substitute* "src/backend/corebackend.cpp"
- (("\\/usr") #$output)))))))
+ (("\\/usr") #$output))))
+ (add-before 'configure 'patch-trustedprefixes
+ (lambda* (#:key inputs #:allow-other-keys)
+ (call-with-output-file "src/util/trustedprefixes"
+ (lambda (port)
+ (map (lambda (name)
+ (display (assoc-ref inputs name) port)
+ (newline port))
+ '("eudev"
+ "cryptsetup"
+ "bcachefs-tools"
+ "btrfs-progs"
+ "dosfstools"
+ "e2fsprogs"
+ "exfatprogs"
+ "f2fs-tools"
+ "fatresize"
+ "jfsutils"
+ "lvm2"
+ "mdadm"
+ "nilfs-utils"
+ "ntfs-3g"
+ "udftools"
+ "util-linux"
+ "zfs")))))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Library for managing partitions")
(description "Library for managing partitions.")
--
2.47.1
Sughosha wrote 2 months ago
[PATCH 4/4] gnu: Add partitionmanager.
(address . 75503@debbugs.gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
2a037410a7a7df8af91f976bc0002d671791cf7d.1736636962.git.sughosha@disroot.org
* gnu/packages/kde.scm (partitionmanager): New variable.

Change-Id: If8f03f352a580c5b11f3508733710d2eb8c45dae
---
gnu/packages/kde.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index a08634bee8..a8471ea935 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1339,6 +1339,45 @@ (define-public kpmcore
(description "Library for managing partitions.")
(license license:gpl3+)))
+(define-public partitionmanager
+ (package
+ (name "partitionmanager")
+ (version "24.05.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/partitionmanager-" version ".tar.xz"))
+ (sha256
+ (base32 "01xmwkwv8jrwx2jpg797ar8ac9gbdagrl2v3yzqn62fhwcwjcxy6"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:qtbase qtbase))
+ (native-inputs
+ (list extra-cmake-modules kdoctools))
+ (inputs
+ (list kconfig
+ kconfigwidgets
+ kcoreaddons
+ kcrash
+ kdbusaddons
+ ki18n
+ kio
+ kjobwidgets
+ kpmcore
+ kwidgetsaddons
+ kwindowsystem
+ kxmlgui
+ polkit-qt6))
+ (home-page "https://apps.kde.org/partitionmanager/")
+ (synopsis "Disk device, partition and file system manager")
+ (description "KDE Partition Manager is a utility to help you manage the
+disks, partitions, and file systems. It allows you to easily create, copy,
+move, delete, back up, restore, and resize them without losing data. It
+supports a large number of file systems, including ext2/3/4, btrfs, NTFS,
+FAT16/32, JFS, XFS and more.")
+ (license license:gpl3+)))
+
(define-public kpublictransport
(package
(name "kpublictransport")
--
2.47.1
Zheng Junjie wrote 2 months ago
Re: [bug#75503] [PATCH 3/4] gnu: kpmcore: Support filesystems.
(name . Sughosha via Guix-patches via)(address . guix-patches@gnu.org)
875xmkrcdj.fsf@iscas.ac.cn
Sughosha via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (103 lines)
> * gnu/packages/kde.scm (kpmcore)[inputs]: Switch to the old input style; Add
> eudev, cryptsetup, bcachefs-tools, btrfs-progs, dosfstools, e2fsprogs,
> exfatprogs, f2fs-tools, fatresize, jfsutils, lvm2, mdadm, nilfs-utils, ntfs-3g,
> udftools, util-linux and zfs.
> [arguments]<#:phases>: Add patch-trustedprefixes phase.
>
> Change-Id: Ib39b8997411cce89494006e3e00ed81d17ded16f
> ---
> gnu/packages/kde.scm | 64 +++++++++++++++++++++++++++++++++++++-------
> 1 file changed, 55 insertions(+), 9 deletions(-)
>
> diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
> index ce64619feb..a08634bee8 100644
> --- a/gnu/packages/kde.scm
> +++ b/gnu/packages/kde.scm
> @@ -58,12 +58,15 @@ (define-module (gnu packages kde)
> #:use-module (gnu packages code)
> #:use-module (gnu packages cpp)
> #:use-module (gnu packages compression)
> + #:use-module (gnu packages cryptsetup)
> #:use-module (gnu packages curl)
> + #:use-module (gnu packages disk)
> #:use-module (gnu packages djvu)
> #:use-module (gnu packages documentation)
> #:use-module (gnu packages gnupg)
> #:use-module (gnu packages graphics)
> #:use-module (gnu packages ebook)
> + #:use-module (gnu packages file-systems)
> #:use-module (gnu packages flex)
> #:use-module (gnu packages fontutils)
> #:use-module (gnu packages freedesktop)
> @@ -1269,14 +1272,33 @@ (define-public kpmcore
> (native-inputs
> (list extra-cmake-modules pkg-config))
> (inputs
> - (list kauth
> - kcoreaddons
> - ki18n
> - kwidgetsaddons
> - polkit-qt6
> - qtbase
> - qca-qt6
> - `(,util-linux "lib")))
> + `(("kauth" ,kauth)
> + ("kcoreaddons" ,kcoreaddons)
> + ("ki18n" ,ki18n)
> + ("kwidgetsaddons" ,kwidgetsaddons)
> + ("polkit-qt6" ,polkit-qt6)
> + ("qtbase" ,qtbase)
> + ("qca-qt6" ,qca-qt6)
> + ("util-linux:lib" ,util-linux "lib")
> +
> + ;; For external commands
> + ("eudev" ,eudev)
> + ("cryptsetup" ,cryptsetup)
> + ("bcachefs-tools" ,bcachefs-tools)
> + ("btrfs-progs" ,btrfs-progs)
> + ("dosfstools" ,dosfstools)
> + ("e2fsprogs" ,e2fsprogs)
> + ("exfatprogs" ,exfatprogs)
> + ("f2fs-tools" ,f2fs-tools)
> + ("fatresize" ,fatresize)
> + ("jfsutils" ,jfsutils)
> + ("lvm2" ,lvm2)
> + ("mdadm" ,mdadm)
> + ("nilfs-utils" ,nilfs-utils)
> + ("ntfs-3g" ,ntfs-3g)
> + ("udftools" ,udftools)
> + ("util-linux" ,util-linux)
> + ("zfs" ,zfs)))
> (arguments
> (list
> #:phases
> @@ -1287,7 +1309,31 @@ (define-public kpmcore
> (("DESTINATION \\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
> "DESTINATION share/polkit-1/actions"))
> (substitute* "src/backend/corebackend.cpp"
> - (("\\/usr") #$output)))))))
> + (("\\/usr") #$output))))
> + (add-before 'configure 'patch-trustedprefixes
> + (lambda* (#:key inputs #:allow-other-keys)
> + (call-with-output-file "src/util/trustedprefixes"
> + (lambda (port)
> + (map (lambda (name)
> + (display (assoc-ref inputs name) port)
> + (newline port))
> + '("eudev"
> + "cryptsetup"
> + "bcachefs-tools"
> + "btrfs-progs"
> + "dosfstools"
> + "e2fsprogs"
> + "exfatprogs"
> + "f2fs-tools"
> + "fatresize"
> + "jfsutils"
> + "lvm2"
> + "mdadm"
> + "nilfs-utils"
> + "ntfs-3g"
> + "udftools"
> + "util-linux"
> + "zfs")))))))))
can we just use
"
/run/current-system/profile/
/usr
/
"
?

I don't think anyone uses that many file systems at once. To control the
size, it might be better to get it from outside.

Toggle quote (3 lines)
> (synopsis "Library for managing partitions")
> (description "Library for managing partitions.")
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmeDKZgACgkQO1qpk+Gi
3/DsSQ//eEn/IZ5g9Hb4GZCGj9wHEAf2CAaB5mSGbBZZ5AjS8Tcxzg8JhszYHAg5
VC2zke716XCpI3yn3Nvn1kdoCwQnh8ALJNU4NysmOfdfNi37g5m6ihJ+cpWwcIAJ
7OO8VRCL65FdvhQjdKHTZ+vuvdwWiITkjDXc9e4iP7owde/5K3fz4rdGdscrap/1
PaBbckLcmTcnx4GvgJ3zJsTDhG+DqA8ewOHR3Of4It+gXOneVct14lg4uQJrOVSG
UA5zsvX6EhNrInWCAaSEBz+LGe0nxDH2v+R+cRQjJu5V3XXNceY0q+pDjpBCqPlB
KtRbpThpKiU6dKCCb4H0M5d5236gm+mBIjExJ5h+ZoGbcwMZPSLqf+uYxJewF7Hf
W9wrDMhVeNwniSn53FRuk+zny+wLn5orBNN2APY7SU8YXo3iGEmnhw5PyqRzPFn5
tanMbLhq8n7U4JWscDKjn1xrf2Gf7TNCtvIse5Gyh1x91L5m5cwSfGfEYWcuAqzC
DfFhWIg3QpYFnqVNbsW2ZTgXHKx0UKfQCtUeTMFJlFVOjXElAuw84k/vNfmgVG5y
oOyuyyf9un9ZAWPzp1O+kpE7+a8QDyS8J67pwJTUTqdZWl27hadkOK7aYVjCiCsa
Sjatntiu24ECCEMpZAwHVCRog8OOgqQ3X1dWfAu9qma9rxUZ3Rs=
=BqIQ
-----END PGP SIGNATURE-----

Sughosha wrote 2 months ago
[PATCH v2 0/3] gnu: Add partitionmanager
(address . 75503@debbugs.gnu.org)
cover.1736672077.git.sughosha@disroot.org
This patch series fixes kpmcore and add partitionmanager.

In this v2 patch series, dependencies related to specific file-systems have
been removed and added only /run/current-system/profile to the trustedprefixes
file, thanks to Zheng.

Sughosha (3):
gnu: kpmcore: Fix polkit action path.
gnu: kpmcore: Fix missing commands.
gnu: Add partitionmanager.

gnu/packages/kde.scm | 80 ++++++++++++++++++++++++++++++++++++++------
1 file changed, 70 insertions(+), 10 deletions(-)


base-commit: 3ea95d7736be1f807d578d17c174b0976543b333
--
2.47.1
Sughosha wrote 2 months ago
[PATCH v2 1/3] gnu: kpmcore: Fix polkit action path.
(address . 75503@debbugs.gnu.org)
1e8a21833e574b2bc0f4d9e707b5bfb1f1957991.1736672077.git.sughosha@disroot.org
* gnu/packages/kde.scm (kpmcore)[arguments]<#:phases>: Replace
fix-cmake-install-directories with fix-polkit-action-path.

Change-Id: I2d230d78b1dbf423b431e14f290c372efa9c1a45
---
gnu/packages/kde.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 62e43c6afd..ce64619feb 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1281,11 +1281,13 @@ (define-public kpmcore
(list
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'fix-cmake-install-directories
+ (add-after 'unpack 'fix-polkit-action-path
(lambda _
(substitute* "src/util/CMakeLists.txt"
(("DESTINATION \\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
- "DESTINATION share/polkit-1/actions")))))))
+ "DESTINATION share/polkit-1/actions"))
+ (substitute* "src/backend/corebackend.cpp"
+ (("\\/usr") #$output)))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Library for managing partitions")
(description "Library for managing partitions.")
--
2.47.1
Sughosha wrote 2 months ago
[PATCH v2 2/3] gnu: kpmcore: Fix missing commands.
(address . 75503@debbugs.gnu.org)
30aeb7bd1db7f54d30386b0d17add90b94dadb57.1736672077.git.sughosha@disroot.org
* gnu/packages/kde.scm (kpmcore)[inputs]: Switch to the old input style; Add
coreutils, cryptsetup, eudev, lvm2, mdadm, smartmontools and util-linux.
[arguments]<#:phases>: Add patch-trustedprefixes-file phase.

Change-Id: I6b205596e2ae5d03010db27b0b41ddb42d4534b5
---
gnu/packages/kde.scm | 37 ++++++++++++++++++++++++++++---------
1 file changed, 28 insertions(+), 9 deletions(-)

Toggle diff (71 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index ce64619feb..7c02de246a 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -45,6 +45,7 @@ (define-module (gnu packages kde)
#:use-module (guix utils)
#:use-module (guix packages)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages algebra)
#:use-module (gnu packages apr)
#:use-module (gnu packages astronomy)
@@ -58,6 +59,7 @@ (define-module (gnu packages kde)
#:use-module (gnu packages code)
#:use-module (gnu packages cpp)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cryptsetup)
#:use-module (gnu packages curl)
#:use-module (gnu packages djvu)
#:use-module (gnu packages documentation)
@@ -1269,14 +1271,21 @@ (define-public kpmcore
(native-inputs
(list extra-cmake-modules pkg-config))
(inputs
- (list kauth
- kcoreaddons
- ki18n
- kwidgetsaddons
- polkit-qt6
- qtbase
- qca-qt6
- `(,util-linux "lib")))
+ `(("coreutils" ,coreutils)
+ ("cryptsetup" ,cryptsetup)
+ ("eudev" ,eudev)
+ ("kauth" ,kauth)
+ ("kcoreaddons" ,kcoreaddons)
+ ("ki18n" ,ki18n)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("lvm2" ,lvm2)
+ ("mdadm" ,mdadm)
+ ("polkit-qt6" ,polkit-qt6)
+ ("qtbase" ,qtbase)
+ ("qca-qt6" ,qca-qt6)
+ ("smartmontools" ,smartmontools)
+ ("util-linux" ,util-linux)
+ ("util-linux:lib" ,util-linux "lib")))
(arguments
(list
#:phases
@@ -1287,7 +1296,17 @@ (define-public kpmcore
(("DESTINATION \\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
"DESTINATION share/polkit-1/actions"))
(substitute* "src/backend/corebackend.cpp"
- (("\\/usr") #$output)))))))
+ (("\\/usr") #$output))))
+ (add-before 'configure 'patch-trustedprefixes-file
+ (lambda _
+ (call-with-output-file "src/util/trustedprefixes"
+ (lambda (port)
+ (map (lambda (prefix)
+ (display prefix port)
+ (newline port))
+ '("/run/current-system/profile"
+ "/usr"
+ "/")))))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Library for managing partitions")
(description "Library for managing partitions.")
--
2.47.1
Sughosha wrote 2 months ago
[PATCH v2 3/3] gnu: Add partitionmanager.
(address . 75503@debbugs.gnu.org)
7e259aac89cebc2d2bffa4d061cc3d136a9ea549.1736672077.git.sughosha@disroot.org
* gnu/packages/kde.scm (partitionmanager): New variable.

Change-Id: I90e712d47a53b179deced9c704d73d0f41b25071
---
gnu/packages/kde.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 7c02de246a..b09381fa6c 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1312,6 +1312,45 @@ (define-public kpmcore
(description "Library for managing partitions.")
(license license:gpl3+)))
+(define-public partitionmanager
+ (package
+ (name "partitionmanager")
+ (version "24.05.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/partitionmanager-" version ".tar.xz"))
+ (sha256
+ (base32 "01xmwkwv8jrwx2jpg797ar8ac9gbdagrl2v3yzqn62fhwcwjcxy6"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:qtbase qtbase))
+ (native-inputs
+ (list extra-cmake-modules kdoctools))
+ (inputs
+ (list kconfig
+ kconfigwidgets
+ kcoreaddons
+ kcrash
+ kdbusaddons
+ ki18n
+ kio
+ kjobwidgets
+ kpmcore
+ kwidgetsaddons
+ kwindowsystem
+ kxmlgui
+ polkit-qt6))
+ (home-page "https://apps.kde.org/partitionmanager/")
+ (synopsis "Disk device, partition and file system manager")
+ (description "KDE Partition Manager is a utility to help you manage the
+disks, partitions, and file systems. It allows you to easily create, copy,
+move, delete, back up, restore, and resize them without losing data. It
+supports a large number of file systems, including ext2/3/4, btrfs, NTFS,
+FAT16/32, JFS, XFS and more.")
+ (license license:gpl3+)))
+
(define-public kpublictransport
(package
(name "kpublictransport")
--
2.47.1
Sughosha wrote 2 months ago
[PATCH v3 0/3] gnu: Add partitionmanager.
(address . 75503@debbugs.gnu.org)
cover.1736685616.git.sughosha@disroot.org
This patch series fixes kpmcore and adds partitionmanager.

In addition to the v2 patch series, the store prefixes of the packages which
provide essential binaries are added to the trustedprefixes. Since these
dependencies are not propagated, it is required to allow calling binaries from
these prefixes.

Sughosha (3):
gnu: kpmcore: Fix polkit action path.
gnu: kpmcore: Fix missing commands.
gnu: Add partitionmanager.

gnu/packages/kde.scm | 87 +++++++++++++++++++++++++++++++++++++++-----
1 file changed, 77 insertions(+), 10 deletions(-)


base-commit: 3ea95d7736be1f807d578d17c174b0976543b333
--
2.47.1
Sughosha wrote 2 months ago
[PATCH v3 1/3] gnu: kpmcore: Fix polkit action path.
(address . 75503@debbugs.gnu.org)
1e8a21833e574b2bc0f4d9e707b5bfb1f1957991.1736685616.git.sughosha@disroot.org
* gnu/packages/kde.scm (kpmcore)[arguments]<#:phases>: Replace
fix-cmake-install-directories with fix-polkit-action-path.

Change-Id: I2d230d78b1dbf423b431e14f290c372efa9c1a45
---
gnu/packages/kde.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 62e43c6afd..ce64619feb 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1281,11 +1281,13 @@ (define-public kpmcore
(list
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'fix-cmake-install-directories
+ (add-after 'unpack 'fix-polkit-action-path
(lambda _
(substitute* "src/util/CMakeLists.txt"
(("DESTINATION \\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
- "DESTINATION share/polkit-1/actions")))))))
+ "DESTINATION share/polkit-1/actions"))
+ (substitute* "src/backend/corebackend.cpp"
+ (("\\/usr") #$output)))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Library for managing partitions")
(description "Library for managing partitions.")
--
2.47.1
Sughosha wrote 2 months ago
[PATCH v3 2/3] gnu: kpmcore: Fix missing commands.
(address . 75503@debbugs.gnu.org)
5a255065c2a16f4d606207d809819a2e2e2ec056.1736685616.git.sughosha@disroot.org
* gnu/packages/kde.scm (kpmcore)[inputs]: Switch to the old input style; Add
coreutils, cryptsetup, eudev, lvm2, mdadm, smartmontools and util-linux.
[arguments]<#:phases>: Add patch-trustedprefixes-file phase.

Change-Id: I6b205596e2ae5d03010db27b0b41ddb42d4534b5
---
gnu/packages/kde.scm | 44 +++++++++++++++++++++++++++++++++++---------
1 file changed, 35 insertions(+), 9 deletions(-)

Toggle diff (78 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index ce64619feb..9481ecd8ea 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -45,6 +45,7 @@ (define-module (gnu packages kde)
#:use-module (guix utils)
#:use-module (guix packages)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages algebra)
#:use-module (gnu packages apr)
#:use-module (gnu packages astronomy)
@@ -58,6 +59,7 @@ (define-module (gnu packages kde)
#:use-module (gnu packages code)
#:use-module (gnu packages cpp)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cryptsetup)
#:use-module (gnu packages curl)
#:use-module (gnu packages djvu)
#:use-module (gnu packages documentation)
@@ -1269,14 +1271,21 @@ (define-public kpmcore
(native-inputs
(list extra-cmake-modules pkg-config))
(inputs
- (list kauth
- kcoreaddons
- ki18n
- kwidgetsaddons
- polkit-qt6
- qtbase
- qca-qt6
- `(,util-linux "lib")))
+ `(("coreutils" ,coreutils)
+ ("cryptsetup" ,cryptsetup)
+ ("eudev" ,eudev)
+ ("kauth" ,kauth)
+ ("kcoreaddons" ,kcoreaddons)
+ ("ki18n" ,ki18n)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("lvm2" ,lvm2)
+ ("mdadm" ,mdadm)
+ ("polkit-qt6" ,polkit-qt6)
+ ("qtbase" ,qtbase)
+ ("qca-qt6" ,qca-qt6)
+ ("smartmontools" ,smartmontools)
+ ("util-linux" ,util-linux)
+ ("util-linux:lib" ,util-linux "lib")))
(arguments
(list
#:phases
@@ -1287,7 +1296,24 @@ (define-public kpmcore
(("DESTINATION \\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
"DESTINATION share/polkit-1/actions"))
(substitute* "src/backend/corebackend.cpp"
- (("\\/usr") #$output)))))))
+ (("\\/usr") #$output))))
+ (add-before 'configure 'patch-trustedprefixes-file
+ (lambda* (#:key inputs #:allow-other-keys)
+ (call-with-output-file "src/util/trustedprefixes"
+ (lambda (port)
+ (map (lambda (prefix)
+ (display prefix port)
+ (newline port))
+ (list (assoc-ref inputs "coreutils")
+ (assoc-ref inputs "util-linux")
+ (assoc-ref inputs "eudev")
+ (assoc-ref inputs "cryptsetup")
+ (assoc-ref inputs "lvm2")
+ (assoc-ref inputs "mdadm")
+ (assoc-ref inputs "smartmontools")
+ "/run/current-system/profile"
+ "/usr"
+ "/")))))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Library for managing partitions")
(description "Library for managing partitions.")
--
2.47.1
Sughosha wrote 2 months ago
[PATCH v3 3/3] gnu: Add partitionmanager.
(address . 75503@debbugs.gnu.org)
acc4053d15ab84f957424d5677f927e14b8171ca.1736685617.git.sughosha@disroot.org
* gnu/packages/kde.scm (partitionmanager): New variable.

Change-Id: I2bd1df994274397ecd92dd78d84954d97fe75f5a
---
gnu/packages/kde.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 9481ecd8ea..3a16c2099c 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1319,6 +1319,45 @@ (define-public kpmcore
(description "Library for managing partitions.")
(license license:gpl3+)))
+(define-public partitionmanager
+ (package
+ (name "partitionmanager")
+ (version "24.05.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/partitionmanager-" version ".tar.xz"))
+ (sha256
+ (base32 "01xmwkwv8jrwx2jpg797ar8ac9gbdagrl2v3yzqn62fhwcwjcxy6"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:qtbase qtbase))
+ (native-inputs
+ (list extra-cmake-modules kdoctools))
+ (inputs
+ (list kconfig
+ kconfigwidgets
+ kcoreaddons
+ kcrash
+ kdbusaddons
+ ki18n
+ kio
+ kjobwidgets
+ kpmcore
+ kwidgetsaddons
+ kwindowsystem
+ kxmlgui
+ polkit-qt6))
+ (home-page "https://apps.kde.org/partitionmanager/")
+ (synopsis "Disk device, partition and file system manager")
+ (description "KDE Partition Manager is a utility to help you manage the
+disks, partitions, and file systems. It allows you to easily create, copy,
+move, delete, back up, restore, and resize them without losing data. It
+supports a large number of file systems, including ext2/3/4, btrfs, NTFS,
+FAT16/32, JFS, XFS and more.")
+ (license license:gpl3+)))
+
(define-public kpublictransport
(package
(name "kpublictransport")
--
2.47.1
Sughosha wrote 4 weeks ago
Re: [PATCH 0/4] gnu: Add partitionmanager.
(address . 75503@debbugs.gnu.org)
5861734.DvuYhMxLoT@localhost.localdomain
This package works file when both the dbus service and the polkit service is
extended with kpmcore.

--
Sughosha
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE6tGJ5HmbXl6yCioZzbwL2VlDpwYFAmesm9YACgkQzbwL2VlD
pwZ8Vg//eiv3KLRKWtjbARzVB9Jqm1dRcuS6AsGYuf2y+b9mnyH9I30kYblYJpa8
SV+QLglKu01gvveRpq59OhXRlVFhwhEYKqJ/nQJ3xkKU266FOdfy6G+D3YKzaXvQ
xLJDmAEnFXNkVvQ7MMkknWlXFo/Jtsg09M0GghPy/0BCX2zflQHPUJ+keJDhFDOw
IBPp6jGGK9XL+IAJWimsjS3KZtawXzm056y+C0U4xHy+tdESVdyl7WMDOVoYXGvB
1owIAKrTjDudCGY5SOZaj7DhihQJzuDyAdyam7QDee8JAbQ6AD0bTECRLzmtkGRo
MHHwcJnGsdFGJuFxv/vp/TsJWVX9Q2liMmAIvbvNvCyANaUo5/Ll8NEElFgrQTqZ
70o3kjCfrqqTbYHgVZFPJewDZR5V/nI8bdnjR46RoXCAAlCralBjM7vTDmzOXO5V
6dWb+RuYmj0es/Fsm/FmFphu8a8hf0kgzCh7CZeI0J1zwExtSRR92OA7xc7C0yA0
C6hZOpKPEGXPjuj08+H+IPTQK6Lijv5D0xpeozBMKkJDACBz/ZIeVXsyk7ml4yUG
WjiEyw9jkowYa08fIDELbe861NhZK3hMYKeKhFxcEl1jBcZL8sqqbZiwrIBDOmnH
XZY6NreZYrmsiqT4NeopLauGsUXyaCI08SqzkhSTdDe2crun2jE=
=EiiJ
-----END PGP SIGNATURE-----


Z572 wrote 4 weeks ago
Re: [bug#75503] [PATCH 0/4] gnu: Add partitionmanager.
(name . Sughosha via Guix-patches via)(address . guix-patches@gnu.org)
87jz9u5qva.fsf@z572.online
Sughosha via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> This package works file when both the dbus service and the polkit service is
> extended with kpmcore.
That's good to know, pushed, closing.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmetibkACgkQO1qpk+Gi
3/AfJA/8CxTEvS6FCXntSIisqF15/g3n0bIcJAG2gmseQOwBM0Oec8dH6+PZgjOQ
dpwrmEbQVpYWE255TrW7pYjAJ6Ex1S1AMKR2hULW9dGuTg+/na+bKtbMABrX8BO0
Cd0hXyHZlPn94BU8MQ5HJ+ivX21JnMuhNPvSJ+jqo6ZvLWaRJdxS+rN7JR1Sv4YG
wx+0hwNHjwZ+LWOSOPLqFOongkEa8Zzz03oSdAX5sLWU5s1ACf199bYjDYoaT1Op
LqwldkL+nlJePwDBBnVJ6H0cOvEtoYEHfS7A0BZUYVGs5WmsICd6bfZC+riGjKD0
+VJCXyPie6tqI4z5aHGlyd4uXNWKl7WJNe1jTr3Rbofzl5WLzg6/QxcWoAWGN1M+
HJ0YEE6q/zy4nLv7Nn+c+xpVlrn0WenMUyS6IdsEly1bwDwO7I/900ivPSoXNnSU
qyalqCkms+ROz5jQCZ7MO1Kq2nvTYetHIUheasEotX5nhoEA6qB/pFHU9eM8P9yr
l5dSr5ZRP2YGYIhCDHOQ0JxNJinHdBIQZykpgVQY6Noq5bdk43gc6tnUiBbA9Wnx
Fj/DijhRmZJhVIYW0uxkqCzJw7trauBedSx8uq09UAqmGS03lxB4nlIU8Q6cjtFZ
XlLcbKEhvSxl7Lgty1B09mF4OkfYOj6Hos84nUfGHU9kWRh3lHA=
=XKXr
-----END PGP SIGNATURE-----

Z572 wrote 4 weeks ago
(name . Sughosha via Guix-patches via)(address . guix-patches@gnu.org)
87ed025qqm.fsf@z572.online
Sughosha via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (4 lines)
> This package works file when both the dbus service and the polkit service is
> extended with kpmcore.


And are you interested in becoming a committer? This makes it easier for
you to contribute packages.
I can vouch for you.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmetimEACgkQO1qpk+Gi
3/Cv1w//fQ4Z18Gr9M9zlbkwIt/7RnmPPHCMptg7pQuJr/vj1SVlye4T2xrP3Dpy
bzl5qHwdADCSyBysdx1Jh/CzO71BoiLJ0QePMptuQZbjV9SS3zT2bINZJzoY6oTr
qgQ17RL0svbf4jJN7MgLwHOZ2K3e4dPz7VEIOLIKDUgfIbgkS00Ue4wXbdOEZyWQ
G+PhP3AoTWw8zi1Ajv4XMTZ+yqf1we15b2er5QvdHk5/UmnbM3mHmTg3TisGzVCS
3LcJd8GExRoT24LNmcdnnSP9i5Hfh6jqzPRxUEtMlvUmr8XPR6dga8vs4knXusPR
Ksqlwgw4Ctj7aV/F03PT8ARS1y05xBehWC6ddFbf8LCbtqVVtUIdBqllAhHS68W8
nkOoVPv42jONX6PNEifoHbip3tUzihXIj/+9AR61t8E1USbXJxF7ymh5COiiiS4V
WaBY1vpi9sQsEH+X3YC3KV4BRWNtxYf3YekhgutxsqAq0DQqAL/abotmxC39zus+
NrubXJnQ+FKl4U/V4p43ynWoWWFQnkVsB5YCGjLPj+R7pP60ChlF6ADJE3lLE4Hw
R1yztrW3eMmIZocK+2fdWKHG6BsqPMMTuH+R/Qx75s4qmgITyZwzAmtrYO6kKHR5
7DpcBPWuYtuTaL3oUDfdPWXHn1qKMANf/OgoeXIrSosmaalCf7Q=
=gZGR
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75503@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75503
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help