[PATCH] gnu: Add dsda-doom.

  • Open
  • quality assurance status badge
Details
One participant
  • Andrew Wong
Owner
unassigned
Submitted by
Andrew Wong
Severity
normal
A
A
Andrew Wong wrote 6 days ago
(address . guix-patches@gnu.org)(name . Andrew Wong)(address . wongandj@icloud.com)
5a3645e2ccbbaac48e122e7f107581db3be0ef92.1736627244.git.wongandj@icloud.com
* gnu/packages/games.scm (dsda-doom): New variable.

Change-Id: I1a999b1b5bf06a7cbe38aa0d4d0ccbb28430b1cf
---
gnu/packages/games.scm | 46 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index fb8018e271..15aebe7fc7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2557,6 +2557,52 @@ (define-public pipewalker
Every puzzle has a complete solution, although there may be more than one.")
(license license:gpl3+)))
+(define-public dsda-doom
+ (package
+ (name "dsda-doom")
+ (version "0.28.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kraflab/dsda-doom")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qvxx4r3ahiy8w9x0559g581971ycmbqm1kszzc65w1aa85f5q2f"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ;no tests
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "prboom2"))))))
+ (inputs (list sdl2
+ sdl2-mixer
+ fluidsynth
+ portmidi
+ libmad
+ libzip
+ glu
+ dumb
+ libvorbis))
+ (home-page "https://github.com/kraflab/dsda-doom")
+ (synopsis "Successor of PrBoom+ with many new features")
+ (description
+ "This is a successor of prboom+ with many new features, including:
+@enumerate
+@item Heretic, Hexen, MBF21, Doom-in-Hexen, UDMF, and MAPINFO support
+@item In-game console and scripting
+@item Full controller support
+@item Palette-based opengl renderer
+@item Debugging features for testing
+@item Strict mode for speedrunning
+@item Various quality of life improvements
+@item Advanced tools for TASing
+@item Rewind
+@end enumerate")
+ (license license:gpl2+)))
+
(define-public prboom-plus
(package
(name "prboom-plus")

base-commit: f15ca836e4686496f675308655c370c95e9f52b7
--
2.47.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75502@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75502
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch