[PATCH] gnu: Add emacs-indent-bars.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Olivier Rojon
Owner
unassigned
Submitted by
Olivier Rojon
Severity
normal

Debbugs page

Olivier Rojon wrote 2 months ago
(address . guix-patches@gnu.org)(name . Olivier Rojon)(address . o.rojon@posteo.net)
20250111101931.22534-1-o.rojon@posteo.net
* gnu/packages/emacs-xyz.scm (emacs-indent-bars): New variable.

Change-Id: I4181674a0723d44e873a0607e0a89af710c9b6f4
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 784fe767bc..7d256f30bf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16217,6 +16217,31 @@ (define-public emacs-rainbow-mode
names, e.g., @samp{#0000ff} is displayed in white with a blue background.")
(license license:gpl3+)))
+(define-public emacs-indent-bars
+ (package
+ (name "emacs-indent-bars")
+ (version "0.8.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/indent-bars-"
+ version ".tar"))
+ (sha256
+ (base32 "1bhdrykkklsscgiz3p29x8kdkw0kbc4mlpnhxghvphx159clhgym"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-compat))
+ (home-page "https://github.com/jdtsmith/indent-bars")
+ (synopsis "Highlight indentation with bars")
+ (description
+ "indent-bars highlights indentation with configurable vertical
+graphical bars, using stipples. The color and appearance (weight,
+pattern, position within the character, zigzag, etc.) are all
+configurable. indent-bars works in any mode using fixed
+tab or space-based indentation. In the terminal (or on request) it
+uses vertical bar characters instead of stipple patterns. Optional
+treesitter support is also available; see indent-bars-ts.el.")
+ (license license:gpl3)))
+
(define-public emacs-ryo-modal
;; Package has no release. Version is extracted from "Version:" keyword in
;; main file.
--
2.47.1
Nicolas Goaziou wrote 2 months ago
(address . 75488-done@debbugs.gnu.org)(name . Olivier Rojon)(address . o.rojon@posteo.net)
87ikq2bxby.fsf@nicolasgoaziou.fr
Hello,

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-indent-bars): New variable.

Applied. Thank you.

Toggle quote (2 lines)
> + (license license:gpl3)))

I set license to GPL3+.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 75488@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75488
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help