[PATCH] gnu: Add doom-runner.

  • Done
  • quality assurance status badge
Details
2 participants
  • ???
  • Andrew Wong
Owner
unassigned
Submitted by
Andrew Wong
Severity
normal
A
A
Andrew Wong wrote on 11 Jan 08:24 +0100
(address . guix-patches@gnu.org)(name . Andrew Wong)(address . wongandj@icloud.com)
bbca210fd0d1d60d4752dde4431c9f94ca5527fa.1736580280.git.wongandj@icloud.com
* gnu/packages/games.scm (doom-runner): New variable.

Change-Id: I986299789ab1c73b6a918226fdb33558355c0269
---
gnu/packages/games.scm | 52 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

Toggle diff (67 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index fb8018e271..ac6b0d314f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1517,6 +1517,58 @@ (define-public deal
license:gpl1+ ;ansidecl.h
license:bsd-3)))) ;random.c
+(define-public doom-runner
+ (package
+ (name "doom-runner")
+ (version "1.8.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Youda008/DoomRunner")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rpywq95zy9w0wj1262x4rf84c52wg1rgf0by549qph6fybn34rn"))))
+ (build-system qt-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (substitute* "DoomRunner.pro"
+ (("/usr")
+ #$output))
+ (invoke "qmake" "DoomRunner.pro" "-spec" "linux-g++"
+ "\"CONFIG+=release\"")))
+ (add-after 'install 'install-xdg
+ (lambda _
+ (with-directory-excursion "Install/XDG"
+ (install-file "DoomRunner.desktop"
+ (string-append #$output
+ "/share/applications"))
+ (let ((install-icon
+ (lambda (size)
+ (install-file (simple-format
+ #f "DoomRunner.~sx~s.png"
+ size size)
+ (simple-format
+ #f "~a/share/icons/hicolor/~sx~s/apps"
+ #$output size size)))))
+ (for-each install-icon
+ '(16 24 32 48 64 128)))))))))
+ (home-page "https://github.com/Youda008/DoomRunner")
+ (synopsis "Launcher for Doom engine games")
+ (description
+ "Doom Runner is yet another launcher of common Doom source ports (like
+GZDoom, Zandronum, PrBoom, ...) with graphical user interface. It is
+written in C++ and Qt, and it is designed around the idea of presets
+for various multi-file modifications to allow one-click switching
+between them and minimize any repetitive work.")
+ (license license:gpl3)))
+
(define-public falltergeist
(package
(name "falltergeist")

base-commit: f15ca836e4686496f675308655c370c95e9f52b7
--
2.47.1
?
(name . Andrew Wong)(address . wongandj@icloud.com)
87a5bvsgqe.fsf@envs.net
Andrew Wong <wongandj@icloud.com> writes:

Toggle quote (2 lines)
> * gnu/packages/games.scm (doom-runner): New variable.

Pushed to master, thank you!

It seems my email can't reach icloud though.
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75487@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75487
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch