[PATCH] gnu: liquidprompt: Patch additional utilities

  • Open
  • quality assurance status badge
Details
One participant
  • Sisiutl
Owner
unassigned
Submitted by
Sisiutl
Severity
normal
S
S
Sisiutl wrote 14 hours ago
(address . guix-patches@gnu.org)(name . Sisiutl)(address . sisiutl@egregore.fun)
20241120162937.15722-1-sisiutl@egregore.fun
* gnu/packages/shellutils.scm (liquidprompt)
[inputs]: Add coreutils and inetutils.
[arguments]<#:phases>: Replace the paths of more utilites

Change-Id: I84578ca40300a7527a23e5d8c3257d49be911a7b
---
gnu/packages/shellutils.scm | 20 +++++++++++++-------
1 file changed, 13 insertions(+), 7 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 7e9f85a5f2..74e9429de0 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -47,6 +47,7 @@ (define-module (gnu packages shellutils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
@@ -946,14 +947,19 @@ (define-public liquidprompt
(string-append "source "
#$output
"/share/liquidprompt/liquidprompt")))))
- (add-after 'fix-plugin 'fix-tput-path
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "liquidprompt"
- (("([ (])tput " all beginning)
+ (add-after 'fix-plugin 'fix-utils-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "liquidprompt"
+ (("([ (])\\\\?(tput|hostname|cksum|uname|tty|grep)([) ])"
+ all beginning command ending)
(string-append beginning
- (search-input-file inputs "bin/tput")
- " "))))))))
- (inputs (list ncurses))
+ (search-input-file
+ inputs
+ (string-append "bin/" command))
+ ending))))))))
+ (inputs (list ncurses
+ coreutils
+ inetutils))
(synopsis "Full-featured prompt for Bash & Zsh")
(description
"Liquidprompt is an adaptive prompt for Bash and Zsh that gives
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74446@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74446
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch