[PATCH] gnu: python-pyopengl: Add support for additional GL platforms.

  • Open
  • quality assurance status badge
Details
One participant
  • Sisiutl
Owner
unassigned
Submitted by
Sisiutl
Severity
normal
S
S
Sisiutl wrote 19 hours ago
(address . guix-patches@gnu.org)(name . Sisiutl)(address . sisiutl@egregore.fun)
20241120113213.18100-1-sisiutl@egregore.fun
* gnu/packages/python-xyz.scm (python-pyopengl)[arguments]:
Fix paths for non-GLX platforms too.

Change-Id: Ib50d5c64ff73079c4ffa3bd3e03012a66591ddfc
---
gnu/packages/python-xyz.scm | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5083473c08..04af924a71 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25706,18 +25706,18 @@ (define-public python-pyopengl
(lambda* (#:key inputs outputs #:allow-other-keys)
(substitute* '("OpenGL/platform/ctypesloader.py")
(("filenames_to_try = \\[\\]") "filenames_to_try = [name]"))
- (substitute* '("OpenGL/platform/glx.py" "tests/check_glut_load.py")
- (("'GL'")
- (string-append "'" (assoc-ref inputs "mesa") "/lib/libGL.so'"))
+ (substitute* '("OpenGL/platform/glx.py"
+ "OpenGL/platform/egl.py"
+ "OpenGL/platform/osmesa.py"
+ "OpenGL/platform/darwin.py"
+ "tests/check_glut_load.py")
(("'GLU'")
(string-append "'" (assoc-ref inputs "glu") "/lib/libGLU.so'"))
(("'glut',")
(string-append "'" (assoc-ref inputs "freeglut") "/lib/libglut.so',"))
- (("'GLESv1_CM'")
- (string-append "'" (assoc-ref inputs "mesa") "/lib/libGLESv1_CM.so'"))
- (("'GLESv2'")
- (string-append "'" (assoc-ref inputs "mesa") "/lib/libGLESv2.so'")))
- ;; Not providing libgle. It seems to be very old.
+ (("'(GL|EGL|GLESv1_CM|GLESv2|OSMesa)'" all gl-library)
+ (string-append "'" (assoc-ref inputs "mesa") (string-append "/lib/lib" gl-library ".so'"))))
+ ;; Not providing libgle. It seems to be very old.
#t)))))
(home-page "https://pyopengl.sourceforge.net")
(synopsis "Standard OpenGL bindings for Python")
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74443@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74443
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch