(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
Enables reproducible building on machines with have a different
arch-suffix in uname output, e.g.:
Machine·characteristics:·Linux-x.x.x-arch1-1-x86_64-with-glibc2.39
vs.
Machine·characteristics:·Linux-x.x.x-arch2-1-x86_64-with-glibc2.39
Will become
Machine·characteristics:·Linux-x.x.x-archx-x-x86_64-with-glibc2.39
Change-Id: Icc37a298c0c2d16e96f2c8eaf5aa4781cc4e5ac4
---
gnu/packages/maths.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (19 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 62b4f63ac9..d76937265d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3421,8 +3421,8 @@ (define-public petsc
(substitute* (find-files "." "^petsc(conf|machineinfo).h$")
;; Prevent build directory from leaking into compiled code
(((getcwd)) out)
- (("Machine characteristics: Linux-[0-9]+\\.[0-9]+\\.[0-9]+")
- "Machine characteristics: Linux-x.x.x"))
+ (("Machine characteristics: Linux-[0-9]+\\.[0-9]+\\.[0-9]+-arch[0-9]+-[0-9]+")
+ "Machine characteristics: Linux-x.x.x-archx-x"))
(substitute* (find-files "." "petscvariables")
;; Do not expose build machine characteristics, set to defaults.
(("MAKE_NP = [[:digit:]]+") "MAKE_NP = 2")
base-commit: 23cbbe6860782c5d4a0ba599ea1cda0642e91661
--
2.44.0