[PATCH] gnu: Add spritely-libp2p-daemon.

  • Open
  • quality assurance status badge
Details
One participant
  • Giacomo Leidi
Owner
unassigned
Submitted by
Giacomo Leidi
Severity
normal
G
G
Giacomo Leidi wrote 4 days ago
(address . guix-patches@gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
ac26775cbbe059fb2c3906d5b37379bde5434fcd.1731876356.git.goodoldpaul@autistici.org
* gnu/packages/ipfs.scm (spritely-libp2p-daemon): New variable.

Change-Id: Ic47e24bc53cb8da89be2c064569feae77764a03b
---
gnu/packages/ipfs.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index d5849a3f18..8cff215e64 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2024 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1217,3 +1218,37 @@ (define-public kubo
(define-public go-ipfs
(deprecated-package "go-ipfs" kubo))
+
+(define-public spritely-libp2p-daemon
+ (let ((version "0.1")
+ (commit "ae96196af1b68a5e23e58fa4afa818878b252a3d")
+ (revision "0"))
+ (package
+ (name "spritely-libp2p-daemon")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/spritely/go-libp2p-daemon.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dcdn7nlysynl7yrbivv8m7j83jq7pabhcff8mvfjdk583rgnkp2"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "gitlab.com/spritely/spritely-libp2p-daemon"
+ #:tests? #f))
+ (propagated-inputs
+ (list go-github-com-libp2p-go-libp2p
+ go-github-com-libp2p-go-libp2p-peer
+ go-github-com-libp2p-go-libp2p-crypto
+ go-github-com-multiformats-go-multiaddr))
+ (home-page "https://gitlab.com/spritely/go-libp2p-daemon")
+ (synopsis "Simple daemon to connect over libp2p")
+ (description "This package provides a very simple daemon to interface to
+from other programming languages. It's designed to fulfill the needs of
+Spritely's Goblins library to support libp2p as a netlayer.")
+ (license license:asl2.0))))

base-commit: d108a7aac2c51f21c55cb8ea8801629a97f5242a
--
2.46.0
G
G
Giacomo Leidi wrote 10 hours ago
[PATCH v2] gnu: Add spritely-libp2p-daemon.
(address . 74407@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
060c9d80a646cfe6e7673cfb77dee4f466bb077f.1732146007.git.goodoldpaul@autistici.org
* gnu/packages/ipfs.scm (spritely-libp2p-daemon): New variable.

Change-Id: Ic47e24bc53cb8da89be2c064569feae77764a03b
---
gnu/packages/ipfs.scm | 54 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)

Toggle diff (73 lines)
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index d5849a3f18..8025e99d19 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2024 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1217,3 +1218,56 @@ (define-public kubo
(define-public go-ipfs
(deprecated-package "go-ipfs" kubo))
+
+(define-public spritely-libp2p-daemon
+ (let ((version "0.1")
+ (commit "ae96196af1b68a5e23e58fa4afa818878b252a3d")
+ (revision "0"))
+ (package
+ (name "spritely-libp2p-daemon")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/spritely/go-libp2p-daemon.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1g4szjm2rxvrgcir9gdn81bsnybvb7hc3dwymc3yarslwsr1h3qf"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "gitlab.com/spritely/spritely-libp2p-daemon"
+ #:tests? #f
+ #:install-source? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; libp2p-asn-util uses go://embed to embed a file, but Go
+ ;; does *not* accept files that are symlinks. Guix sets up
+ ;; all dependency files as symlinks, though. To work around
+ ;; this, we delete the symlink and copy over the file to be
+ ;; embedded.
+ (add-after 'unpack 'fix-libp2p-asn-util-embed
+ (lambda _
+ (let ((file-name
+ (string-append
+ "src/github.com/libp2p/go-libp2p-asn-util/"
+ "sorted-network-list.bin")))
+ (delete-file file-name)
+ (copy-file
+ (string-append #$go-github-com-libp2p-go-libp2p-asn-util
+ "/" file-name)
+ file-name)))))))
+ (propagated-inputs
+ (list go-github-com-libp2p-go-libp2p
+ go-github-com-libp2p-go-libp2p-peer
+ go-github-com-libp2p-go-libp2p-crypto
+ go-github-com-multiformats-go-multiaddr))
+ (home-page "https://gitlab.com/spritely/go-libp2p-daemon")
+ (synopsis "Simple daemon to connect over libp2p")
+ (description "This package provides a very simple daemon to interface to
+from other programming languages. It's designed to fulfill the needs of
+Spritely's Goblins library to support libp2p as a netlayer.")
+ (license license:asl2.0))))

base-commit: d108a7aac2c51f21c55cb8ea8801629a97f5242a
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74407@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74407
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch