[PATCH 0/2] gnu: sslh: Update to 2.1.2.

  • Open
  • quality assurance status badge
Details
One participant
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote 4 days ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1731833680.git.poptsov.artyom@gmail.com
This patchset updates sslh to 2.1.2 and fixes its build.

Unfortunately I had to disable "tcp-wrappers" as it leads to linker errors due
to missing "allow_severity" and "deny_severity". As a reference, MPD
(MusicPlayerDaemon) author decided to solve the same problem simply by
dropping "tcp-wrappers" support altogether:

Also I had to disable "libcap" support for now as tests would fail with
"permission denied" error. It is sub-optimal indeed, but at least now tests
run without such errors.

Artyom V. Poptsov (2):
gnu: sslh: Update to 2.1.2.
gnu: sslh: Use GEXPs.

gnu/packages/networking.scm | 63 ++++++++++++++++++++-----------------
1 file changed, 34 insertions(+), 29 deletions(-)


base-commit: 0e1ffbc7f5f060f89c890472377a6102f27f6e9b
--
2.46.0
A
A
Artyom V. Poptsov wrote 4 days ago
[PATCH 1/2] gnu: sslh: Update to 2.1.2.
(address . 74391@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
5efc66babbe61a9cc66a9de1f635bca5fd8fd377.1731833680.git.poptsov.artyom@gmail.com
* gnu/packages/networking.scm (sslh): Update to 2.1.2.
[native-inputs]: Add pcre2.
[inputs]: Remove tcp-wrappers and libcap. Add libev.
[arguments]<phases>: Patch tests; disable a failing test.
<make-flags>: Disable USELIBCAP as it leads to "permission denied" errors.
Disable USELIBWRAP as it leads to linker errors. Add USELIBCONFIG.

Change-Id: I20ba6e5ec1af4c7666d2b1f9870c850207e9c2c9
---
gnu/packages/networking.scm | 28 ++++++++++++++++++----------
1 file changed, 18 insertions(+), 10 deletions(-)

Toggle diff (77 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f0f0619161..091ed06d3d 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -147,6 +147,7 @@ (define-module (gnu packages networking)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages logging)
#:use-module (gnu packages lua)
#:use-module (gnu packages kerberos)
#:use-module (gnu packages man)
@@ -2716,7 +2717,7 @@ (define-public enet-moonlight
(define-public sslh
(package
(name "sslh")
- (version "1.21c")
+ (version "2.1.2")
(source
(origin
(method git-fetch)
@@ -2725,28 +2726,36 @@ (define-public sslh
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "19h32dn0076p3s7dn35qi5yp2xvnxw9sqphppmn72vyb8caxvw1z"))))
+ (base32 "0v4wmwcjqlpiagq2q30v7459ffvxb7i6kvjq1av6ajdd5iib2vpq"))))
(build-system gnu-build-system)
(native-inputs
(list ;; Test dependencies.
lcov
+ pcre2
perl
perl-conf-libconfig
perl-io-socket-inet6
perl-socket6
psmisc)) ; for ‘killall’
(inputs
- (list libcap libconfig pcre tcp-wrappers))
+ (list libev libconfig pcre))
(arguments
`(#:phases
(modify-phases %standard-phases
- (delete 'configure) ; no configure script
(add-before 'check 'fix-tests
(lambda _
- (substitute* "./t"
- (("\"/tmp") "$ENV{\"TMPDIR\"} . \"")
- ;; The Guix build environment lacks ‘ip6-localhost’.
- (("ip6-localhost") "localhost"))
+ (substitute* "t"
+ ;; XXX: Disable a failing test.
+ (("my \\$DROP_CNX = 1;")
+ "my $DROP_CNX = 0;")
+ ;; XXX: "sslh-select" seems to not support this option for some
+ ;; reason. According to "sslhconf.cfg" this option just overrides the
+ ;; verbosity configuration so it seems that we can safely drop it.
+ (("-v 4")
+ ""))
+ (substitute* "test.cfg"
+ ;; The Guix build environment lacks ‘ip4-localhost’.
+ (("ip4-localhost") "localhost"))
#t))
;; Many of these files are mentioned in the man page. Install them.
(add-after 'install 'install-documentation
@@ -2761,8 +2770,7 @@ (define-public sslh
(find-files "scripts"))))
#t)))
#:make-flags (list ,(string-append "CC=" (cc-for-target))
- "USELIBCAP=1"
- "USELIBWRAP=1"
+ "USELIBCONFIG=1"
(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:test-target "test"))
(home-page "https://www.rutschle.net/tech/sslh/README.html")
--
2.46.0
A
A
Artyom V. Poptsov wrote 4 days ago
[PATCH 2/2] gnu: sslh: Use GEXPs.
(address . 74391@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
2924c8c2d1d1ee64f90867729d837724edf98119.1731833680.git.poptsov.artyom@gmail.com
* gnu/packages/networking.scm (sslh): Use GEXPs.

Change-Id: I5b31afdfeb1f1f9b2e5f86290adc405f3a90a367
---
gnu/packages/networking.scm | 61 ++++++++++++++++++-------------------
1 file changed, 29 insertions(+), 32 deletions(-)

Toggle diff (74 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 091ed06d3d..6017654866 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2740,38 +2740,35 @@ (define-public sslh
(inputs
(list libev libconfig pcre))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'fix-tests
- (lambda _
- (substitute* "t"
- ;; XXX: Disable a failing test.
- (("my \\$DROP_CNX = 1;")
- "my $DROP_CNX = 0;")
- ;; XXX: "sslh-select" seems to not support this option for some
- ;; reason. According to "sslhconf.cfg" this option just overrides the
- ;; verbosity configuration so it seems that we can safely drop it.
- (("-v 4")
- ""))
- (substitute* "test.cfg"
- ;; The Guix build environment lacks ‘ip4-localhost’.
- (("ip4-localhost") "localhost"))
- #t))
- ;; Many of these files are mentioned in the man page. Install them.
- (add-after 'install 'install-documentation
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/sslh")))
- (install-file "README.md" doc)
- (for-each
- (lambda (file)
- (install-file file (string-append doc "/examples")))
- (append (find-files "." "\\.cfg")
- (find-files "scripts"))))
- #t)))
- #:make-flags (list ,(string-append "CC=" (cc-for-target))
- "USELIBCONFIG=1"
- (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'fix-tests
+ (lambda _
+ (substitute* "t"
+ ;; XXX: Disable a failing test.
+ (("my \\$DROP_CNX = 1;")
+ "my $DROP_CNX = 0;")
+ ;; XXX: "sslh-select" seems to not support this option for some
+ ;; reason. According to "sslhconf.cfg" this option just overrides the
+ ;; verbosity configuration so it seems that we can safely drop it.
+ (("-v 4")
+ ""))
+ (substitute* "test.cfg"
+ ;; The Guix build environment lacks ‘ip4-localhost’.
+ (("ip4-localhost") "localhost"))))
+ ;; Many of these files are mentioned in the man page. Install them.
+ (add-after 'install 'install-documentation
+ (lambda _
+ (let* ((doc (string-append #$output "/share/doc/sslh")))
+ (install-file "README.md" doc)
+ (for-each
+ (lambda (file)
+ (install-file file (string-append doc "/examples")))
+ (append (find-files "." "\\.cfg")
+ (find-files "scripts")))))))
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ "USELIBCONFIG=1"
+ (string-append "PREFIX=" #$output))
#:test-target "test"))
(home-page "https://www.rutschle.net/tech/sslh/README.html")
(synopsis "Applicative network protocol demultiplexer")
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74391@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74391
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch