[PATCH] gnu: Add sdl3.

  • Open
  • quality assurance status badge
Details
One participant
  • dan
Owner
unassigned
Submitted by
dan
Severity
normal
D
D
dan wrote 4 days ago
(address . guix-patches@gnu.org)
a939f0dabea7bb598ff9add1fdc0d24d2d433da4.1731821565.git.i@dan.games
* gnu/packages/sdl.scm (sdl3): New variable.

Change-Id: I3e8c3c6290078da18139ce5375a8e1902a360f4a
---
gnu/packages/sdl.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 227846c042..0ed9d24f80 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -146,6 +146,40 @@ (define-public sdl2
(home-page "https://libsdl.org/")
(license license:bsd-3)))
+(define-public sdl3
+ (package
+ (inherit sdl2)
+ (name "sdl3")
+ (version "3.1.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libsdl-org/SDL")
+ ;; Change to release- when 3.2.0 is released.
+ (commit (string-append "preview-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1plyp0x8rvfwxpmfdjndj78kbfaisljjza700mvks4qyjjvmk2rh"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:configure-flags
+ #~(list "-DSDL_SHARED=ON"
+ "-DSDL_ALSA_SHARED=OFF"
+ "-DSDL_PULSEAUDIO_SHARED=OFF"
+ "-DSDL_X11_SHARED=OFF"
+ "-DSDL_WAYLAND_SHARED=OFF"
+ "-DSDL_KMSDRM=ON"
+ "-DSDL_KMSDRM_SHARED=OFF"
+ (string-append "-DCMAKE_INSTALL_RPATH="
+ (string-join
+ (list
+ (string-append #$(this-package-input "eudev") "/lib")
+ (string-append #$(this-package-input "vulkan-loader") "/lib"))
+ ";")))))))
+
(define-public sdl12-compat
(package
(name "sdl12-compat")

base-commit: 0e1ffbc7f5f060f89c890472377a6102f27f6e9b
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74388@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74388
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch