[PATCH] gnu: libx86emu: Fix build.

  • Done
  • quality assurance status badge
Details
One participant
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote 5 days ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
b647d3a149c94ee84cde1af3af7442633afa3416.1731745518.git.poptsov.artyom@gmail.com
* gnu/packages/virtualization.scm (libx86emu): Fix build.
[arguments]: Add extra "make-x86test" phase to make sure that "x86test" exists
before running the parallel tests.

Change-Id: Iad8d3fca6d4c04f6df9eba88e33e47324f160083
---
gnu/packages/virtualization.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 5c9461745c..b76180c3c6 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024 Jakob Kirsch <jakob.kirsch@web.de>
;;; Copyright © 2024 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -732,6 +733,12 @@ (define-public libx86emu
(string-append "LIBDIR = " lib "\n"))
(("/usr/include")
include)))))
+ ;; XXX: "make -C test" fails because it cannot find "x86test"
+ ;; executable due to parallel tests. So we need to make sure that
+ ;; this file is built before running the tests.
+ (add-before 'check 'make-x86test
+ (lambda _
+ (invoke "make" "-C" "test" "x86test")))
(delete 'configure)))) ;no configure script
(native-inputs (list nasm perl))
(synopsis "Library for x86 emulation")

base-commit: 3e8d3d80f41e016cdfe80e488a78c2351c94fef8
--
2.46.0
A
A
Artyom V. Poptsov wrote 5 days ago
(address . 74379-done@debbugs.gnu.org)
87a5dztr7t.fsf@gmail.com
Merged to the "master" branch as
b647d3a149c94ee84cde1af3af7442633afa3416.

- avp

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmc4cfkZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFfgpaD/9tuXgnyem6Pc81VlrjJbOs
2/ULjF8RJWJVyRxVSQsOBr/6Rn0ylw8dHZYppWhHh4lHCT5mEMuYts1krHb6diEk
SiybvK+38Zy4aElnbwdCVakTNu1GbDHwUEDapJdYKiJ5GiUEvkgvRAwHGkbPguSR
klqAyOUy/AfybNK+lCfPSxhrOMEHq5pc/aKiR/0jzSR5OklksvLyNvAqIkFqCyjL
kfPQkyZjxs7XXC4nMZSgA+d2lFpEp+sXWPgzQAiijdywOGNO6t+EUxaMnlcM6ipd
6BBsJnKXg1BOFBmZspyqKHHaQwHMpP9aIvqFLgndLYS/bUZdkPtEnhz/g6aznhuz
brsm+quWeq5axpdvhgfOcs7KR5dtkVXraZU0BcKGojdPMb0TtFbB21F2WVTMVU8C
pF4O7v6qOmPxGayk1pQhLZIqCvlBtTq8ulsGvZsq/g0eMvDTlZGgiU0FegC5tb/v
u4ObOKNtCnJAC56CMwiHQ6xOH7l4W7ymgYE4K6NagG4jvaGtqN4+Qe6NAfcFibwv
hO6csItALAqbvPOTu6teOGtrnNo2CGBdlm8Mnfj5vlIVc97U638l5x2aZsdqoWMg
abyz3PZOKOqnWdoLcZwSoPq8O/kkevBJRe9makFjBgiRH4X/GwWkj1ke2vs5E6/v
ks4+FAji0KEkxeJSCJNydg==
=wk0s
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74379@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74379
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch