(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
Change-Id: I1435b866babeb95af48e0fd970d931f022c8bc67
---
gnu/packages/maths.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)
Toggle diff (24 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index bb6c1648b5..89fb9291b8 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1726,7 +1726,14 @@ (define-public hdf5-1.14
;; modifies the test reference.
(substitute* "test/test_check_version.sh.in"
(("TESTING\\(\\).*" all)
- (string-append all "\nSKIP; exit 0\n")))))))))))
+ (string-append all "\nSKIP; exit 0\n")))))
+ (add-after 'patch-configure 'patch-configure-build-settings
+ (lambda _
+ (substitute* "src/H5build_settings.autotools.c.in"
+ ;; Don't record the build-time kernel version to make the
+ ;; library file reproducible.
+ (("@UNAME_INFO@")
+ "Linux"))))))))))
(define-public hdf5
;; Default version of HDF5.
base-commit: b10ce47d8be5b6c15987f4e1d93b3bd71b1eb220
--
2.44.0