[PATCH] gnu: libseat, seatd: Update to 0.9.1.

  • Done
  • quality assurance status badge
Details
One participant
  • Zheng Junjie
Owner
unassigned
Submitted by
Zheng Junjie
Severity
normal
Z
Z
Zheng Junjie wrote on 12 Nov 07:33 +0100
(address . guix-patches@gnu.org)
9271c6dd3db968b78931179dbec0a3cec3646d71.1731393185.git.zhengjunjie@iscas.ac.cn
* gnu/packages/admin.scm (libseat): Update to 0.9.1.
[arguments]: Use G-expressions.
[native-inputs]: Remove label.
[propagated-inputs]: Remove label.

(seatd): [arguments]: Use G-expressions.
[native-inputs]: Remove label.

Change-Id: I53ebe502ad80bc892e995749aae3387c42a79bad
---
gnu/packages/admin.scm | 30 +++++++++++++++---------------
1 file changed, 15 insertions(+), 15 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9c765b51a97..c0f12e308e4 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -5763,7 +5763,7 @@ (define-public wlgreet
(define-public libseat
(package
(name "libseat")
- (version "0.8.0")
+ (version "0.9.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5772,15 +5772,15 @@ (define-public libseat
(file-name (git-file-name name version))
(sha256
(base32
- "02wzrgp8di6hqmicnm2fim6jnvbn62wy248ikvdvrhiywrb7i931"))))
+ "1q1ih1f9v5240nlas1gz44giwq4k88p3yikfq7w0a4sw58yr6pz8"))))
(build-system meson-build-system)
(arguments
- `(#:configure-flags '("-Dlibseat-logind=elogind"
- "-Dserver=disabled")))
+ (list #:configure-flags #~(list "-Dlibseat-logind=elogind"
+ "-Dserver=disabled")))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(propagated-inputs
- `(("elogind" ,elogind)))
+ (list elogind))
(home-page "https://sr.ht/~kennylevinsen/seatd")
(synopsis "Seat management library")
(description
@@ -5793,16 +5793,16 @@ (define-public seatd
(inherit libseat)
(name "seatd")
(arguments
- `(#:configure-flags '("-Dlibseat-logind=elogind")
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'remove-libs
- (lambda* (#:key outputs #:allow-other-keys)
- (with-directory-excursion (assoc-ref outputs "out")
- (for-each delete-file-recursively '("lib" "include"))))))))
+ (list #:configure-flags #~(list "-Dlibseat-logind=elogind")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'remove-libs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-directory-excursion (assoc-ref outputs "out")
+ (for-each delete-file-recursively '("lib" "include"))))))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("scdoc" ,scdoc)))
+ (list pkg-config
+ scdoc))
(inputs '())
(synopsis "Seat management daemon")
(description

base-commit: 0cbd830ebb8ce802afe99c439ce7fdee448074be
--
2.46.0
Z
Z
Z572 wrote 22 hours ago
(address . 74317-done@debbugs.gnu.org)(name . Ricardo Wurmus)(address . rekado@elephly.net)
87r0762jrn.fsf@iscas.ac.cn
Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:

Toggle quote (76 lines)
> * gnu/packages/admin.scm (libseat): Update to 0.9.1.
> [arguments]: Use G-expressions.
> [native-inputs]: Remove label.
> [propagated-inputs]: Remove label.
>
> (seatd): [arguments]: Use G-expressions.
> [native-inputs]: Remove label.
>
> Change-Id: I53ebe502ad80bc892e995749aae3387c42a79bad
> ---
> gnu/packages/admin.scm | 30 +++++++++++++++---------------
> 1 file changed, 15 insertions(+), 15 deletions(-)
>
> diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
> index 9c765b51a97..c0f12e308e4 100644
> --- a/gnu/packages/admin.scm
> +++ b/gnu/packages/admin.scm
> @@ -5763,7 +5763,7 @@ (define-public wlgreet
> (define-public libseat
> (package
> (name "libseat")
> - (version "0.8.0")
> + (version "0.9.1")
> (source (origin
> (method git-fetch)
> (uri (git-reference
> @@ -5772,15 +5772,15 @@ (define-public libseat
> (file-name (git-file-name name version))
> (sha256
> (base32
> - "02wzrgp8di6hqmicnm2fim6jnvbn62wy248ikvdvrhiywrb7i931"))))
> + "1q1ih1f9v5240nlas1gz44giwq4k88p3yikfq7w0a4sw58yr6pz8"))))
> (build-system meson-build-system)
> (arguments
> - `(#:configure-flags '("-Dlibseat-logind=elogind"
> - "-Dserver=disabled")))
> + (list #:configure-flags #~(list "-Dlibseat-logind=elogind"
> + "-Dserver=disabled")))
> (native-inputs
> - `(("pkg-config" ,pkg-config)))
> + (list pkg-config))
> (propagated-inputs
> - `(("elogind" ,elogind)))
> + (list elogind))
> (home-page "https://sr.ht/~kennylevinsen/seatd")
> (synopsis "Seat management library")
> (description
> @@ -5793,16 +5793,16 @@ (define-public seatd
> (inherit libseat)
> (name "seatd")
> (arguments
> - `(#:configure-flags '("-Dlibseat-logind=elogind")
> - #:phases
> - (modify-phases %standard-phases
> - (add-after 'install 'remove-libs
> - (lambda* (#:key outputs #:allow-other-keys)
> - (with-directory-excursion (assoc-ref outputs "out")
> - (for-each delete-file-recursively '("lib" "include"))))))))
> + (list #:configure-flags #~(list "-Dlibseat-logind=elogind")
> + #:phases
> + #~(modify-phases %standard-phases
> + (add-after 'install 'remove-libs
> + (lambda* (#:key outputs #:allow-other-keys)
> + (with-directory-excursion (assoc-ref outputs "out")
> + (for-each delete-file-recursively '("lib" "include"))))))))
> (native-inputs
> - `(("pkg-config" ,pkg-config)
> - ("scdoc" ,scdoc)))
> + (list pkg-config
> + scdoc))
> (inputs '())
> (synopsis "Seat management daemon")
> (description
>
> base-commit: 0cbd830ebb8ce802afe99c439ce7fdee448074be

pushed, closing.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmc90GwACgkQO1qpk+Gi
3/C0RA//WXiZ7xPKWJX7Y4t8ox1KcBm5y6LJ60v8MuTC+zfEJ6LJXwia25Y4nQnA
eg01I+P+sIT3nNndQYTXXH1reSw1M57epPrfHa/qe781LqsyBOgIh1w2122JvYtX
cV6wwl2Lvi0fMvBTnrfJwKIttHzcio0563xy4SVYeS+pBCEbRcIDdLVUk6lCuLW6
1jlCYfIqwLjgZWQGR0Q85sceBLJ1DxJIwwq/a7Y45gm2QXgkQ83yWsMOIksbSwCg
K1rUlwPu2DU3MwcS36DmImVnLovQuY1m12hZuqMrj3GY43Tcz/++Bn8ytW7aa992
JxG7CNfmE5hfNVMCYYkChIdKBaRfnqEc5ufkheEBaYtHyUbswaYcc86mphWq98d7
ZR2h2EKIJgg+7EoFDvlQ24k3cLZn9r9S+w8EMw7fnIGMQsce1RzZX/GEwyEEWP/f
OZXTy/5L4VljWQsX/7Z0Q4OZDQbfbdi6hbF90HFwr38FTrIL5H/rthZjvTHDLOOw
RUyOoFeDeGj/2BFSy4c+nxUCPrqPYf541+80vpAjkOeSSzYKm0Sc1vmqY6M+1ox0
BbxvyACNt6kyHQdDFV9vSRcoAwO4oWpAr5WMcCQhZxGToBmojVFuaV2xmXSErwyK
acQnFn9JgpFyFB8BmGdTklhcN0cVrLwUiQ01ANgNPP+bvG3hpRU=
=Iz5I
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74317@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74317
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch