[PATCH 0/1] gnu: Add ptouch-print.

  • Open
  • quality assurance status badge
Details
One participant
  • Fredrik Salomonsson
Owner
unassigned
Submitted by
Fredrik Salomonsson
Severity
normal
F
F
Fredrik Salomonsson wrote on 12 Nov 04:18 +0100
(address . guix-patches@gnu.org)(name . Fredrik Salomonsson)(address . plattfot@posteo.net)
cover.1731381092.git.plattfot@posteo.net
Hi Guix,

Adding a package to be able to print labels with a Brother P-touch printer. I
tested this with a P700 and it worked fine. It installs the udev rules that
should allow any user to use this CLI tool without needing sudo. But I could
not get that to work. Might be my setup or that Guix System does not properly
support the uaccess tag. E.g. see the Arch Wiki [0] on what the uaccess tag
is suppose to trigger.


Fredrik Salomonsson (1):
gnu: Add ptouch-print.

gnu/packages/printers.scm | 55 +++++++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)


base-commit: b790db7589858fc77989b4d1f369c52bca6d6e7c
--
2.46.0
F
F
Fredrik Salomonsson wrote on 12 Nov 04:28 +0100
[PATCH 1/1] gnu: Add ptouch-print.
(address . 74315@debbugs.gnu.org)(name . Fredrik Salomonsson)(address . plattfot@posteo.net)
e78f169b2270122be75a945ef06e7ea7533d6476.1731381092.git.plattfot@posteo.net
* gnu/packages/printers.scm (ptouch-print): New variable.

Change-Id: I2ab2a80b80932af8566f6c5879e63e7b0bced747
---
gnu/packages/printers.scm | 55 +++++++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)

Toggle diff (83 lines)
diff --git a/gnu/packages/printers.scm b/gnu/packages/printers.scm
index 0069494b4d..995af76359 100644
--- a/gnu/packages/printers.scm
+++ b/gnu/packages/printers.scm
@@ -22,14 +22,18 @@ (define-module (gnu packages printers)
#:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages avahi)
+ #:use-module (gnu packages gd)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages golang-xyz)
#:use-module (gnu packages libusb)
#:use-module (gnu packages man)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages version-control)
#:use-module (gnu packages qt))
;; This is a module for packages related to printer-like devices, but not
@@ -69,6 +73,57 @@ (define-public ipp-usb
simply relay a TCP connection to USB do not work.")
(license license:bsd-2)))
+(define-public ptouch-print
+ (let ((commit "740b20e150e030aa2e75086d1202064f9c4c4090")
+ (revision "0"))
+ (package
+ (name "ptouch-print")
+ (version (git-version "1.5" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://git.familie-radermacher.ch/linux/ptouch-print.git")
+ (commit commit)))
+ (sha256
+ (base32 "17lw6gyb9hqdzdlypm98bdpnfjn74a3jrdd0rwic63a7072iqnzr"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ;no test target
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'patch-cmakefile
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ ;; Remove the internal override of CMAKE_INSTALL_PREFIX
+ (("set\\(CMAKE_INSTALL_PREFIX /usr\\)")
+ "")
+ ;; Remove hard coded udev install steps, installing it in the
+ ;; install-udev-rules phase
+ (("if\\(EXISTS /etc/udev/rules.d\\)
+\tinstall\\(FILES udev/90-usb-ptouch-permissions.rules DESTINATION /etc/udev/rules.d\\)
+\tinstall\\(CODE \"execute_process(COMMAND udevadm control --reload-rules)\"\\)
+endif\\(\\)
+")
+ "")) #t))
+ (add-after 'install 'install-udev-rules
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (rules (string-append out "/lib/udev/rules.d/")))
+ (install-file
+ "../source/udev/90-usb-ptouch-permissions.rules"
+ rules)))))))
+ (native-inputs (list gd git gettext-minimal libusb pkg-config))
+ (synopsis "CLI tool to print labels on Brother P-Touch printers")
+ (description
+ "A command line tool to print labels on Brother P-Touch
+printers on Linux. Note that there is no need to install the printer via CUPS, the
+printer is accessed directly via libusb.")
+ (home-page
+ "https://dominic.familie-radermacher.ch/projekte/ptouch-print/")
+ (license license:gpl3))))
+
(define-public robocut
(package
(name "robocut")
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74315@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74315
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch