[PATCH] gnu: Add flacon.

  • Open
  • quality assurance status badge
Details
One participant
  • Leo Famulari
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 11 Nov 00:54 +0100
(address . guix-patches@gnu.org)
e98756b2500edd17a2628f120879a5659c22571f.1731282889.git.leo@famulari.name
* gnu/packages/music.scm (flacon): New variable.

Change-Id: Id94a350e8650689d8dc48b55af36ac3ad4e1402f
---
gnu/packages/music.scm | 36 +++++++++++++++++++++++++++++++++++-
1 file changed, 35 insertions(+), 1 deletion(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 980bce6b30..deb6bdcac7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016, 2017, 2019, 2021-2024 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016, 2018, 2021 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2018, 2021, 2024 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
@@ -1331,6 +1331,40 @@ (define-public extempore
audio and video).")
(license license:bsd-2)))
+(define-public flacon
+ (package
+ (name "flacon")
+ (version "11.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/flacon/flacon")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (sha256
+ (base32 "0yp73yl5x9m2l4whrzj6yx8aqv1915khmlihgp1p12m9m540dql2"))))
+ (build-system cmake-build-system)
+ (arguments
+ ;; The tests fail while attempting to exercise MacOS functionality.
+ (list #:tests? #f))
+ (native-inputs (list pkg-config))
+ (inputs
+ (list qtbase-5
+ qttools-5
+ taglib
+ uchardet
+ zlib))
+ (home-page "https://flacon.github.io/")
+ (synopsis "Split audio tracks from an audio CD image to separate tracks")
+ (description "Flacon extracts individual tracks from one big audio file
+containing an entire CD of music and saves them as separate audio files. To do
+this, it uses information from the appropriate CUE file. Also, Flacon makes it
+possible to conveniently revise or specify tags both for all tracks at once or
+for each tag separately.")
+ (license license:lgpl2.1+)))
+
(define-public fluida-lv2
(package
(name "fluida-lv2")

base-commit: 9cdcfb52ace77fe3b497b21deb639a3027ff02f0
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74304@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74304
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch