(address . guix-patches@gnu.org)(name . Trevor Arjeski)(address . tmarjeski@gmail.com)
fzf-tab is a zsh plugin that replaces the default autocompletion with fzf so
that you can use fuzzy finding and multi-selection.
Change-Id: I821eb28c9ac12e8d6449ce7bc389538d260d6091
---
gnu/packages/shellutils.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
Toggle diff (39 lines)
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index be8d9bdc25..80ce5df719 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -912,3 +912,30 @@ (define-public liquidprompt
\"source \" liquidprompt \"/share/liquidprompt/themes/powerline/powerline.theme\"))))))
@end example\n")
(license license:agpl3+)))
+
+(define-public fzf-tab
+ (package
+ (name "fzf-tab")
+ (version "1.1.2")
+ (home-page "https://github.com/Aloxaf/fzf-tab")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Aloxaf/fzf-tab.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "061jjpgghn8d5q2m2cd2qdjwbz38qrcarldj16xvxbid4c137zs2"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan '(("lib" "/share/zsh/plugins/fzf-tab/")
+ ("modules" "/share/zsh/plugins/fzf-tab/")
+ ("fzf-tab.plugin.zsh" "/share/zsh/plugins/fzf-tab/")
+ ("fzf-tab.zsh" "/share/zsh/plugins/fzf-tab/")
+ ("README.md" "/share/doc/fzf-tab/"))))
+ (synopsis "Replace zsh's default completion menu with fzf.")
+ (description
+ "Replaces zsh's default completion menu with fzf, enabling fuzzy finding
+and multi-selection.")
+ (license license:expat)))
base-commit: fa7906d64881ee12e0c418136b44c73766e3d169
--
2.41.0