* gnu/packages/freedesktop.scm (udisks) [native-inputs]: Remove input labels.
[phases]: Remove trailing #t.
Change-Id: I805df6ac2e5ad96cf7a092d34354aefb12bd7586
---
gnu/packages/freedesktop.scm | 67 +++++++++++++++++-------------------
1 file changed, 31 insertions(+), 36 deletions(-)
Toggle diff (105 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 6941450436..bb0858cd9e 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -27,7 +27,7 @@
;;; Copyright © 2021 Robby Zambito <contact@robbyzambito.me>
;;; Copyright © 2021, 2022, 2023 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021, 2022 John Kehayias <john.kehayias@protonmail.com>
-;;; Copyright © 2021, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021, 2021, 2022, 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
@@ -1732,34 +1732,31 @@ (define-public udisks
"06cq52kp1nyy15qzylywy9s7hhhqc45k0s3y68crf0zsmjyng0yj"))))
(build-system gnu-build-system)
(native-inputs
- `(("docbook-xml" ,docbook-xml-4.3) ; to build the manpages
- ("docbook-xsl" ,docbook-xsl)
- ("glib:bin" ,glib "bin") ; for glib-mkenums
- ("gnome-common" ,gnome-common) ; TODO: Why is this needed?
- ("gobject-introspection" ,gobject-introspection)
- ("gtk-doc" ,gtk-doc/stable)
- ("intltool" ,intltool)
- ("pkg-config" ,pkg-config)
- ("xsltproc" ,libxslt)))
+ (list docbook-xml-4.3 ; to build the manpages
+ docbook-xsl
+ `(,glib "bin") ; for glib-mkenums
+ gnome-common ; TODO: Why is this needed?
+ gobject-introspection
+ gtk-doc/stable
+ intltool
+ pkg-config
+ libxslt))
(propagated-inputs
- (list glib)) ; required by udisks2.pc
+ (list glib)) ; required by udisks2.pc
(inputs
- `(,acl
- ;; TODO(staging): Make unconditional.
- ,@(if (%current-target-system)
- (list bash-minimal) ; for wrap-program
- '())
- ,cryptsetup
- ,libatasmart
- ,libblockdev
- ,libgudev
- ,polkit
- ,util-linux))
+ (list acl
+ bash-minimal
+ cryptsetup
+ libatasmart
+ libblockdev
+ libgudev
+ polkit
+ util-linux))
(outputs '("out"
- "doc")) ;5 MiB of gtk-doc HTML
+ "doc")) ;5 MiB of gtk-doc HTML
(arguments
- `(#:tests? #f ; requiring system message dbus
- #:disallowed-references ("doc") ;enforce separation of "doc"
+ `(#:tests? #f ; requiring system message dbus
+ #:disallowed-references ("doc") ;enforce separation of "doc"
#:configure-flags
(list "--enable-man"
"--enable-available-modules" ; Such as lvm2, btrfs, etc.
@@ -1786,15 +1783,14 @@ (define-public udisks
docbook-xml-catalog-file)))
#:phases
(modify-phases %standard-phases
- (add-before
- 'configure 'fix-girdir
- (lambda _
- ;; Install introspection data to its own output.
- (substitute* "udisks/Makefile.in"
- (("girdir = .*")
- "girdir = $(datadir)/gir-1.0\n")
- (("typelibsdir = .*")
- "typelibsdir = $(libdir)/girepository-1.0\n"))))
+ (add-before 'configure 'fix-girdir
+ (lambda _
+ ;; Install introspection data to its own output.
+ (substitute* "udisks/Makefile.in"
+ (("girdir = .*")
+ "girdir = $(datadir)/gir-1.0\n")
+ (("typelibsdir = .*")
+ "typelibsdir = $(libdir)/girepository-1.0\n"))))
(add-after 'install 'wrap-udisksd
(lambda* (#:key outputs inputs #:allow-other-keys)
;; Tell 'udisksd' where to find the 'mount' command.
@@ -1809,8 +1805,7 @@ (define-public udisks
;; partitions, e.g. in gnome-disks
,(string-append cryptsetup "/sbin")
"/run/current-system/profile/bin"
- "/run/current-system/profile/sbin")))
- #t))))))
+ "/run/current-system/profile/sbin")))))))))
(home-page "https://www.freedesktop.org/wiki/Software/udisks/")
(synopsis "Disk manager service")
(description
--
2.45.1