(address . guix-patches@gnu.org)
* gnu/packages/gtk.scm (gtk)[#:phases]<patch>: Add section dedicated to
failures on i686-linux.
---
gnu/packages/gtk.scm | 15 ++++++++++++++-
1 file changed, 14 insertions(+), 1 deletion(-)
Toggle diff (30 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index d5777ae67b..1c78a969f6 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1235,7 +1235,20 @@ (define-public gtk
;; The inscription-markup.ui fails due to /etc/machine-id
;; related warnings (see:
;; https://gitlab.gnome.org/GNOME/gtk/-/issues/5169).
- (("[ \t]*'inscription-markup.ui',") ""))))
+ (("[ \t]*'inscription-markup.ui',") ""))
+ ;; XXX: These failures appear specific to i686 – investigate them.
+ #$@(if (target-x86-32?)
+ #~((substitute* "testsuite/gsk/meson.build"
+ (("'empty-(fill|stroke)\\.node',") "")
+ (("'fill2?\\.node',") "")
+ (("'stroke\\.node',") "")
+ (("'fill-fractional-([a-z-]*)-nogl',") "")
+ (("\\[ 'path-special-cases' \\],") "")
+ (("\\[ '(path|curve)-special-cases' \\],") "")
+ (("\\[ 'path-private' \\],") ""))
+ (substitute* "testsuite/a11y/meson.build"
+ (("\\{ 'name': 'text(view)?' \\},") "")))
+ #~())))
(add-before 'build 'set-cache
(lambda _
(setenv "XDG_CACHE_HOME" (getcwd))))
base-commit: 4b5b1fa8125c3055ddea36f37e0c5311489e1563
--
2.41.0