(address . guix-patches@gnu.org)(address . ngraves@ngraves.fr)
This avoids the lint "the source file name should contain the package
name" with generated packages.
Change-Id: I61c81203d9f3cdd035e2b64a4c7a8d86d1f3dd50
---
guix/import/elpa.scm | 1 +
1 file changed, 1 insertion(+)
Toggle diff (14 lines)
diff --git a/guix/import/elpa.scm b/guix/import/elpa.scm
index d1855b36986..46b6dc98a20 100644
--- a/guix/import/elpa.scm
+++ b/guix/import/elpa.scm
@@ -250,6 +250,7 @@ (define ref
(uri (git-reference
(url ,url)
(commit ,commit)))
+ (file-name (git-file-name name version))
(sha256
(base32
,(bytevector->nix-base32-string
--
2.41.0