[PATCH 2/9] Update rust-heck

  • Done
  • quality assurance status badge
Details
One participant
  • Julian Flake
Owner
unassigned
Submitted by
Julian Flake
Severity
normal
J
J
Julian Flake wrote on 19 May 13:54 +0200
(address . guix-patches@gnu.org)(name . Julian Flake)(address . flake@uni-koblenz.de)
4ecca0692d6fde6afac59df316536c4359ceeca7.1716119149.git.flake@uni-koblenz.de
Change-Id: I7edaffd33fd725a2554e2cc6b89fb88b9e28f73a
---
gnu/packages/crates-io.scm | 19 ++++++++++++++++---
1 file changed, 16 insertions(+), 3 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 365db079b6..78b529946a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -28512,17 +28512,17 @@ (define-public rust-heapsize-plugin-0.1
total runtime size of an object on the heap")
(license license:mpl2.0)))
-(define-public rust-heck-0.4
+(define-public rust-heck-0.5
(package
(name "rust-heck")
- (version "0.4.1")
+ (version "0.5.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "heck" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1a7mqsnycv5z4z5vnv1k34548jzmc0ajic7c1j8jsaspnhw5ql4m"))))
+ (base32 "1sjmpsdl8czyh9ywl3qcsfsq9a307dg4ni2vnlwgnzzqhc4y0113"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -28536,6 +28536,19 @@ (define-public rust-heck-0.4
(license (list license:asl2.0
license:expat))))
+(define-public rust-heck-0.4
+ (package
+ (inherit rust-heck-0.5)
+ (name "rust-heck")
+ (version "0.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "heck" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1a7mqsnycv5z4z5vnv1k34548jzmc0ajic7c1j8jsaspnhw5ql4m"))))))
+
(define-public rust-heck-0.3
(package
(inherit rust-heck-0.4)
--
2.41.0
J
J
Julian Flake wrote on 19 May 14:39 +0200
close false issues
878r06ht68.fsf@uni-koblenz.de
should've been part of the series 71052
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71056@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71056
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch