(address . guix-patches@gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
This causes the test suite to run in about in nearly a third of the original
time (from 145 min to 52 minutes on a particular machine).
* gnu/packages/nss.scm (nss/fixed) [phases] {check}: Set NSS_CYCLES
environment variable to 'standard'.
Change-Id: I5dab1ed16b302af2276b0f075a790f6193edbe95
---
gnu/packages/nss.scm | 5 +++++
1 file changed, 5 insertions(+)
Toggle diff (20 lines)
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 80bf627583..8fb8a2fc99 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -288,6 +288,11 @@ (define-public nss/fixed
(substitute* "nss/tests/dbtests/dbtests.sh"
((" -lt 5") " -lt 50"))
+ ;; Since the test suite is very lengthy, run the test
+ ;; suite once, not thrice as done by default, by
+ ;; selecting only the 'standard' cycle.
+ (setenv "NSS_CYCLES" "standard")
+
;; The "PayPalEE.cert" certificate expires every six months,
;; leading to test failures:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To
base-commit: 898b5f30f3d485d48275c920da172863da9524c6
--
2.41.0