(address . bug-mumi@gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
Maintaining symbolic links to Debbugs data is not reasonable burden
for co-existing installations of various versions of Debbugs and Mumi.
This change further allows the location to be configured in an
operating-system declaration that syncronizes the data from
debbugs.gnu.org via a Shepherd timer. A patch with a 'configuration'
record is available but has not been submitted.
---
mumi/config.scm.in | 21 +++++++++++----------
1 file changed, 11 insertions(+), 10 deletions(-)
Toggle diff (36 lines)
diff --git a/mumi/config.scm.in b/mumi/config.scm.in
index eda815b..cf916fb 100644
--- a/mumi/config.scm.in
+++ b/mumi/config.scm.in
@@ -62,16 +62,17 @@
(string-replace dir "@prefix@"
0 (string-length "${prefix}"))
dir)))))
- (data-dir . ,(let ((maybe-dir
- (string-append (getcwd) "/data")))
- (if (and (getenv "MUMI_UNINSTALLED")
- (file-exists? maybe-dir))
- maybe-dir
- (let ((dir "@localstatedir@/mumi/data"))
- (if (string-prefix? "${prefix}" dir)
- (string-replace dir "@prefix@"
- 0 (string-length "${prefix}"))
- dir)))))
+ (data-dir . ,(or (getenv "DEBBUGS_DATA")
+ (let ((maybe-dir
+ (string-append (getcwd) "/data")))
+ (if (and (getenv "MUMI_UNINSTALLED")
+ (file-exists? maybe-dir))
+ maybe-dir
+ (let ((dir "@localstatedir@/mumi/data"))
+ (if (string-prefix? "${prefix}" dir)
+ (string-replace dir "@prefix@"
+ 0 (string-length "${prefix}"))
+ dir))))))
(host . "localhost")
(port . 1234)
(cache-ttl . 120)
base-commit: 99416ed5c7d950eaf54d52023a2efd975bccac92
--
2.41.0