(address . bug-mumi@gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
In most cases, providing HTTP headers with the charset is superior
to (and has precedence over) the declaration in an HTML <meta> tag:
A preview of this code is live at patchwise.org.
---
mumi/web/render.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (23 lines)
diff --git a/mumi/web/render.scm b/mumi/web/render.scm
index ad3ae0e..e867178 100644
--- a/mumi/web/render.scm
+++ b/mumi/web/render.scm
@@ -103,12 +103,12 @@
(define* (render-html sxml #:key (extra-headers '()))
(values (append extra-headers
- '((content-type . (text/html))))
+ '((content-type . (text/html (charset . "utf-8")))))
(lambda (port)
(sxml->html sxml port))))
(define (render-json json)
- (values '((content-type . (application/json)))
+ (values '((content-type . (application/json (charset . "utf-8"))))
(lambda (port)
(scm->json json port))))
base-commit: 99416ed5c7d950eaf54d52023a2efd975bccac92
--
2.41.0