(address . guix-patches@patchwise.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
* gnu/packages/guile-xyz.scm (guile-avatar): New variable.
For avatars in Mumi.
Change-Id: Ib255842ff8b59b7743c8d7be728a7ca7370024fe
---
gnu/packages/guile-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Toggle diff (43 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index dd56bffed9..8251493349 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -558,6 +558,34 @@ (define-public guile-aspell
dictionary and suggesting spelling corrections.")
(license license:gpl3+)))
+(define-public guile-avatar
+ (let ((commit "c2860952fd09ecc878c3d4f1ee2f1678668fbb7a")
+ (revision "0"))
+ (package
+ (name "guile-avatar")
+ (version (git-version "0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/lechner/guile-avatar")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dq9zcx4q3m5s3cpixq4zvlmdrlcc626mpqb7nmmj7vnda8k717f"))))
+ (build-system guile-build-system)
+ (arguments
+ (list
+ #:source-directory "scm"))
+ (inputs (list guile-3.0))
+ (propagated-inputs (list guile-hashing))
+ (home-page "https://codeberg.org/lechner/guile-avatar")
+ (synopsis "Get URLs for free avatar services from an email address")
+ (description
+ "Guile-Avatar helps you to determine URLs for free avatar services
+from the provided email address.")
+ (license license:agpl3+))))
+
(define-public guile2.0-bash
;; This project is currently retired. It was initially announced here:
;; <https://lists.gnu.org/archive/html/guile-user/2015-02/msg00003.html>.
base-commit: 703ae431f4ad28658e34675310b4fdf58685ccdd
--
2.41.0