* gnu/packages/astronomy.scm (python-drms, python-spherical-geometry,
python-asdf-coordinates-schemacs, python-asdf-wcs-schemas, python-rad)
[native-inputs]: Add python-setuptools and python-wheel.
(python-casa-formats-io, python-tweakwcs)[native-inputs]: Add
python-setuptools.
* gnu/packages/bioinformatics.scm (python-ega-download-client)
[native-inputs]: Add python-setuptools and python-wheel.
* gnu/packages/databases.scm (datasette)[native-inputs]: Add
python-pip.
* gnu/packages/django.scm (python-django-localflavor,
python-django-contact-form)[native-inputs]: Add python-setuptools and
python-wheel.
* gnu/packages/graphviz.scm (python-uqbar)[native-inputs]: Add
python-setuptools and python-wheel.
* gnu/packages/jupyter.scm (python-jupyterlab-server)[native-inputs]:
Add python-wheel.
(python-nbstripout)[native-inputs]: Add python-setuptools and
python-wheel.
* gnu/packages/machine-learning.scm (python-captum,
python-linear-operator, python-gpytorch)[native-inputs]: Add
python-setuptools.
* gnu/packages/music.scm (abjad, abjad-ext-rmarkers,
abjed-ext-nauert, python-mutagen)[native-inputs]: Add
python-setuptools and python-wheel.
* gnu/packages/package-management.scm
(python-conda-package-handling)[native-inputs]: Add python-setuptools
and python-wheel.
(conda)[native-inputs]: Add python-wheel.
* gnu/packages/python-check.scm (python-pyinstrument,
python-pytest-testmon, python-pytest-trio, python-nbval,
python-pytest-toolbox)[native-inputs]: Add python-setuptools and
python-wheel.
(python-nptyping)[native-inputs]: Add python-setuptools.
* gnu/packages/python-check.scm (python-dask-expr)[native-inputs]:
Add python-setuptools and python-wheel.
* gnu/packages/python-web.scm (parfive, python-aioftp, python-hupper,
python-sanic, python-mechanicalsoup, python-tinycss, python-aiostream,
python-cbor2, gunicorn)[native-inputs]: Add python-setuptools and
python-wheel.
* gnu/packages/python-xyz.scm (python-apprise, python-jaraco-classes,
python-sparse, python-shtab, python-pyan3)[native-inputs]: Add
python-setuptools.
(python-jupytext, python-orderedmultidict, python-ukkonen,
python-identify, python-nodeenv, python-cfgv, python-zarr,
python-multipart, python-nbconvert, python-cram, python-immutables,
python-numpydoc, python-cairosvg, python-unidecode, python-black,
python-multidict, python-mpv-jsonipc, python-humanize,
python-cmd2)[native-inputs]: Add python-setuptools and python-wheel.
(python-partd, python-dask, python-zarr)[native-inputs]: Add
python-wheel.
(python-nbconvert)[propagated-inputs]: Add texlive-etoolbox. Remove
duplicate textlive-jknapltx.
(python-isort)[native-inputs]: Add python-pip.
* gnu/packages/simulation.scm (python-fenics-dijitso)[native-inputs]:
Add python-setuptools and python-wheel.
* gnu/packages/sphinx.scm (python-pydata-sphinx-theme,
python-sphinx-autodoc-typehints)[native-inputs]: Add
python-setuptools.
* gnu/packages/syndication.scm (tuir)[native-inputs]: Add
python-setuptools and python-wheel.
* gnu/packages/terminals.scm (python-halo)[native-inputs]: Add
python-setuptools and python-wheel.
* gnu/packages/time.scm (python-arrow, python-dateutil)
[native-inputs]: Add python-setuptools and python-wheel.
* gnu/packages/version-control.scm (pre-commit)[native-inputs]: Add
python-setuptools and python-wheel.
* gnu/packages/virtualization.scm (python-qemu-qmp,
python-transient)[native-inputs]: Add python-setuptools and
python-wheel.
* gnu/packages/xorg.scm (python-xcffib)[native-inputs]: Add
python-setuptools and python-wheel.
Change-Id: Id61cf8cdc47bd4c2871c0a9c8e9a5bfd51157df0
---
gnu/packages/astronomy.scm | 25 +++++++----
gnu/packages/bioinformatics.scm | 9 +++-
gnu/packages/databases.scm | 1 +
gnu/packages/django.scm | 2 +
gnu/packages/graphviz.scm | 4 +-
gnu/packages/jupyter.scm | 7 +++-
gnu/packages/machine-learning.scm | 4 +-
gnu/packages/music.scm | 10 ++---
gnu/packages/package-management.scm | 12 ++++--
gnu/packages/python-check.scm | 17 +++++---
gnu/packages/python-science.scm | 4 +-
gnu/packages/python-web.scm | 46 +++++++++++++++------
gnu/packages/python-xyz.scm | 64 +++++++++++++++++++----------
gnu/packages/simulation.scm | 2 +-
gnu/packages/sphinx.scm | 4 +-
gnu/packages/syndication.scm | 4 +-
gnu/packages/terminals.scm | 2 +-
gnu/packages/time.scm | 10 +++--
gnu/packages/version-control.scm | 2 +
gnu/packages/virtualization.scm | 9 ++--
gnu/packages/xorg.scm | 4 +-
21 files changed, 169 insertions(+), 73 deletions(-)
Toggle diff (362 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index de5193d9b83..32c6f30e8f6 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2041,7 +2041,8 @@ (define-public python-casa-formats-io
(lambda _
(invoke "python" "setup.py" "build_ext" "--inplace"))))))
(native-inputs
- (list python-pytest python-pytest-cov python-pytest-openfiles))
+ (list python-pytest python-pytest-cov python-pytest-openfiles
+ python-setuptools))
(propagated-inputs
(list python-astropy python-click python-dask python-numpy))
(home-page "https://casa-formats-io.readthedocs.io/")
@@ -2254,9 +2255,11 @@ (define-public python-drms
(build-system pyproject-build-system)
(native-inputs
(list python-astropy
- python-pytest-astropy
python-pytest
- python-setuptools-scm))
+ python-pytest-astropy
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(propagated-inputs (list python-numpy python-pandas))
(home-page "https://sunpy.org")
(synopsis "Access astronomical HMI, AIA and MDI data with Python")
@@ -3230,7 +3233,9 @@ (define-public python-spherical-geometry
(native-inputs
(list python-pytest
python-pytest-astropy-header
- python-setuptools-scm))
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(inputs
(list qd))
(propagated-inputs
@@ -4607,6 +4612,7 @@ (define-public python-tweakwcs
python-pytest
python-pytest-cov
python-scipy
+ python-setuptools
python-setuptools-scm))
(home-page "https://tweakwcs.readthedocs.io/en/latest/")
(synopsis
@@ -4800,7 +4806,9 @@ (define python-asdf-coordinates-schemas
(native-inputs
(list python-pytest
python-pytest-xdist
- python-setuptools-scm))
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(propagated-inputs
(list python-asdf))
(home-page "https://github.com/asdf-format/asdf-coordinates-schemas")
@@ -4986,7 +4994,9 @@ (define python-asdf-wcs-schemas
(list python-asdf
python-pytest
python-pytest-openfiles
- python-setuptools-scm))
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(propagated-inputs
(list python-asdf-coordinates-schemas
python-asdf-standard
@@ -5053,7 +5063,8 @@ (define-public python-rad
;; python-rad -> python-roman-datamodels -> python-crds -> python-rad
#:test-flags #~(list "--ignore=tests/test_schemas.py")))
(native-inputs
- (list python-pytest python-setuptools-scm))
+ (list python-pytest python-setuptools
+ python-setuptools-scm python-wheel))
(propagated-inputs (list python-asdf python-asdf-astropy))
(home-page "https://github.com/spacetelescope/rad")
(synopsis "Roman Attribute Dictionary")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 47cca108658..a611caf715a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2771,8 +2771,13 @@ (define-public python-ega-download-client
(("==") ">=")))))))
(propagated-inputs (list python-htsget python-psutil python-requests
python-tqdm python-urllib3))
- (native-inputs (list python-coverage python-pytest python-pyfakefs
- python-responses python-mock))
+ (native-inputs (list python-coverage
+ python-mock
+ python-pyfakefs
+ python-pytest
+ python-responses
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/EGA-archive/ega-download-client")
(synopsis "EGA download client")
(description "PyEGA3 is a tool for viewing and downloading files from
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index a3a550c40c3..67e6ced7c32 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -5571,6 +5571,7 @@ (define-public datasette
(list python-beautifulsoup4
python-black
python-cogapp
+ python-pip
python-pytest
python-pytest-asyncio
python-pytest-runner
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 21099f0ff0f..4a271eaf0b5 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -294,6 +294,8 @@ (define-public python-django-localflavor
(if tests?
(apply invoke "python" "-m" "django" "test" test-flags)
(format #t "test suite not run~%")))))))
+ (native-inputs
+ (list python-setuptools python-wheel))
(propagated-inputs
(list python-django python-stdnum))
(home-page "https://django-localflavor.readthedocs.io/en/latest/")
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 2c23b6abd5c..db40b99928a 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -221,7 +221,9 @@ (define-public python-uqbar
python-isort
python-mypy
python-pytest
- python-pytest-cov))
+ python-pytest-cov
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-black python-sphinx-5 python-unidecode
(package/inherit python-sphinx-rtd-theme
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index cf3fa509966..e2bef079ba0 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -409,7 +409,8 @@ (define-public python-jupyterlab-server
python-requests-mock
python-ruamel.yaml
python-strict-rfc3339
- python-werkzeug))
+ python-werkzeug
+ python-wheel))
(home-page "https://jupyter.org")
(synopsis "Server components for JupyterLab applications")
(description "JupyterLab Server sits between JupyterLab and Jupyter
@@ -819,7 +820,9 @@ (define-public python-nbstripout
(list python-pytest
python-pytest-cram
python-pytest-flake8
- python-pytest-runner))
+ python-pytest-runner
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/kynan/nbstripout")
(synopsis "Strips outputs from Jupyter and IPython notebooks")
(description
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 21d58d9aae9..ba6f51b3f11 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -4535,7 +4535,7 @@ (define-public python-captum
python-parameterized
python-pytest
python-pytest-cov
- python-scikit-learn))
+ python-setuptools))
(home-page "https://captum.ai")
(synopsis "Model interpretability for PyTorch")
(description "Captum is a model interpretability and understanding library
@@ -5114,6 +5114,7 @@ (define-public python-linear-operator
(native-inputs (list python-flake8
python-flake8-print
python-pytest
+ python-setuptools
python-setuptools-scm
python-twine))
(home-page "https://github.com/cornellius-gp/linear_operator/")
@@ -5146,6 +5147,7 @@ (define-public python-gpytorch
python-flake8-print
python-nbval
python-pytest
+ python-setuptools
python-twine))
(home-page "https://gpytorch.ai")
(synopsis "Implementation of Gaussian Processes in PyTorch")
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 37fe94b56de..6b765dcb3d6 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1698,7 +1698,7 @@ (define-public abjad
(inputs
(list lilypond))
(native-inputs
- (list python-pytest))
+ (list python-pytest python-setuptools python-wheel))
(propagated-inputs
(list python-quicktions
python-ply
@@ -1730,7 +1730,7 @@ (define-public abjad-ext-rmakers
(base32 "1y8s55b4mlsigm0xkk6qjpp08c75rv0swvjp0lj3cs6lgqdjxdjl"))))
(build-system pyproject-build-system)
(native-inputs
- (list lilypond python-pytest))
+ (list lilypond python-pytest python-setuptools python-wheel))
(propagated-inputs
(list abjad))
(home-page "https://abjad.github.io")
@@ -1755,7 +1755,7 @@ (define-public abjad-ext-nauert
(base32 "0j4pf4h27jm3df0dn2rwkdx6zqcxvr7pqchbaa9rffz7q4hbakmf"))))
(build-system pyproject-build-system)
(native-inputs
- (list lilypond python-pytest))
+ (list lilypond python-pytest python-setuptools python-wheel))
(propagated-inputs
(list abjad))
(home-page "https://abjad.github.io")
@@ -3978,8 +3978,8 @@ (define-public python-mutagen
(("( +)@given" all spaces)
(string-append spaces "@settings(deadline=None)\n" all))))))))
(native-inputs
- (list python-pytest python-hypothesis python-flake8))
- (home-page "https://mutagen.readthedocs.io/")
+ (list python-pytest python-hypothesis python-flake8
+ python-setuptools python-wheel))
(synopsis "Read and write audio tags")
(description "Mutagen is a Python module to handle audio metadata. It
supports ASF, FLAC, M4A, Monkey’s Audio, MP3, Musepack, Ogg FLAC, Ogg Speex, Ogg
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 949c42e274b..feed16ebcef 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1143,8 +1143,13 @@ (define-public python-conda-package-handling
(inputs
(list libarchive))
(native-inputs
- (list python-cython python-pytest python-pytest-cov
- python-pytest-mock python-mock))
+ (list python-cython
+ python-mock
+ python-pytest
+ python-pytest-cov
+ python-pytest-mock
+ python-setuptools
+ python-wheel))
(home-page "https://conda.io")
(synopsis "Create and extract conda packages of various formats")
(description
@@ -1284,7 +1289,8 @@ (define-public conda
(list python-coverage
python-flaky
python-pytest-timeout
- python-pytest-xprocess))
+ python-pytest-xprocess
+ python-wheel))
(home-page "https://github.com/conda/conda")
(synopsis "Cross-platform, OS-agnostic, system-level binary package manager")
(description
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 46c8b3414e4..5571cee2088 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -377,7 +377,9 @@ (define-public python-pyinstrument
python-greenlet
python-pytest
python-pytest-asyncio
- python-pytest-trio))
+ python-pytest-trio
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/joerick/pyinstrument")
(synopsis "Call stack profiler for Python")
(description
@@ -1169,7 +1171,8 @@ (define-public python-pytest-testmon
(base32 "01qhbkb3n8c5c4id94w6b06q9wb7b6a33mqwyrkdfzk5pzv1gcyd"))))
(build-system pyproject-build-system)
(arguments (list #:tests? #false)) ;there are none
- (native-inputs (list python-coverage python-pytest))
+ (native-inputs (list python-coverage python-pytest
+ python-setuptools python-wheel))
(home-page "https://github.com/tarpas/pytest-testmon")
(synopsis "Selects tests affected by changed files and methods")
(description
@@ -1198,7 +1201,8 @@ (define-public python-pytest-trio
;; No keyboard interrupt in our build environment.
" and not test_actual_test"))))
(native-inputs
- (list python-hypothesis python-pytest python-pytest-cov))
+ (list python-hypothesis python-pytest python-pytest-cov
+ python-setuptools python-wheel))
(propagated-inputs
(list python-async-generator python-outcome python-pytest python-trio))
(home-page "https://github.com/python-trio/pytest-trio")
@@ -1487,7 +1491,8 @@ (define-public python-pytest-toolbox
(substitute* "setup.cfg"
((".*timeout.*") ""))))))))
(native-inputs
- (list python-pydantic python-pytest python-pytest-isort))
+ (list python-pydantic python-pytest python-pytest-isort
+ python-setuptools python-wheel))
(home-page "https://github.com/samuelcolvin/pytest-toolbox")
(synopsis "Numerous useful plugins for Pytest")
(description
@@ -1585,7 +1590,8 @@ (define-public python-nbval
(delete-file "tests/\
ipynb-test-samples/test-latex-pass-correctouput.ipynb"))))))
(native-inputs
- (list python-pytest python-pytest-cov python-sympy))
+ (list python-pytest python-pytest-cov python-setuptools python-sympy
+ python-wheel))
(propagated-inputs
(list python-ipykernel python-jupyter-client python-nbformat
python-six python-coverage))
@@ -2062,6 +2068,7 @@ (define-public python-nptyping
(native-inputs
(list python-beartype
python-mypy
+ python-setuptools
python-typeguard
python-wheel))
(propagated-inputs (list python-numpy python-typing-extensions))
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index dd4cffea8e1..f82feab0963 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -2157,7 +2157,9 @@ (define-public python-dask-expr
;; package without creating a mutually recursive dependency.
(list python-dask/bootstrap
python-pytest
- python-versioneer))
+ python-setuptools
+ python-versioneer
+ python-wheel))
(home-page "https://github.com/dask/dask-expr")
(synopsis "Dask DataFrames with query optimization")
(description "This is a rewrite of Dask DataFrame that includes query
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 05413fd2e7e..61ea8a63558 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -684,10 +684,12 @@ (define-public python-aiostream
"0l2ijb7yk0820wiyf6zrzx8fhzf8925an7r06mcaw3in1mr6rssq"))))
(build-system python-build-system)
(native-inputs
- (list python-pytest
+ (list python-setuptools
+ python-pytest
python-pytest-asyncio
python-pytest-cov
- python-pytest-runner))
+ python-pytest-runner
+ python-wheel))
(home-page "https://github.com/vxgmichel/aiostream")
(synopsis "Generator-based operators for asynchronous iteration")
(description "@