(address . guix-patches@gnu.org)(name . Richard Sent)(address . richard@freakingpenguin.com)
doc/guix.texi (G-Expressions): Document the use of assume-valid-file-name with
local-file.
---
Hi Guix!
I found it odd that assume-valid-file-name isn't documented in the
manual. Well, now it is!
doc/guix.texi | 12 ++++++++++++
1 file changed, 12 insertions(+)
Toggle diff (27 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 1c1e0164e7..221db5c022 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -12154,6 +12154,18 @@ G-Expressions
absolute file name and @var{stat} is the result of @code{lstat}; exclude
entries for which @var{select?} does not return true.
+@var{file} can be wrapped in the @code{assume-valid-file-name} syntactic
+keyword. When this is done, there will not be a warning when
+@code{local-file} is used with a non-literal path. The path is still
+looked up relative to the current working directory at run time.
+Wrapping is done like this:
+
+@lisp
+(define alice-key-file-path "alice.pub")
+;; ...
+(local-file (assume-valid-file-name alice-key-file-path))
+@end lisp
+
This is the declarative counterpart of the @code{interned-file} monadic
procedure (@pxref{The Store Monad, @code{interned-file}}).
@end deffn
base-commit: da41a8f5e85774e2a507d821b5d52e600fb9d1d7
--
2.41.0