(address . guix-patches@gnu.org)(name . Richard Sent)(address . richard@freakingpenguin.com)
As the manual suggests running a certbot command to view the issued
certificates, add it to the profile.
gnu/services/certbot.scm (certbot-service-type): Extend profile-service-type
with certbot-configuration-package.
Change-Id: I92618597bbdc8d838420b2e0f82de601b0bc609b
---
Hi Guix!
This is just a small enhancement to certbot-service-type to make it
easier to use. The manual suggests running a certbot command to view
the issued certificates ($ certbot certificates). So, adding the
configured certbot package to the profile improves ease of use.
gnu/services/certbot.scm | 2 ++
1 file changed, 2 insertions(+)
Toggle diff (17 lines)
diff --git a/gnu/services/certbot.scm b/gnu/services/certbot.scm
index f287c8367f..b276c49e0f 100644
--- a/gnu/services/certbot.scm
+++ b/gnu/services/certbot.scm
@@ -350,6 +350,8 @@ (define certbot-service-type
(extensions
(list (service-extension nginx-service-type
certbot-nginx-server-configurations)
+ (service-extension profile-service-type
+ (compose list certbot-configuration-package))
(service-extension activation-service-type
certbot-activation)
(service-extension mcron-service-type
base-commit: da41a8f5e85774e2a507d821b5d52e600fb9d1d7
--
2.41.0