(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
This adds binwarp from the stumpwm-contrib repository - first patch so let me know if there's anything missing :)
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -71,6 +71,7 @@
;;; Copyright © 2024 chris <chris@bumblehead.com>
;;; Copyright © 2024 Erik Eduardo Alonso Hernández <erik@erikeduardo.xyz>
;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
+;;; Copyright © 2024 bigbug <bigbookofbug@proton.me>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2590,6 +2591,22 @@ (define-public sbcl-stumpwm-pamixer
control module for StumpWM.")
(license license:gpl3))))
+(define-public sbcl-stumpwm-binwarp
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-binwarp")
+ (arguments
+ '(#:asd-systems '("binwarp")
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "util/binwarp") #t)))))
+ (home-page "https://github.com/stumpwm/stumpwm-contrib")
+ (synopsis "Keyboard-driven divide-and-conquer mouse control mode.")
+ (description "This package provides a new keyboard-driven keymap.")
+ (license (list license:gpl2+ license:gpl3+ license:bsd-2))))
+
(define-public sbcl-stumpwm-ttf-fonts
(package (inherit stumpwm-contrib)
Sent with [Proton Mail](https://proton.me/)secure email.