[PATCH] gnu: wm.scm: Add Binwarp to stumpwm-contrib

  • Done
  • quality assurance status badge
Details
2 participants
  • not emma
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
not emma
Severity
normal
N
N
not emma wrote on 6 May 17:50 +0200
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
NzFz2dTfxvkle-T4gZmeN_wJJemczxjHDIfktPzFuXeXEA3Tq7EK-0ICNhI3iA-RQEvJusoiDEwSuxMYYtEiHU_pYyvRB6kqO6PKFLGysJk=@proton.me
This adds binwarp from the stumpwm-contrib repository - first patch so let me know if there's anything missing :)

--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -71,6 +71,7 @@
;;; Copyright © 2024 chris <chris@bumblehead.com>
;;; Copyright © 2024 Erik Eduardo Alonso Hernández <erik@erikeduardo.xyz>
;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
+;;; Copyright © 2024 bigbug <bigbookofbug@proton.me>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2590,6 +2591,22 @@ (define-public sbcl-stumpwm-pamixer
control module for StumpWM.")
(license license:gpl3))))

+(define-public sbcl-stumpwm-binwarp
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-binwarp")
+ (arguments
+ '(#:asd-systems '("binwarp")
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "util/binwarp") #t)))))
+ (synopsis "Keyboard-driven divide-and-conquer mouse control mode.")
+ (description "This package provides a new keyboard-driven keymap.")
+ (license (list license:gpl2+ license:gpl3+ license:bsd-2))))
+
(define-public sbcl-stumpwm-ttf-fonts
(package (inherit stumpwm-contrib)

Sent with [Proton Mail](https://proton.me/)secure email.
Attachment: file
G
G
Guillaume Le Vaillant wrote on 9 May 16:57 +0200
(name . not emma)(address . bigbookofbug@proton.me)(address . 70803@debbugs.gnu.org)
87v83noww9.fsf@kitej
Hi.
The patch you sent is corrupted and does not apply.
It looks like your email client destroyed the indentation. Could you
send the patch again after setting your email client not to do that?
You can also sent the patch as an attached file if your email client
refuses to cooperate.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZjzkdg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j86lQEAhS0o+HcGKWiHI1BDeGByReI7j22XNbZ1nFrQ
teJ8yrUA/jU5Mksu7RXEkXlwndhgVOEz9SpPbRzlp9bEjNR43Gsl
=Bpp5
-----END PGP SIGNATURE-----

N
N
not emma wrote on 9 May 17:29 +0200
(name . 70803@debbugs.gnu.org)(address . 70803@debbugs.gnu.org)
9f4Lh2XMAGhxkqKVzuBVJUv_N26pr9ozlniKAvJkVQyO7u5nCkkS6oSKnRQRyQUUmDq-xDjnqp9bwnNR3XDrwH3q-uj_VaoNk35lmBMaTX8=@proton.me
Sent with Proton Mail secure email.

------- Forwarded Message -------
From: not emma <bigbookofbug@proton.me>
Date: On Thursday, May 9th, 2024 at 3:27 PM
Subject: Re: [bug#70803] [PATCH] gnu: wm.scm: Add Binwarp to stumpwm-contrib
To: Guillaume Le Vaillant <glv@posteo.net>


Toggle quote (16 lines)
> Thanks for the heads up! I'm attaching the diff as a text file - and will attatch the the modified wm.scm as well
>
>
>
>
> Sent with Proton Mail secure email.
>
>
> On Thursday, May 9th, 2024 at 2:57 PM, Guillaume Le Vaillant glv@posteo.net wrote:
>
> > Hi.
> > The patch you sent is corrupted and does not apply.
> > It looks like your email client destroyed the indentation. Could you
> > send the patch again after setting your email client not to do that?
> > You can also sent the patch as an attached file if your email client
> > refuses to cooperate.
Toggle diff (35 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f4c6dbda0a..19414eec53 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -71,6 +71,7 @@
;;; Copyright © 2024 chris <chris@bumblehead.com>
;;; Copyright © 2024 Erik Eduardo Alonso Hernández <erik@erikeduardo.xyz>
;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
+;;; Copyright © 2024 bigbug <bigbookofbug@proton.me>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2590,6 +2591,22 @@ (define-public sbcl-stumpwm-pamixer
control module for StumpWM.")
(license license:gpl3))))
+(define-public sbcl-stumpwm-binwarp
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-binwarp")
+ (arguments
+ '(#:asd-systems '("binwarp")
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "util/binwarp") #t)))))
+ (home-page "https://github.com/stumpwm/stumpwm-contrib")
+ (synopsis "Keyboard-driven divide-and-conquer mouse control mode.")
+ (description "This package provides a new keyboard-driven keymap.")
+ (license (list license:gpl2+ license:gpl3+ license:bsd-2))))
+
(define-public sbcl-stumpwm-ttf-fonts
(package
(inherit stumpwm-contrib)
Attachment: wm.scm
G
G
Guillaume Le Vaillant wrote on 9 May 18:19 +0200
Re: [bug#70803] [PATCH] gnu: wm.scm: Add Binwarp to stumpwm-contrib
(name . not emma)(address . bigbookofbug@proton.me)(name . 70803@debbugs.gnu.org)(address . 70803@debbugs.gnu.org)
87r0ebot4x.fsf@kitej
Patch applied as 360fea15cb25d0cdf55ec55488956257a0219fe4 with a few
minor modifications.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZjz3fg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8wJgD/ff/CYzyG49+38PhpZKS+q/IIarUFTbKMJhTf
xph5pRQA/1/esbjDpr/pRpahkycBUdsGgr9V1XWkBMafrcBPHy39
=N6jh
-----END PGP SIGNATURE-----

G
G
Guillaume Le Vaillant wrote on 9 May 18:21 +0200
(address . 70803-done@debbugs.gnu.org)
87msozot0p.fsf@kitej
Closing.
Closed
?