(address . guix-patches@gnu.org)
* gnu/packages/potassco.scm (python-clintest): New variable.
---
gnu/packages/potassco.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
Toggle diff (36 lines)
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index 43d9ea6647..6a124c5bba 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -612,3 +612,27 @@ (define-public python-clinguin
(description "Clinguin is a graphical user interface toolkit for clingo,
which allows user interfaces to be specified entirely as a logic program.")
(license license:expat)))
+
+(define-public python-clintest
+ (package
+ (name "python-clintest")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/potassco/clintest")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xzbby9ram55h87ykm652kgm45b8rlhbjc8gjkz308h1jnjllmmy"))))
+ (build-system pyproject-build-system)
+ (inputs (list python-clingo))
+ (home-page "https://potassco.org/clintest/")
+ (synopsis "Test framework for clingo programs")
+ (description "Clintest is a framework for unit testing clingo programs.
+It provides various components to assemble the most commonly used tests quickly,
+but also works fine along custom-built test. Clintest monitors the test
+outcome while solving to abort the search for solutions once the outcome is
+certain.")
+ (license license:expat)))
base-commit: 5c13ab50b9c7d44238c64e5337027f04ae1d9223
--
2.41.0