[PATCH] gnu: guile-tap: Update to 0.5.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Frank Terbeck
  • Christopher Baines
Owner
unassigned
Submitted by
Frank Terbeck
Severity
normal
F
F
Frank Terbeck wrote on 3 May 13:22 +0200
(address . guix-patches@gnu.org)(name . Frank Terbeck)(address . ft@bewatermyfriend.org)
20240503112223.1726868-1-ft@bewatermyfriend.org
* gnu/packages/guile-xyz.scm (guile-tap): Update to 0.5.0

Signed-off-by: Frank Terbeck <ft@bewatermyfriend.org>
Change-Id: Ia8a02400f1d559fcec7eb9861f24a7116928814b
---
This is my first contribution to Guix. I am the upstream for guile-tap,
and was positively surprised by "guix refresh". Good stuff! This is
basically the result of that.

Additionally, I've added a "substitute*" call for bin/tap-harness, to
replace the raw "guile" call in it with the full binary name via the
"which" utility. This is analogous to the shebang-rewriting that the
Guix does by default.

This is done because bin/tap-harness used to be a program that had guile
in it's shebang line, but now it is a shell script that calls out to
guile.

I am not sure if this is best practise, but I figured if this is done
for shebang lines, it should be correct for raw calls to an interpreter
line this as well.

gnu/packages/guile-xyz.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 9534341b70..875fe7ee24 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -6124,7 +6124,7 @@ (define-public lokke
(define-public guile-tap
(package
(name "guile-tap")
- (version "0.4.6")
+ (version "0.5.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -6133,7 +6133,7 @@ (define-public guile-tap
(file-name (git-file-name name version))
(sha256
(base32
- "04ip5cbvsjjcicsri813f4711yh7db6fvc2px4788rl8p1iqvi6x"))))
+ "0yimi9ci5h6wh7bs3ir7p181pwbd2hxlhx7pqq53gr54mnad8qv4"))))
(build-system gnu-build-system)
(arguments
(list #:phases
@@ -6142,7 +6142,9 @@ (define-public guile-tap
(lambda _
(substitute* "Makefile"
(("PREFIX = /usr/local") (string-append "PREFIX="
- #$output)))))
+ #$output)))
+ (substitute* "bin/tap-harness"
+ ((" guile ") (string-append " " (which "guile") " ")))))
(replace 'build
(lambda _
(invoke "make")
--
2.43.0
C
C
Christopher Baines wrote on 12 May 20:36 +0200
(name . Frank Terbeck)(address . ft@bewatermyfriend.org)(address . 70733-done@debbugs.gnu.org)
87o79a7u85.fsf@cbaines.net
Frank Terbeck <ft@bewatermyfriend.org> writes:

Toggle quote (25 lines)
> * gnu/packages/guile-xyz.scm (guile-tap): Update to 0.5.0
>
> Signed-off-by: Frank Terbeck <ft@bewatermyfriend.org>
> Change-Id: Ia8a02400f1d559fcec7eb9861f24a7116928814b
> ---
> This is my first contribution to Guix. I am the upstream for guile-tap,
> and was positively surprised by "guix refresh". Good stuff! This is
> basically the result of that.
>
> Additionally, I've added a "substitute*" call for bin/tap-harness, to
> replace the raw "guile" call in it with the full binary name via the
> "which" utility. This is analogous to the shebang-rewriting that the
> Guix does by default.
>
> This is done because bin/tap-harness used to be a program that had guile
> in it's shebang line, but now it is a shell script that calls out to
> guile.
>
> I am not sure if this is best practise, but I figured if this is done
> for shebang lines, it should be correct for raw calls to an interpreter
> line this as well.
>
> gnu/packages/guile-xyz.scm | 8 +++++---
> 1 file changed, 5 insertions(+), 3 deletions(-)

Thanks for the patch Frank, it looks good and I think substituting the
full guile filename in tap-harness is correct.

I've pushed it to master as d2b9736c5e4c87af8264304d528c517633a282aa.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmZBDDpfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfmoxAAuLAEgGk4IUF7JrK+Al/DwLWSAJhxjaMR
FrQDuuyNE+ZhtDce61BrGLPMbdI47Px6gX7arNayp5HJstg+nX6+sPS2RlblN+d/
Gh82naDWGRsUB0+NSl0r9trNiNNe7POfIfRpvO4Te0RQ+9iMSxD6P9vuKQkPCqr4
O6KI4JpAc0rGRrkfcnw2SljgIIKO7C3Vbx9/gaPGxolejfaLcjJeyjmqiogdZHWm
0g6Ngc/r5WOEkvRJ0cnNExL/579G6LhaaRD3GINfO0cwmZlK8sKWk1aPj9SJDrzx
cAI93XuQB9AGt2m6DAfGNQKzqas7qrQ/DlfrTQvYA1Y7T9Gd4V5HSSQcNSeG7FDm
XL9xXsephAmfW3Dfm+L6u2sIxy8rqRsSAmd59mckYltn6/1P0eyPLu9ihNBDbYtQ
lVI2zMwmyk6i3Y1548McMuI+MMbiyzFfUYoUtsLUPL7waIesMYp+KkJvpSlKiF2x
6zTMv2Wo7U/1E1W3f2aEUQh1RG+OfqJy0LThXVJZryUVGzQQZ7hXZ+BS+tJMQdZH
qDwGAhIjBn4duXKCI8V1QiIl7DcqM8O70bqjnVYqPg9/BqOAJ73/f6GnQrhv3YOa
7rdGLzStMaD3Lufa+Gc0MgeyN+/hIt/8Gei1zTyXjau471gD+gNF9QZ51EIysmcn
JnGDckLmu+c=
=7MbM
-----END PGP SIGNATURE-----

Closed
?