(address . guix-patches@gnu.org)(name . Karl Hallsby)(address . karl@hallsby.com)
* gnu/pcakages/java.scm: Add -XX:+UseParallelGC to generated wrapper scripts
for TLA+'s binary tools.
TLA+'s tools request (and throw a warning message) when you invoke them
without Java's parallel GC flag. Including this flag removes the warning
message and should improve performance (theoretically).
Change-Id: I12f7432db21db31ae2b0b30cc7f41f4a6af58b0a
---
gnu/packages/java.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
Toggle diff (25 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index c43231dcb6..63acc11abe 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2024 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2024 Raven Hallsby <karl@hallsby.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -14447,7 +14448,7 @@ (define-public tla2tools
(display
(string-append
"#!/bin/sh\n"
- java " -cp " java-cp " " class " \"$@\""))))
+ java " -XX:+UseParallelGC " " -cp " java-cp " " class " \"$@\""))))
(chmod file #o755)))))
;; bin/wrapper . java-class
'(("pcal" . "pcal.trans")
base-commit: e2ba93373a29ddf5d5754368957e89f3b426bb0a
--
2.41.0