[PATCH] gnu: nss/fixed: Tweak performance test.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Christopher Baines
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 1 May 11:41 +0200
(address . guix-patches@gnu.org)
26a7162056587eb3c5855e6d35e70c15b9fb72cc.1714556505.git.mail@cbaines.net
As I'm seeing this test fail with results of 5 to 7 seconds.

* gnu/packages/nss.scm (nss/fixed)[arguments]: Tweak a test to have a higher
time threshold.

Change-Id: Icb0551cd986acf67b2ba17dc8772a67b9747d31a
---
gnu/packages/nss.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 162e748094..60bc4d52de 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -280,6 +280,14 @@ (define-public nss/fixed
(setenv "USE_IP" "TRUE")
(setenv "IP_ADDRESS" "127.0.0.1")
+ ;; This specific test is looking at performance "now
+ ;; verify that we can quickly dump a database", and
+ ;; we're not testing performance here (especially
+ ;; since we're using faketime), so raise the
+ ;; threshold
+ (substitute* "tests/dbtests/dbtests.sh"
+ ((" -lt 5") " -lt 50"))
+
;; The "PayPalEE.cert" certificate expires every six months,
;; leading to test failures:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To

base-commit: 7d4ae2fca723114fb1df56de33b82177fbc4d0a6
--
2.41.0
C
C
Christopher Baines wrote on 1 May 11:51 +0200
[PATCH v2] gnu: nss/fixed: Tweak performance test.
(address . 70693@debbugs.gnu.org)
df3f8e708890db3ba960082d90dc8f8f8d4931e8.1714557075.git.mail@cbaines.net
As I'm seeing this test fail with results of 5 to 7 seconds.

* gnu/packages/nss.scm (nss/fixed)[arguments]: Tweak a test to have a higher
time threshold.

Change-Id: Icb0551cd986acf67b2ba17dc8772a67b9747d31a
---
gnu/packages/nss.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 162e748094..80bf627583 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -280,6 +280,14 @@ (define-public nss/fixed
(setenv "USE_IP" "TRUE")
(setenv "IP_ADDRESS" "127.0.0.1")
+ ;; This specific test is looking at performance "now
+ ;; verify that we can quickly dump a database", and
+ ;; we're not testing performance here (especially
+ ;; since we're using faketime), so raise the
+ ;; threshold
+ (substitute* "nss/tests/dbtests/dbtests.sh"
+ ((" -lt 5") " -lt 50"))
+
;; The "PayPalEE.cert" certificate expires every six months,
;; leading to test failures:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To

base-commit: 7d4ae2fca723114fb1df56de33b82177fbc4d0a6
--
2.41.0
M
M
Maxim Cournoyer wrote on 1 May 18:32 +0200
(name . Christopher Baines)(address . mail@cbaines.net)(address . 70693@debbugs.gnu.org)
871q6l8pd4.fsf@gmail.com
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (7 lines)
> As I'm seeing this test fail with results of 5 to 7 seconds.
>
> * gnu/packages/nss.scm (nss/fixed)[arguments]: Tweak a test to have a higher
> time threshold.
>
> Change-Id: Icb0551cd986acf67b2ba17dc8772a67b9747d31a

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
L
L
Ludovic Courtès wrote on 2 May 10:16 +0200
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
87ikzw1vdx.fsf@gnu.org
Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

Toggle quote (11 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> As I'm seeing this test fail with results of 5 to 7 seconds.
>>
>> * gnu/packages/nss.scm (nss/fixed)[arguments]: Tweak a test to have a higher
>> time threshold.
>>
>> Change-Id: Icb0551cd986acf67b2ba17dc8772a67b9747d31a
>
> Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

+1!

Not immediately related but Christina submitted patches to make nss
reproducible and to upgrade it that we should look into while we’re at
it:


Ludo’.
C
C
Christopher Baines wrote on 7 May 21:45 +0200
[PATCH v2 2/3] gnu: Add po4a-minimal.
(address . 70693@debbugs.gnu.org)
be6d275a1a45d831adb0129755a991606b54dcdc.1715111123.git.mail@cbaines.net
The main reason is to avoid the texlive-updmap.cfg input indirectly pulling in
nss, which has a very time consuming testsuite.

* gnu/packages/gettext.scm (po4a-minimal): New variable.

Change-Id: If8d46a18a02e57d5427852e8e122de01f970ded4
---
gnu/packages/gettext.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 1408cc4cb4..27212e3574 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -317,3 +317,16 @@ (define-public po4a
more interestingly, the maintenance of translations) using gettext tools on
areas where they were not expected like documentation.")
(license gpl2+)))
+
+(define-public po4a-minimal
+ (package/inherit po4a
+ (native-inputs
+ ;; Remove test dependencies
+ (modify-inputs (package-native-inputs po4a)
+ (delete "docbook-xml")
+ (delete "perl-test-pod")
+ (delete "texlive-updmap.cfg")))
+ (arguments
+ (substitute-keyword-arguments (package-arguments po4a)
+ ((#:tests? _ #t) #f)))
+ (properties '((hidden? . #t)))))
--
2.41.0
C
C
Christopher Baines wrote on 7 May 21:45 +0200
[PATCH v2 1/3] gnu: nss/fixed: Tweak performance test.
(address . 70693@debbugs.gnu.org)
86386e3f8cd94c44ac685abb9b722d746d22177a.1715111123.git.mail@cbaines.net
As I'm seeing this test fail with results of 5 to 7 seconds.

* gnu/packages/nss.scm (nss/fixed)[arguments]: Tweak a test to have a higher
time threshold.

Change-Id: Icb0551cd986acf67b2ba17dc8772a67b9747d31a
---
gnu/packages/nss.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 162e748094..80bf627583 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -280,6 +280,14 @@ (define-public nss/fixed
(setenv "USE_IP" "TRUE")
(setenv "IP_ADDRESS" "127.0.0.1")
+ ;; This specific test is looking at performance "now
+ ;; verify that we can quickly dump a database", and
+ ;; we're not testing performance here (especially
+ ;; since we're using faketime), so raise the
+ ;; threshold
+ (substitute* "nss/tests/dbtests/dbtests.sh"
+ ((" -lt 5") " -lt 50"))
+
;; The "PayPalEE.cert" certificate expires every six months,
;; leading to test failures:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To

base-commit: 014875b29e68da6357a5323e6dd1eaa74a05b753
--
2.41.0
C
C
Christopher Baines wrote on 7 May 21:45 +0200
[PATCH v2 3/3] Use po4a-minimal for guix.
(address . 70693@debbugs.gnu.org)
426f2432592afe22d59d9952f0078a20c9b18a4d.1715111123.git.mail@cbaines.net
As this avoids the indirect dependency on nss, which has a testsuite that
takes a long time to run.

* gnu/packages/package-management.scm (guix)[native-inputs]: Use po4a-minimal.
* guix/self.scm (%packages, translate-texi-manuals): Use po4a-minimal.

Change-Id: Iac7555cc850c1618d3d54f1b290faa4f9cfb4f8a
---
gnu/packages/package-management.scm | 2 +-
guix/self.scm | 8 ++++----
2 files changed, 5 insertions(+), 5 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index faa1a75aa0..631cbe1009 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -493,7 +493,7 @@ (define-public guix
("graphviz" ,graphviz-minimal)
("font-ghostscript" ,font-ghostscript) ;fonts for 'dot'
("help2man" ,help2man)
- ("po4a" ,po4a)))
+ ("po4a" ,po4a-minimal)))
(inputs
`(("bzip2" ,bzip2)
("gzip" ,gzip)
diff --git a/guix/self.scm b/guix/self.scm
index 19c6d08e01..8c85684090 100644
--- a/guix/self.scm
+++ b/guix/self.scm
@@ -71,7 +71,7 @@ (define %packages
("bzip2" . ,(ref 'compression 'bzip2))
("xz" . ,(ref 'compression 'xz))
("git-minimal" . ,(ref 'version-control 'git-minimal))
- ("po4a" . ,(ref 'gettext 'po4a))
+ ("po4a-minimal" . ,(ref 'gettext 'po4a-minimal))
("gettext-minimal" . ,(ref 'gettext 'gettext-minimal))
("gcc-toolchain" . ,(ref 'commencement 'gcc-toolchain))
("glibc-utf8-locales" . ,(delay
@@ -291,8 +291,8 @@ (define* (locale-data source domain
(define (translate-texi-manuals source)
"Return the translated texinfo manuals built from SOURCE."
- (define po4a
- (specification->package "po4a"))
+ (define po4a-minimal
+ (specification->package "po4a-minimal"))
(define gettext-minimal
(specification->package "gettext-minimal"))
@@ -317,7 +317,7 @@ (define (translate-texi-manuals source)
(define (translate-tmp-texi po source output)
"Translate Texinfo file SOURCE using messages from PO, and write
the result to OUTPUT."
- (invoke #+(file-append po4a "/bin/po4a-translate")
+ (invoke #+(file-append po4a-minimal "/bin/po4a-translate")
"-M" "UTF-8" "-L" "UTF-8" "-k" "0" "-f" "texinfo"
"-m" source "-p" po "-l" output))
--
2.41.0
C
C
Christopher Baines wrote on 7 May 21:53 +0200
Re: [bug#70693] [PATCH v2] gnu: nss/fixed: Tweak performance test.
(name . Ludovic Courtès)(address . ludo@gnu.org)
871q6dh000.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (21 lines)
> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:
>
>> Christopher Baines <mail@cbaines.net> writes:
>>
>>> As I'm seeing this test fail with results of 5 to 7 seconds.
>>>
>>> * gnu/packages/nss.scm (nss/fixed)[arguments]: Tweak a test to have a higher
>>> time threshold.
>>>
>>> Change-Id: Icb0551cd986acf67b2ba17dc8772a67b9747d31a
>>
>> Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>
>
> +1!
>
> Not immediately related but Christina submitted patches to make nss
> reproducible and to upgrade it that we should look into while we’re at
> it:
>
> https://issues.guix.gnu.org/40316

I haven't got around to looking at that, but the data service failed to
process the v1 patch, the job timed out after 72 hours.

I don't think that necessarily means that patch hasn't worked, it's just
that we needed to build nss (because grafts, see #61363) to compute the
guix derivation for each system. As Ludo pointed out to me on IRC
though, that can probably be avoided so I've sent a v2 series that
includes a couple of patches to remove the link between guix and nss via
packages needed for the po4a tests.

Lets see if this gets further and we hopefully see how nss builds on
different systems.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmY6hr9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdpDw/+N9XLGDR7XrKw1ocpj6ucqnTYbUZ9OQhk
+ndqiymCU+gRWTzd4pLIbOU7+KvcbFTesVUDv7fc8Pz8plrbl9dp/15ApxlGatUk
jmFelaBwe8kc31neSQCcuUZo+xvQlzcz04kj7Zv6P1nkrmGpSFUfJ0ePYakOYzLb
7xo9NYkUr/OQB28ICc6kuPNERvGPXE7Eq9RcBPU+3Sp8uj9V97FYUgOw+Xwv6gpE
JtQ+Ig1HWGpiEt5cEg7zoueLGDkJboDWhWprsqbiRwL5Ue8Zwnou+2KWsm8Q22hZ
JL3GT/zq2xdweVH8B5BBt0vXCwOFzVIB6HkBcZTIQtXwY/whJVUIYlOoYlX8bOsa
L15r8vYwyS5ydW9GV/4aIBr7AN3RdPbnashTtLBMML9507/TxITvy5U8BxyupNEF
99CIhV2ARuT7uWro82qrB9tADE2cBc8S55CKyfK4AoHhQ092UZACgEB+5KDwUX7B
kWz+fldSWhI2vvQaFVg4kHaTW3aU/C6qJ2FwXonsWl8eLmITG2ZC7QdyYGH3U2F8
my+feIbIrancupp/XKAJqgbccnJ6MQlxSTxPoFAruLQgLuWTzJIbc6iabop8nQla
DtFavDLaNCJ2e16Ki9nUALqiF0J6uEs1osYRQSyFLnGcwdW2R9GK/w5NSu+doFPZ
NxzkqBU7nLE=
=NByG
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 9 May 16:09 +0200
Re: [bug#70693] [PATCH v2 3/3] Use po4a-minimal for guix.
(name . Christopher Baines)(address . mail@cbaines.net)
87ikzn3wmx.fsf@gnu.org
Hi,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (8 lines)
> As this avoids the indirect dependency on nss, which has a testsuite that
> takes a long time to run.
>
> * gnu/packages/package-management.scm (guix)[native-inputs]: Use po4a-minimal.
> * guix/self.scm (%packages, translate-texi-manuals): Use po4a-minimal.
>
> Change-Id: Iac7555cc850c1618d3d54f1b290faa4f9cfb4f8a

LGTM, thanks!

Ludo’.
L
L
Ludovic Courtès wrote on 9 May 16:11 +0200
Re: [bug#70693] [PATCH v2 2/3] gnu: Add po4a-minimal.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 70693@debbugs.gnu.org)
87edab3wim.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (7 lines)
> The main reason is to avoid the texlive-updmap.cfg input indirectly pulling in
> nss, which has a very time consuming testsuite.
>
> * gnu/packages/gettext.scm (po4a-minimal): New variable.
>
> Change-Id: If8d46a18a02e57d5427852e8e122de01f970ded4

[...]

Toggle quote (5 lines)
> +(define-public po4a-minimal
> + (package/inherit po4a
> + (native-inputs
> + ;; Remove test dependencies

Maybe add: “, primarily to reduce the size of the dependency graph of the
‘guix’ package.”

Toggle quote (5 lines)
> + (modify-inputs (package-native-inputs po4a)
> + (delete "docbook-xml")
> + (delete "perl-test-pod")
> + (delete "texlive-updmap.cfg")))

This can be: (delete "docbook-xml" "perl-test-pod" "texlive-updmap.cfg").

Otherwise LGTM!

Ludo’.
L
L
Ludovic Courtès wrote on 9 May 16:13 +0200
Re: [bug#70693] [PATCH v2] gnu: nss/fixed: Tweak performance test.
(name . Christopher Baines)(address . mail@cbaines.net)
87a5kz3wfq.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (7 lines)
> I don't think that necessarily means that patch hasn't worked, it's just
> that we needed to build nss (because grafts, see #61363) to compute the
> guix derivation for each system. As Ludo pointed out to me on IRC
> though, that can probably be avoided so I've sent a v2 series that
> includes a couple of patches to remove the link between guix and nss via
> packages needed for the po4a tests.

It would still make sense to apply the initial patch here, IMO.

Also, we could create an ‘nss-upgrade’ branch to remove the graft and
upgrade ‘nss’, also applying the reproducibility patches that Christina
posted.

WDYT?

Thanks,
Ludo’.
C
C
Christopher Baines wrote on 9 May 16:35 +0200
[PATCH v3 1/3] gnu: nss/fixed: Tweak performance test.
(address . 70693@debbugs.gnu.org)
e18f8abc59798e33072b959b3ccb8e60111d630b.1715265342.git.mail@cbaines.net
As I'm seeing this test fail with results of 5 to 7 seconds.

* gnu/packages/nss.scm (nss/fixed)[arguments]: Tweak a test to have a higher
time threshold.

Change-Id: Icb0551cd986acf67b2ba17dc8772a67b9747d31a
---
gnu/packages/nss.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 162e748094..80bf627583 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -280,6 +280,14 @@ (define-public nss/fixed
(setenv "USE_IP" "TRUE")
(setenv "IP_ADDRESS" "127.0.0.1")
+ ;; This specific test is looking at performance "now
+ ;; verify that we can quickly dump a database", and
+ ;; we're not testing performance here (especially
+ ;; since we're using faketime), so raise the
+ ;; threshold
+ (substitute* "nss/tests/dbtests/dbtests.sh"
+ ((" -lt 5") " -lt 50"))
+
;; The "PayPalEE.cert" certificate expires every six months,
;; leading to test failures:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To

base-commit: cf5f7a8bf9ca2288700fcf351bbca0fc341ec969
--
2.41.0
C
C
Christopher Baines wrote on 9 May 16:35 +0200
[PATCH v3 2/3] gnu: Add po4a-minimal.
(address . 70693@debbugs.gnu.org)
3a9488a476a1cb365892f433342360d7dff776c7.1715265342.git.mail@cbaines.net
The main reason is to avoid the texlive-updmap.cfg input indirectly pulling in
nss, which has a very time consuming testsuite.

* gnu/packages/gettext.scm (po4a-minimal): New variable.

Change-Id: If8d46a18a02e57d5427852e8e122de01f970ded4
---
gnu/packages/gettext.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 1408cc4cb4..31fe95f6ad 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -317,3 +317,15 @@ (define-public po4a
more interestingly, the maintenance of translations) using gettext tools on
areas where they were not expected like documentation.")
(license gpl2+)))
+
+(define-public po4a-minimal
+ (package/inherit po4a
+ (native-inputs
+ ;; Remove test dependencies, primarily to reduce the size of the
+ ;; dependency graph of the ‘guix’ package.
+ (modify-inputs (package-native-inputs po4a)
+ (delete "docbook-xml" "perl-test-pod" "texlive-updmap.cfg")))
+ (arguments
+ (substitute-keyword-arguments (package-arguments po4a)
+ ((#:tests? _ #t) #f)))
+ (properties '((hidden? . #t)))))
--
2.41.0
C
C
Christopher Baines wrote on 9 May 16:35 +0200
[PATCH v3 3/3] Use po4a-minimal for guix.
(address . 70693@debbugs.gnu.org)
3e8a5857a16857bd0c48243ead1a49cfc1827df1.1715265342.git.mail@cbaines.net
As this avoids the indirect dependency on nss, which has a testsuite that
takes a long time to run.

* gnu/packages/package-management.scm (guix)[native-inputs]: Use po4a-minimal.
* guix/self.scm (%packages, translate-texi-manuals): Use po4a-minimal.

Change-Id: Iac7555cc850c1618d3d54f1b290faa4f9cfb4f8a
---
gnu/packages/package-management.scm | 2 +-
guix/self.scm | 8 ++++----
2 files changed, 5 insertions(+), 5 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index faa1a75aa0..631cbe1009 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -493,7 +493,7 @@ (define-public guix
("graphviz" ,graphviz-minimal)
("font-ghostscript" ,font-ghostscript) ;fonts for 'dot'
("help2man" ,help2man)
- ("po4a" ,po4a)))
+ ("po4a" ,po4a-minimal)))
(inputs
`(("bzip2" ,bzip2)
("gzip" ,gzip)
diff --git a/guix/self.scm b/guix/self.scm
index 19c6d08e01..8c85684090 100644
--- a/guix/self.scm
+++ b/guix/self.scm
@@ -71,7 +71,7 @@ (define %packages
("bzip2" . ,(ref 'compression 'bzip2))
("xz" . ,(ref 'compression 'xz))
("git-minimal" . ,(ref 'version-control 'git-minimal))
- ("po4a" . ,(ref 'gettext 'po4a))
+ ("po4a-minimal" . ,(ref 'gettext 'po4a-minimal))
("gettext-minimal" . ,(ref 'gettext 'gettext-minimal))
("gcc-toolchain" . ,(ref 'commencement 'gcc-toolchain))
("glibc-utf8-locales" . ,(delay
@@ -291,8 +291,8 @@ (define* (locale-data source domain
(define (translate-texi-manuals source)
"Return the translated texinfo manuals built from SOURCE."
- (define po4a
- (specification->package "po4a"))
+ (define po4a-minimal
+ (specification->package "po4a-minimal"))
(define gettext-minimal
(specification->package "gettext-minimal"))
@@ -317,7 +317,7 @@ (define (translate-texi-manuals source)
(define (translate-tmp-texi po source output)
"Translate Texinfo file SOURCE using messages from PO, and write
the result to OUTPUT."
- (invoke #+(file-append po4a "/bin/po4a-translate")
+ (invoke #+(file-append po4a-minimal "/bin/po4a-translate")
"-M" "UTF-8" "-L" "UTF-8" "-k" "0" "-f" "texinfo"
"-m" source "-p" po "-l" output))
--
2.41.0
C
C
Christopher Baines wrote on 9 May 16:36 +0200
Re: [bug#70693] [PATCH v2 2/3] gnu: Add po4a-minimal.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 70693@debbugs.gnu.org)
87ttj7dpcv.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (26 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> The main reason is to avoid the texlive-updmap.cfg input indirectly pulling in
>> nss, which has a very time consuming testsuite.
>>
>> * gnu/packages/gettext.scm (po4a-minimal): New variable.
>>
>> Change-Id: If8d46a18a02e57d5427852e8e122de01f970ded4
>
> [...]
>
>> +(define-public po4a-minimal
>> + (package/inherit po4a
>> + (native-inputs
>> + ;; Remove test dependencies
>
> Maybe add: “, primarily to reduce the size of the dependency graph of the
> ‘guix’ package.”
>
>> + (modify-inputs (package-native-inputs po4a)
>> + (delete "docbook-xml")
>> + (delete "perl-test-pod")
>> + (delete "texlive-updmap.cfg")))
>
> This can be: (delete "docbook-xml" "perl-test-pod" "texlive-updmap.cfg").

I've sent a v3 with these changes now.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmY832BfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfmihAAr+YApHYC9qIlg6S6nTRxEI5sxqLCkJPL
NNJ1UzrnFTYNHdK7wM899D3Os+iqfTcYDsWAVzcgJpVEz8vum+tiqm/e9HxC2BQG
kMsIb8XReer1CGh4qOuEIpJ3BcnBiPHT9+dx2Z4vI1CKI9I2ikQ50PPgOgbiFH/d
l3LyVupzzem5GY/vZ26bmwURZms2gg633kZmYPL8NTL8+pnGuSpfvqCggzQ/S0Pk
Hssw9POETVVy9kqnVPaGYP2QsQKdbhr7AM8yzEiUtdX8VNOGf9DCrJAcDA6EbJOl
GNaDWK/HGe5v3Lf9NxfkPqiQPGWDONi/7Lh2Fy9UyG+R5CmK3sf3U34iP85w2nF/
9wSTCMsk6epdM+3NgwNPBpa47uRZVKRkR6iVUbzfh9weJ0YoXAr/+YgJXQlJL0C+
l1rhSUaeqw8tOdxXb7chgsjnUAg93weAEiEuGnCjKDGAIIDlvtmYjD3ltc1D+Y5i
p87zMAak2d/mv2nf0YWGlPpr3H+e8kUqvgKavtbDklQuOP8SCMHW8JBHJsZdHGs9
3FeYjlpKe8RdZ/NbpCxxNSzjftQOX2wHlG3Gn/lswW1/RZkVvzevW/ExGMX9i8bN
QVfl90Seu7S5rnikyzVRz0mzMBcxsKIP+COvO7JxdahXRTY/gA2i7vdczQSxrguQ
99KXkomoN74=
=dCuW
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 9 May 16:52 +0200
Re: [bug#70693] [PATCH v2] gnu: nss/fixed: Tweak performance test.
(name . Ludovic Courtès)(address . ludo@gnu.org)
87o79fdomg.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (11 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> I don't think that necessarily means that patch hasn't worked, it's just
>> that we needed to build nss (because grafts, see #61363) to compute the
>> guix derivation for each system. As Ludo pointed out to me on IRC
>> though, that can probably be avoided so I've sent a v2 series that
>> includes a couple of patches to remove the link between guix and nss via
>> packages needed for the po4a tests.
>
> It would still make sense to apply the initial patch here, IMO.

Personally I'm waiting for QA to build things since I want to see if
this does fix nss on the 4 systems it's currently broken on, and so that
there's substitutes available if and when this is merged.

The large number of builds recently on the master branch might delay
this though.

Toggle quote (6 lines)
> Also, we could create an ‘nss-upgrade’ branch to remove the graft and
> upgrade ‘nss’, also applying the reproducibility patches that Christina
> posted.
>
> WDYT?

I don't mind, if it doesn't happen on core-updates then that seems like
an OK approach.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmY84xdfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xcakw/9FALuj5QhUQ9yIRlN8AaO3t91bqZzlnzQ
+75O7Q1R2awStzCPPGQNMBwDW6CHjV6N/yeTASxAswznWAJvAjjnx7FwsmSymELo
WPUsf58MR7Ydj53yAxkNj4gj3PK96+OvZWzFGGDoQeWmwOw4eTYMOAUZQdr+W678
BscIOMYjjYiyl5SbH/Xx6YhOiO/FHseUOp9VctoOuZ9/XOtIq97SRTVBFuEPPmje
oneMA52f9G1bW0eSgWaP5EgzrSSeLvm9xdQlqIqGqInoUIeBcgqES+p1GSIRng5H
lXvq+Dfr8dzSp9CU9QUJKi0Aq8ySXqXbTuNv6tnv7e4ag9l34yP63LJKFK3i0WZW
n0w4IFq3OOhS3+IeuBTRwQm1n8JkIkSJa97QdWNQdn7ut9gHY8nDukEQU6hCBREz
B+zW4Soj9KqpNy/nxlTfjRek2ZfuW3UCRSg9chhM8yJo0YltjclrIyy1JMCWAq3l
+BYtSg/P3xsZN7Y7RdRdkff84vpfmWzC6+TkzkgIJO5dNPQRCU5ggrWFoE/KPqmy
6tCt7cy3tsNZQqR5O0ID5rz5yEjXgx+UuKr757fc8wuPzAduWxxUwmrRB183NuQg
uZxmTCHdKGEMdCGAgNojsx4FPntM2a/Gd8cE3lSVjkrRqjbz5X1wy0JUkn9wwrZd
rRhiX2QgX6U=
=6PCI
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 13 May 10:58 +0200
Re: [bug#70693] [PATCH v3 1/3] gnu: nss/fixed: Tweak performance test.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 70693@debbugs.gnu.org)
87h6f2dr5m.fsf@gnu.org
Hi!

LGTM to me, please push!

Ludo’.
C
C
Christopher Baines wrote on 13 May 14:44 +0200
(address . 70693-done@debbugs.gnu.org)
871q6551ay.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (4 lines)
> Hi!
>
> LGTM to me, please push!

Things are building, so I've pushed this to master as
7b0f145802f0c2c785014293d748721678fef824.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmZCCyVfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeszRAAisnYuHCeq7G+tqoZHdAUlbyp3T07CWKd
eFQQE9a6Cv8f6yNlV0RM+5+B/yzlEyc9sES4exYskN1cwz4FEUuq2iUK+jNMLFw3
LZOQ3Agmdor0/qlOqVeF22HKR41Q86OoL5xlWr16ns/8hFNX9nXjwcPhyqsbhguW
IFqu2ygtRKwk5FAk01k86w/FY1gIWb7Z/u29gsOJOTYTsh4hKIS/9aA96mG67LtT
aWJB9G1pT0sCoCqm16oRGRY+RLUwbGSl8smj7nndUSONnDy7fmLXhE1V2mGPUsKz
RoSAjnZ1mC2i2ShBbP+TIIFCDr3LLsqbt7tK1RfOfEjv2Fvg8lrv31JExvtcLt/0
Y7GF/XkLyxXnYnH/Ci34DhGnt3ivhUKFXX0V2q6RCYV4xBFqA5aQBoFnjKmaX2Ay
R+9YlIBz7CkhCT4gi9HS0GmyW8I9dQM9J5YwMvDrHxMrPzZVMAj+1REYAGy7Wnbs
q7/z2AZyqdhYqSuwF+KVDAiCvKwVK5xNz4O8wFlqfhmw2WLJY3dLRTkKJjMZNZde
zDkKUAcKVJS2IFvB5CF8mPJdCsuEvbYjuyu2ldL13rdMqjLZrjvRpiLADz8zRi1R
dthPA/xfYnf2vCSfAJo/2QhoDAO8skTnGt0YkmbFVObaq4bBLHKLTvQtnpqN8XF0
Qz4A3zV1cD0=
=7Ju+
-----END PGP SIGNATURE-----

Closed
?