[PATCH] gnu: Add python-overpass.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Wilko Meyer
Owner
unassigned
Submitted by
Wilko Meyer
Severity
normal
W
W
Wilko Meyer wrote on 30 Apr 21:47 +0200
(address . guix-patches@gnu.org)
c7d31cd7dcad61991810a541cc29c210f7599690.1714506457.git.w@wmeyer.eu
* gnu/packages/geo.scm (python-overpass): New variable.
* gnu/packages/geo.scm: Add copyright.

Change-Id: Icd7a66ec6acd2e213bfd6920a1d71c1e0e815695
---

Hi Guix,

this patch adds python-overpass, a python wrapper for the OSM overpass
API. I had to disable tests as they all rely on network
functionality/on being able to talk to a web API.

gnu/packages/geo.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 985fa77231..6ab2312385 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2022 Roman Scherer <roman.scherer@burningswell.com>
;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -986,6 +987,30 @@ (define-public python-geopandas
require a spatial database such as PostGIS.")
(license license:bsd-3)))
+(define-public python-overpass
+ (package
+ (name "python-overpass")
+ (version "0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "overpass" version))
+ (sha256
+ (base32 "0l2n01j0vslag8cf3sp7jif0d4ql6i99fvfv2mgc3ajws69aqzr6"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; tests disabled, as they require network
+ (list #:tests? #f))
+ (propagated-inputs (list python-geojson
+ python-requests
+ python-shapely))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/mvexel/overpass-api-python-wrapper")
+ (synopsis "Python wrapper for the OpenStreetMap Overpass API")
+ (description "This package provides python-overpass, a Python wrapper
+for the @code{OpenStreetMap} Overpass API.")
+ (license license:asl2.0)))
+
(define-public python-ogr2osm
(package
(name "python-ogr2osm")

base-commit: 6effb89fc401cf34505aeef1833f10100311e7c7
prerequisite-patch-id: 689bdf5170b3bf27aac818d97108eef8213dad6b
--
2.41.0
A
A
Andreas Enge wrote 7 days ago
(name . Wilko Meyer)(address . w@wmeyer.eu)
ZkEONDnVwmSttlMT@jurong
Hello,

I have just pushed your patch, thanks a lot!

Am Tue, Apr 30, 2024 at 09:47:37PM +0200 schrieb Wilko Meyer:
Toggle quote (3 lines)
> * gnu/packages/geo.scm (python-overpass): New variable.
> * gnu/packages/geo.scm: Add copyright.

The second line is not needed. And if you have two changes in the
same file, there would not be a need to repeat the "* path/to/file" part.

Andreas
Closed
?