* gnu/packages/graphics.scm (materialx): New variable.
Change-Id: I62c6a1675114611f23287068148171a44fa30a42
---
gnu/packages/graphics.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)
Toggle diff (48 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index fcf3999f24..cd7dbf2dbe 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1354,6 +1354,41 @@ (define-public openimageio
(home-page "https://www.openimageio.org")
(license license:bsd-3)))
+(define-public materialx
+ (package
+ (name "materialx")
+ (version "1.38.9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AcademySoftwareFoundation/MaterialX")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "190xkg1q1sr9d95rq8rim6cxzlg2safki9i9zjsjw9wwv2bl95wr"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-DBUILD_SHARED_LIBS=ON")
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke
+ "ctest" "-E"
+ "MaterialXTest_Render_GLSL_TestSuite")))))))
+ (inputs
+ (list libglvnd libx11 libxt))
+ (home-page "https://materialx.org/")
+ (synopsis
+ "Standard for the exchange of rich material and look-development content")
+ (description "MaterialX is an open standard for representing rich material
+and look-development content in computer graphics, enabling its
+platform-independent description and exchange across applications and
+renderers.")
+ (license license:asl2.0)))
+
(define-public openscenegraph
(package
(name "openscenegraph")
--
2.39.2