(address . guix-patches@gnu.org)(name . Richard Sent)(address . richard@freakingpenguin.com)
* doc/guix.texi: Mention that make clean may need to be run before running
make check-system when previous builds were run with different work trees. See
Change-Id: I39d465961637d9fc6b11f59e1500770220780b4c
---
Hi Guix!
Ran into this issue myself. It seems common enough to be worth
mentioning in the docs, similar to the message in (guix) Building from
Git.
I found my solution from https://issues.guix.gnu.org/47573.
Toggle quote (5 lines)
> If you get an error like this one:
>
> configure.ac:46: error: possibly undefined macro: PKG_CHECK_MODULES
doc/guix.texi | 17 +++++++++++++++++
1 file changed, 17 insertions(+)
Toggle diff (32 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index ef9e4216b4..72cac183a5 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -1177,6 +1177,23 @@ Running the Test Suite
substitutes are available for their dependencies (@pxref{Substitutes}).
Some of them require a lot of storage space to hold VM images.
+If you encounter an error like this one:
+
+@example
+Compiling Scheme modules...
+ice-9/eval.scm:142:16: In procedure compile-top-call:
+error: all-system-tests: unbound variable
+hint: Did you forget `(use-modules (gnu tests))'?
+@end example
+
+@noindent
+there may be inconsistency in the work tree from previous builds. Try
+running:
+
+@example
+make clean && make
+@end example
+
Again in case of test failures, please send @email{bug-guix@@gnu.org}
all the details.
base-commit: ade6845da6cec99f3bca46faac9b2bad6877817e
--
2.41.0