[PATCH] home: services: add newline to XDG_RUNTIME_DIR warning

  • Done
  • quality assurance status badge
Details
4 participants
  • Attila Lendvai
  • Hilton Chain
  • Fabio Natali
  • Richard Sent
Owner
unassigned
Submitted by
Richard Sent
Severity
normal
R
R
Richard Sent wrote on 30 Mar 02:10 +0100
(address . guix-patches@gnu.org)(name . Richard Sent)(address . richard@freakingpenguin.com)
06b44aeb449a5335f12e1a4774d8a3222d87bf8c.1711761035.git.richard@freakingpenguin.com
* gnu/home/services.scm: Add end-of-text newline to warning printed by
on-first-login script when XDG_RUNTIME_DIR does not exist.

Change-Id: I3bfe2c415f6941fa9a2231ab2a0be53db965053f
---
Without this change, the prompt will be pushed to the side by the
warning message. Other warnings in the repo follow this convention, so
I assume this one should as well.

gnu/home/services.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/home/services.scm b/gnu/home/services.scm
index b69cd91203..39c9033ad6 100644
--- a/gnu/home/services.scm
+++ b/gnu/home/services.scm
@@ -445,7 +445,7 @@ (define (compute-on-first-login-script _ gexps)
(warning (G_ "XDG_RUNTIME_DIR doesn't exists, on-first-login script
won't execute anything. You can check if xdg runtime directory exists,
XDG_RUNTIME_DIR variable is set to appropriate value and manually execute the
-script by running '$HOME/.guix-home/on-first-login'"))))))))
+script by running '$HOME/.guix-home/on-first-login'~%"))))))))
(define (on-first-login-script-entry on-first-login)
"Return, as a monadic value, an entry for the on-first-login script

base-commit: d67e4f0f9b10c7ddac8fb0ca68cbf1d6ad0a6e5d
--
2.41.0
F
F
Fabio Natali wrote on 8 Aug 20:04 +0200
"Review" and gentle bump of 70085
(address . 70085@debbugs.gnu.org)
87ikwayjpx.fsf@fabionatali.com
Thanks Richard.

This is more of a bump rather than a review as the change itself is a
pretty obvious.

For what it's worth, I confirm I double-checked the change locally (as I
was accidentally experiencing the "XDG_RUNTIME_DIR doesn't exists"
warning).

All looks good, if someone with commit rights wants to give a final look
and push, that'd be cool.

Thanks, cheers, Fabio.
A
A
Attila Lendvai wrote on 28 Sep 19:36 +0200
a less gentle reminder...
(name . 70085@debbugs.gnu.org)(address . 70085@debbugs.gnu.org)
YDnNK2YEYMZIqjja6jd7spxwLeaHBwWXh_YXV7Yh_LXWB_UxXo0PHlRnLaheypQbvpk4yDCETmyANdPI4nEwWqDMQubPjnXmfApZHxen9Ag=@lendvai.name
it took a few hours of my life to find out that this is the reason my emacs tramp cannot connect to my servers all of a sudden.

and this rather straightforward fix is all the way back from march!

could someone please push this finally?

sidenote for another issue: why is my user missing its $XDG_RUNTIME_DIR ? its value is /run/user/1000, but that dir doesn't exist.

my ssh server is dropbear, i switched away from openssh after their last blunder. maybe that is the root cause of the warning?

--
• attila lendvai
• PGP: 963F 5D5F 45C7 DFCD 0A39
--
“Discipline must come through liberty. […] We do not consider an individual disciplined only when he has been rendered as artificially silent as a mute and as immovable as a paralytic. He is an individual annihilated, not disciplined.”
— Maria Montessori (1870–1952), 'The Montessori Method'
H
H
Hilton Chain wrote on 29 Sep 16:40 +0200
(name . Attila Lendvai)(address . attila@lendvai.name)(name . 70085@debbugs.gnu.org)(address . 70085@debbugs.gnu.org)
87cykmjzfs.wl-hako@ultrarare.space
On Sun, 29 Sep 2024 01:36:23 +0800,
Attila Lendvai wrote:
Toggle quote (5 lines)
>
> sidenote for another issue: why is my user missing its $XDG_RUNTIME_DIR ? its value is /run/user/1000, but that dir doesn't exist.
>
> my ssh server is dropbear, i switched away from openssh after their last blunder. maybe that is the root cause of the warning?

I suppose the directory should be created by elogind or greetd?
H
H
Hilton Chain wrote on 29 Sep 16:38 +0200
Re: [bug#70085] [PATCH] home: services: add newline to XDG_RUNTIME_DIR warning
(name . Richard Sent)(address . richard@freakingpenguin.com)
87ed52jzj3.wl-hako@ultrarare.space
Hi everyone,

On Sat, 30 Mar 2024 09:10:35 +0800,
Richard Sent wrote:
Toggle quote (13 lines)
>
> * gnu/home/services.scm: Add end-of-text newline to warning printed by
> on-first-login script when XDG_RUNTIME_DIR does not exist.
>
> Change-Id: I3bfe2c415f6941fa9a2231ab2a0be53db965053f
> ---
> Without this change, the prompt will be pushed to the side by the
> warning message. Other warnings in the repo follow this convention, so
> I assume this one should as well.
>
> gnu/home/services.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)

Applied as cbf46d2565112180fe7b316b2530293ed2d3acf3, thanks!
Closed
A
A
Attila Lendvai wrote on 30 Sep 09:47 +0200
Re: [bug#70085] a less gentle reminder...
(name . Hilton Chain)(address . hako@ultrarare.space)(name . 70085@debbugs.gnu.org)(address . 70085@debbugs.gnu.org)
U7hCdMSNMkRdP5cJTwFDi4ZOc-w3VA4IOBmMa4d3QltWpdASwNM3EmGrpndbRMOws0GaSuz22S6H-NSHOMBGc42mApvN7mqyIuVlkb9TBvI=@lendvai.name
Toggle quote (8 lines)
> > sidenote for another issue: why is my user missing its $XDG_RUNTIME_DIR ? its value is /run/user/1000, but that dir doesn't exist.
> >
> > my ssh server is dropbear, i switched away from openssh after their last blunder. maybe that is the root cause of the warning?
>
>
> I suppose the directory should be created by elogind or greetd?


i have no idea about the login infrastructure.

with that in mind: i have a suspicion that dropbear lacks some integration (PAM?) that invokes the login services you mentioned above. or maybe it doesn't define some env variable that openssh does?

these machines are used as servers to which i log in through ssh (i.e. no logins through the local console).

i'll search around and i'll open a new issue if i cannot resolve this.

--
• attila lendvai
• PGP: 963F 5D5F 45C7 DFCD 0A39
--
“It is by logic that we prove, but by intuition that we discover.”
— Henri Poincaré (1854–1912)
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70085@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70085
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch