(address . guix-patches@gnu.org)(name . Richard Sent)(address . richard@freakingpenguin.com)
* gnu/home/services.scm: Add end-of-text newline to warning printed by
on-first-login script when XDG_RUNTIME_DIR does not exist.
Change-Id: I3bfe2c415f6941fa9a2231ab2a0be53db965053f
---
Without this change, the prompt will be pushed to the side by the
warning message. Other warnings in the repo follow this convention, so
I assume this one should as well.
gnu/home/services.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Toggle diff (17 lines)
diff --git a/gnu/home/services.scm b/gnu/home/services.scm
index b69cd91203..39c9033ad6 100644
--- a/gnu/home/services.scm
+++ b/gnu/home/services.scm
@@ -445,7 +445,7 @@ (define (compute-on-first-login-script _ gexps)
(warning (G_ "XDG_RUNTIME_DIR doesn't exists, on-first-login script
won't execute anything. You can check if xdg runtime directory exists,
XDG_RUNTIME_DIR variable is set to appropriate value and manually execute the
-script by running '$HOME/.guix-home/on-first-login'"))))))))
+script by running '$HOME/.guix-home/on-first-login'~%"))))))))
(define (on-first-login-script-entry on-first-login)
"Return, as a monadic value, an entry for the on-first-login script
base-commit: d67e4f0f9b10c7ddac8fb0ca68cbf1d6ad0a6e5d
--
2.41.0