* gnu/packages/backup.scm (borgmatic): Update to 1.8.6.
[inputs]: Add python-apprise.
Change-Id: I4daed9554eec0117cecccc74325cc1b4b75aa7b2
---
gnu/packages/backup.scm | 61 +++++++++++++++++++++--------------------
1 file changed, 32 insertions(+), 29 deletions(-)
Toggle diff (81 lines)
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 3126464347..2c9bc4034d 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -1304,42 +1304,45 @@ (define-public disarchive
(define-public borgmatic
(package
(name "borgmatic")
- (version "1.7.12")
+ (version "1.8.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "borgmatic" version))
(sha256
- (base32 "0720wvs3h2w8h28d7mpvjfp0q37dnrwf1y2ik3y4yr9csih7fmgh"))))
+ (base32 "14bngfhfzlrqjhqw059gr6mggz84nr97b3y7y8nj53431jwrfpas"))))
(build-system python-build-system)
(arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'configure
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Set absolute store path to borg.
- (substitute* "borgmatic/commands/borgmatic.py"
- (("\\.get\\('local_path', 'borg'\\)")
- (string-append ".get('local_path', '"
- (search-input-file inputs "bin/borg")
- "')")))
- (substitute* "tests/unit/commands/test_borgmatic.py"
- (("(module.get_local_path.+ == )'borg'" all start)
- (string-append start "'"
- (search-input-file inputs "bin/borg")
- "'")))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; Tests require the installed executable.
- (setenv "PATH" (string-append #$output "/bin"
- ":" (getenv "PATH")))
- (invoke "pytest")))))))
- (inputs
- (list borg python-colorama python-jsonschema python-requests
- python-ruamel.yaml))
- (native-inputs
- (list python-flexmock python-pytest python-pytest-cov))
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Set absolute store path to borg.
+ (substitute* "borgmatic/commands/borgmatic.py"
+ (("\\.get\\('local_path', 'borg'\\)")
+ (string-append ".get('local_path', '"
+ (search-input-file inputs "bin/borg")
+ "')")))
+ (substitute* "tests/unit/commands/test_borgmatic.py"
+ (("(module.get_local_path.+ == )'borg'" all start)
+ (string-append start "'"
+ (search-input-file inputs "bin/borg")
+ "'")))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Tests require the installed executable.
+ (setenv "PATH"
+ (string-append #$output "/bin" ":"
+ (getenv "PATH")))
+ (invoke "pytest")))))))
+ (inputs (list borg
+ python-colorama
+ python-jsonschema
+ python-requests
+ python-ruamel.yaml
+ python-apprise))
+ (native-inputs (list python-flexmock python-pytest python-pytest-cov))
(home-page "https://torsion.org/borgmatic/")
(synopsis "Simple, configuration-driven backup software")
(description
--
2.41.0